¿Cómo hago para que el complemento de Java funcione en Google Chrome?

62

Google ha actualizado su navegador Chrome a la versión 35. Esta nueva versión usa Aura en lugar de GTK2 y ya no admite complementos NPAPI como Java (tanto OpenJDK como Oracle) . Los complementos de PPAPI como PepperFlash aún funcionan.

Mi escuela utiliza Google Chrome y las aplicaciones de Google todos los días y esto parece un problema potencialmente grave para algunos de los sitios web educativos que utilizamos. ¿Alguien ha encontrado una solución o solución alternativa para que Java funcione?

Este artículo de WEB UPD8 confirma que Java no funciona .

    
pregunta HarlemSquirrel 22.05.2014 - 12:02

2 respuestas

56

No puede hacer que Java funcione en Chrome 35. Es debido a la eliminación del plugin anterior NPAPI. He planteado un informe de error. En espera de una respuesta adecuada de los desarrolladores. El informe de error está aquí: enlace . Puede intentar y seguir el hilo de esta discusión aquí: enlace

ACTUALIZAR Parece que vamos a estar estancados aquí por bastante tiempo. El informe de mi error se fusionó con el error principal y se configuró como no se corregirá. Aquí está: enlace

ACTUALIZACIÓN2 Una pregunta relevante fue publicada en Oracle. No hay mucha tracción. Ustedes pueden comenzar una discusión sobre ese hilo. Vaya aquí: enlace

Para todos ustedes: para mantener el funcionamiento de Chrome, baje su GOogle Chrome a 34. Puede descargar el deb aquí: enlace . Luego use el administrador de paquetes sinápticos o use la línea de comandos para bloquear las actualizaciones del paquete google-chrome-stable. Chrome 34 no tiene ningún error evidente, por lo que puede usarlo de forma segura durante los próximos 3 meses. Espero que para ese momento se agregue algún parche.

    
respondido por el Ubuntuser 22.05.2014 - 18:38
2

Usted PUEDE hacer que Java funcione en Chrome, o al menos habilitar el complemento NPAPI para ello ... temporalmente. La opción se eliminará por completo en Chrome 45. (Actualmente estamos en 43, la estimación es septiembre de 2015).

Tenga en cuenta que habilitar NPAPI no necesariamente significa que el Applet de Java funcionará ... Lo intenté con uno y no fue así. Es probable que esto se deba a que tiene instalada la última versión de Java, lo que prácticamente bloquea cualquier acceso web. Lo cual es una pena, ya que se han creado tantos ingeniosos servicios web mejorados en Java (como enlace ).

En cualquier caso, la opción de habilitar NPAPI se encuentra al navegar a:

chrome://flags/#enable-npapi

Nuevamente, su millaje puede variar (YMMV).

    
respondido por el rdtsc 15.06.2015 - 15:46

Lea otras preguntas en las etiquetas