¿El escritorio olvida el tema?

78

Estoy ejecutando Ubuntu en VirtualBox (en un host de Windows 7). Varias veces, la barra de menú de nivel superior, la barra de tareas y, aparentemente, todos los cuadros de diálogo del sistema, han olvidado el tema de "Ambiente" de fábrica con el que se ajustan cuando instalé el sistema por primera vez. Los títulos de las ventanas aún conservan el tema, pero prácticamente nada más lo hace.

He buscado alto y bajo en Google para obtener ayuda con este problema. Todo lo que he encontrado sugiere ejecutar algún reinicio de gconf o eliminar .gconf * .gnome * y otros directorios similares. He seguido todos estos consejos y nada funciona. Todavía me da un aburrido aspecto y sensación 3D gris estilo Windows-95. En ocasiones anteriores, después de mucho perder el tiempo, me di por vencida y reinicié la instancia de VM, y me sorprendió gratamente ver que el tema original de "Ambience" se restauraba a través de la interfaz de usuario, pero invariablemente desaparece después, generalmente después de reiniciar, así que nunca puedo imaginar lo que hice que lo rompió.

Aquí hay una muestra del sitio de Ubuntu de cómo quiero que se vea.

Y aquí hay una captura de pantalla de mi sistema tal como se ve actualmente.

También tenga en cuenta que mis terminales GNOME normalmente tienen un bonito aspecto semitranslúcido de color púrpura, y como se puede ver en la captura de pantalla, ahora son solo un sólido blanco mate.

Esta última vez (ayer), probar numerosas combinaciones de todos los trucos habituales y reiniciar varias veces no lo ha solucionado, así que aquí estoy en SU ​​preguntándome:

¿Cómo recupero el tema de fábrica de mi escritorio Gnome / Ubuntu, y advierto que omitir todos los archivos de configuración, como se sugiere en muchos lugares en línea, no lo logra?

Puede ser útil saber que parece fallar, ya sea después de cambiar el tamaño de la instancia de VM, forzar el tamaño del escritorio de Ubuntu para cambiar el tamaño, o después de jugar con la configuración de Compiz. No he podido averiguar cuál de estos es y no podría ser ninguno de los dos. Dada la cantidad de dolor que he tenido que pasar para que las cosas vuelvan a la normalidad (y dado que no sé cómo hacerlo), ha resultado difícil aislar definitivamente la causa.

    
pregunta Marcelo Cantos 13.01.2011 - 02:09

15 respuestas

45

@ zpletan's answer lleva a un poco de caza alrededor, que rápidamente desenterró lo que parece ser la causa de mi problema. Se detalla en Ubuntu Error # 574296 . En resumen, mi sistema Core i7 con SSD inicia todo con sincronizaciones suficientemente diferentes que gnome-settings-daemon se ejecuta demasiado pronto, se libera y me deja principalmente con un tema stock GTK.

Un breve descanso en /etc/xdg/autostart/gnome-settings-daemon.desktop lo soluciona:

Exec= bash -c "sleep 2; /usr/lib/gnome-settings-daemon/gnome-settings-daemon"
    
respondido por el Marcelo Cantos 17.01.2011 - 02:34
22

No pude solucionar este problema con ninguna de las respuestas sugeridas (la respuesta actualmente aceptada funcionaba esporádicamente, pero generalmente no funcionaba para mí). Intenté aumentar mucho el tiempo de sueño y todavía no funcionaba de manera consistente.

Sin embargo, una de las respuestas apuntó a un error que rastrea este problema, y ​​encontré un comentario sobre el error que lo resolvió para mí.

Aquí están los bits clave:

Primero, crea un script bash (lo llamé /etc/xdg/autostart/gnomesettingsdaemonfix.sh )

#!/bin/bash

pid=$(pgrep gnome-settings-)

while [ -n "$pid" ];
do
  pid=$(pgrep gnome-settings-)
  sleep 0
done

exit 0

Asegúrate de que sea ejecutable (ejecuta chmod +x ).

Luego edita /etc/xdg/autostart/gnome-settings-daemon.desktop

Cambia la línea Exec a:

Exec=bash -c '/etc/xdg/autostart/gnomesettingsdaemonfix.sh;/usr/lib/gnome-settings-daemon/gnome-settings-daemon'

Eso parece haberlo solucionado hasta ahora para mí.

    
respondido por el TM. 15.05.2011 - 21:49
16

Presione Alt + F2 (Ejecutar aplicación) y ejecute lo siguiente:

gksudo gnome-settings-daemon
    
respondido por el zpletan 14.01.2011 - 12:13
7

10.10 tiene este problema, pero normalmente sucede cuando instala el controlador patentado de nvidia. Sin embargo, la solución probablemente también funcione en una máquina virtual.

Crea un archivo de texto. Escribir en él

include "/usr/share/themes/Ambiance/gtk-2.0/gtkrc"
gtk-icon-theme-name = "ubuntu-mono-dark"

y guárdelo en su carpeta de inicio con el nombre .gtkrc-2.0. Reiniciar.

Si todavía hay elementos incorrectos (para mí fue la fuente), necesita agregar este cambio al archivo, google para obtener un tutorial de gtk para las posibles mejoras.

    
respondido por el rumtscho 13.01.2011 - 07:55
4

He estado buscando una solución para este problema durante meses. Aparentemente, nadie sabe qué lo causa. Este error ha existido durante años y nadie lo ha solucionado.

A veces ocurre durante el arranque con una condición de carrera entre la primera y la segunda instancia de gnome-settings-daemon, y algunas veces sucede en el medio de una sesión de escritorio en funcionamiento cuando gnome-settings-daemon deja de funcionar o falla.

La única solución que he encontrado que parece solucionarlo es escribir

killall gnome-settings-daemon
gnome-settings-daemon &

en una terminal en funcionamiento que dejo abierta.

Al cerrar el terminal, se elimina la instancia de fondo de gnome-settings-daemon y el escritorio vuelve al tema predeterminado (no por defecto de Ubuntu, sino que por defecto es gnome). Por lo tanto, ejecuto el daemon en segundo plano y dejo la terminal ejecutándose también porque el proceso necesita su padre.

    
respondido por el Cheryl 23.01.2012 - 13:10
4

Tuve el mismo problema y recibí un error en la mendicidad: Could not apply the stored configuration for monitors.

Se eliminó el archivo: ~/.config/monitors.xml volvió a registrarse y funcionó como un guante.

    
respondido por el topless 12.10.2011 - 19:08
2

Tengo el mismo problema, sudo killall nautilus lo soluciona. (temporalmente)

    
respondido por el Pit 14.01.2011 - 08:12
1

Lo siento, pero mi sugerencia anterior de usar '--sync' no es una solución. Resulta que después de algunos reinicios, el problema es el mismo.

Pero, con suerte, logré capturar el siguiente resultado del proceso "gnome-settings-daemon" que se cuelga durante las startups cuando el tema no se puede aplicar:

** (gnome-settings-daemon:1679): WARNING **: You can only run one xsettings manager at a time; exiting

** (gnome-settings-daemon:1679): WARNING **: Unable to start xsettings manager: Could not initialize xsettings manager.

Cuando el tema se aplica con éxito, no hay salida.

A partir de esto, parece que gnome-settings-daemon podría ejecutarse dos veces de alguna manera. Aparentemente, si la primera instancia se completa antes de que se ejecute la segunda instancia, se aplicará el tema, de lo contrario fallará.

NOTA: La captura de salida se realizó editando /etc/xdg/autostart/gnome-settings-daemon.desktop's 'Exec =' entrada a "bash -c '/ usr / lib / gnome-settings-daemon / gnome- settings-daemon --debug --sync & amp; & gt; /home/sanjeev/Desktop/test.txt '"(la opción --sync se usó como recomiendan algunos sitios web)

PD: pruebas adicionales, muestran que, de hecho, hay dos ejecuciones de instancias que deben ejecutarse una tras otra.

Aunque el método de "dormir" podría funcionar, aquí hay una solución más "técnicamente correcta", si se me permite, al problema. Lo intenté con 6 reinicios y parece que funciona lo siguiente:

Paso 1: Cree un script (lo llamé gnome-settings-daemon-fix.sh) en / etc / xdg / autostart con lo siguiente:

#!/bin/bash
# gnome-settings-daemon-fix.sh

pid='pgrep gnome-settings-'
wait pid

exit 0

Paso 2: edite 'gnome-settings-daemon.desktop' en la entrada 'Exec =' y reemplácelo por:

Exec=bash -c 'bash /etc/xdg/autostart/gnome-settings-daemon-fix.sh ;/usr/lib/gnome-settings-daemon/gnome-settings-daemon'

Todo está hecho. Básicamente, lo que estamos haciendo es esperar que la primera instancia salga antes de que se lance la segunda. ¿Alguien podría notificar si esto solucionó su problema?

    
respondido por el Sanjeev 27.03.2011 - 23:33
1

También tuve un problema muy similar. Esto fue después de una actualización (IIRC parcial) de mi Natty Narwhal ya que estaba en estado alpha 3. En mi caso, el archivo ~ / michael / .nautilus / browser.xml parecía estar dañado. Después de probar algunas de las sugerencias de este sitio parcial, simplemente eliminé este archivo, reinicié mi PC y todos mis temas volvieron y se mantuvieron estables. Creo que puedes intentar resolver tu problema como yo.

    
respondido por el Michael Staengl 08.05.2011 - 08:23
1

Esto me sucede de vez en cuando con 11.04 Unity 3D y cada vez que lo borré abriendo Apariencia, botón Personalizar, pestaña Ícono y haciendo clic en el conjunto de Íconos elegido aunque esté indicado como en uso. En mi caso, eso sería Faenza-Dark. Sucede tan infrecuentemente que aún no he identificado ninguna secuencia de eventos que cause esto.

    
respondido por el fragos 28.08.2011 - 20:58
1

Esto funcionó para mí en una ventana de terminal:

echo "PATH=\"/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games\"" | tee -a ~/.profile
    
respondido por el user10655 08.07.2011 - 03:43
1

Aquí hay una solución rápida, vaya a su consola virtual, pare gdm, inicie el servidor X

  1. presione "Ctrl + F1 a la derecha" (Ctrl + Alt + F1 es una combinación para instalaciones no virtualizadas)
  2. inicie sesión
  3. tipo: sudo /etc/init.d/gdm stop
  4. tipo: startx

ya que esta es mi primera publicación, tuve que poner imágenes como esta:

enlace

    
respondido por el nidla 09.11.2011 - 09:18
1

Esto también me sucedió a mí y, en mi caso, tuve que destruir todo mi directorio personal y luego restaurar partes y piezas, por la respuesta aquí . Si está haciendo los scripts de tiempo para gnome-settings-daemon, vea si puede hacer que funcione correctamente creando otra cuenta e iniciando sesión como esa cuenta. En mi caso, la segunda cuenta no tenía el problema de no inicio y, por lo tanto, apliqué la corrección en el enlace.

    
respondido por el mfisch 12.12.2011 - 06:41
0

Por favor, intente esto y reinicie! :)

gconftool-2 --shutdown        
rm -rf ~/.gconf/apps/panel       
pkill gnome-panel        
    
respondido por el Iván Stojanovic 13.01.2011 - 02:20
0

Creo que hay bastantes personas con la idea correcta.

Supongo que después de ciertas actualizaciones (kernels nuevos, etc.) se vuelve a perfilar ureadahead. Aquí es donde creo que ocurre el problema. gnome-settings-daemon se llama demasiado pronto.

Eliminé todos los archivos con 'paquete' (paquete, home.pack, boot.pack, run.pack) en el nombre en / var / lib / ureadahead / folder para forzar un nuevo perfil. Todo se veía genial después de eso.

Al volver a perfilar, elimine los archivos anteriores, reinicie e inicie sesión rápidamente tan pronto como vea la pantalla de inicio de sesión. Espere unos 30 segundos o cuando el disco deje de girar antes de hacer cualquier cosa. Deja que termine su negocio. Su ventana nautilus debería verse bien ahora.

Tal vez un error se deba archivar con ureadahead para poner gnome-settings-daemon fuera de servicio.

    
respondido por el user32089 10.04.2012 - 07:50

Lea otras preguntas en las etiquetas