El teclado se bloquea en IntelliJ IDEA en Ubuntu 14.04

165

¿Podrías ayudarme con un asunto extraño? Uso Intellij IDEA 13 en Ubuntu 14.04, y de vez en cuando mi teclado completamente (sí, completamente, no se trata de accesos directos) se bloquea en IDEA. Todavía puedo hacer cualquier cosa que quiera en IDEA con mi mouse, también puedo usar el teclado en cualquier otro lugar excepto IDEA. Y solo se puede solucionar reiniciando IDEA hasta el momento.

¿Alguien puede dar una pista, por favor?

    
pregunta Treble Snake 24.07.2014 - 06:58

4 respuestas

206

Hay un problema abierto en jetbrains youtrack para intellij idea que recomienda dos soluciones:

  1. La entrada del teclado se puede desbloquear reiniciando el daemon IBus desde una consola:

    ibus-daemon -rd
    
  2. IBus se puede desactivar para IDEA al desactivar env. variable XMODIFIERS, pero se perderá la capacidad de ingresar caracteres nacionales en IDEA:

    XMODIFIERS="" idea.sh
    

Utilicé el segundo y solucioné mi problema.

    
respondido por el Saeed Zarinfam 18.10.2014 - 16:50
14

Pude resolverlo con lo que encontré aquí que básicamente agrega export XMODIFIERS="" en idea.sh

    
respondido por el Alfergon 05.03.2015 - 16:45
5

Para una solución permanente , la actualización 01/01/2015 sobre el problema recomienda a:

Actualice IBus a la versión 1.5.11 o agregue export IBUS_ENABLE_SYNC_MODE=1 a su ~/.profile , luego reinicie una sesión.

Alternativamente, puedes desactivar IBus en System Settings | Language Support | Keyboard input method .

IDEA 15 mostrará una advertencia si una versión incompatible de IBus está en uso.

    
respondido por el Alex 30.11.2015 - 11:53
1

Lo probé y está funcionando hasta ahora, pero lo actualizaré si se congela nuevamente. He visto una sugerencia en youtrack que sugiere apagar iBus, lo que parece interferir particularmente debido a su uso del acceso directo ctrl + space para cambiar la configuración del idioma. Puede hacerlo yendo a:

soporte de idioma & gt; sistema de método de entrada de teclado & gt; ninguno

**** ACTUALIZACIÓN *****

Después de ejecutarlo por un tiempo, esta técnica aún no funcionaba ya que seguí congelando. Supongo que por ahora me atengo a la siguiente solución alternativa para reiniciar ibus, que es un poco incómodo, pero ¿qué se puede hacer?

ir a la terminal

tipo:

ibus-daemon -rd
    
respondido por el ThinkBonobo 05.04.2015 - 00:33

Lea otras preguntas en las etiquetas