Inicio lento - "se está ejecutando un trabajo de inicio para dev-disk-by ..."

74

No recuerdo cuándo se produjo el problema, pero es probable cuando cambié mi imagen de Ubuntu VMWare a una SSD externa para poder usar el sistema operativo en cualquiera de mis PC. No hay muchos enlaces en Google sobre el tema, pero los que aparecen hablan de fstab. Por ejemplo .

Menciona tener que eliminar la partición de intercambio y volver a crearla.

Puedo intentar hacer esto con Gparted, pero mi principal preocupación es perder mi configuración actual en Ubuntu, ya que no estoy completamente seguro de lo que sucederá si me meto con el intercambio como se sugiere en el hilo. ¿Alguien capaz de ayudar?

Captura de pantalla

    
pregunta cpd1 18.12.2015 - 21:45

9 respuestas

81

Si obtiene "un trabajo de inicio iniciado por dev-disk-by ..." seguido de un retraso de 90 segundos durante cada inicio, complete los siguientes pasos:

  1. Instale gparted utilizando el Centro de software
  2. Abra gparted y vea qué particiones usa actualmente Ubuntu
  3. Edite el archivo fstab usando la línea siguiente.

    sudo -H gedit /etc/fstab
    
  4. Encuentra el dispositivo que no estás usando actualmente

  5. Inserta un # y un espacio al principio de esa línea coméntelo.

  6. Restablecer, ¡espero que te sirva!

respondido por el William MacDonald 04.04.2016 - 07:06
28

Parece que el problema se debió al hecho de que, aunque fstab tenía una entrada para un intercambio, en realidad no había ninguno. Utilicé GParted para cambiar el tamaño de la partición y creé un nuevo Swap. Luego copié el UUID en el archivo fstab ...

  1. Ahora tengo intercambio
  2. Y el arranque se ha reducido en segundos frente a más de 90 segundos
respondido por el cpd1 31.12.2015 - 02:56
20

Tuve el mismo problema después de cambiar el tamaño de mi partición primaria en mi VM, ya que gparted live me obligó a eliminar & amp; reiniciar mi intercambio para hacerlo. Eso causó que se estableciera un nuevo UUID que no coincidía con el archivo fstab.

Para evitar el problema, en /etc/fstab puede

  • Reemplace el UUID de intercambio con el nuevo (ejecute sudo blkid para encontrarlo) después del cambio de tamaño de la partición primaria.

  • O bien, comente la partición de intercambio antes (o después) del cambio de tamaño de la partición primaria.

Recomendaría el primero ya que es la forma en que se configurará el sistema operativo.

    
respondido por el Matthew Cordaro 09.08.2016 - 20:24
12

En mi caso, anteriormente había estado usando swap cifrado, y el trabajo de inicio mencionó /dev/mapper/cryptswap1 . Para resolver el problema, también tuve que eliminar el archivo /etc/crypttab , además de los pasos descritos en la respuesta de William MacDonald.

    
respondido por el Kalle Elmér 28.09.2016 - 13:40
3

Al redimensionar o eliminar particiones con gparted, a menudo tiene que crear una nueva partición de intercambio.

Luego, es necesario activar el intercambio a través de gparted después de su creación (existe el comando "Activar intercambio").

Además, debe copiar el nuevo UUID en / etc / fstab para montarlo; de lo contrario, al arrancar, el sistema operativo intentará encontrarlo pero será en vano porque el archivo fstab contiene el UUID que hace referencia al antiguo intercambio. Gparted ofrece la información para el UUID pero puede ejecutarla fácilmente en la terminal:

sudo blkid

para encontrarlo.

    
respondido por el Alessandro D'lncal 01.09.2016 - 19:09
2

Tuve el mismo problema al arrancar.

En mi archivo /etc/fstab , mis particiones se definieron como /dev/sda1 , /dev/sda2 , etc., pero al arrancar aparecieron varias veces el mensaje " Se está ejecutando un trabajo de inicio para dev-sdx "(" x "define qué unidad o partición se vio afectada).

Para resolverlo, cambié el valor de /dev/sdx por el UUID de la partición. Para ver el UUID, desde la ejecución del terminal lsblk -f . Luego, copie el UUID de la partición afectada y escríbalo en /etc/fstab file, reemplazando /dev/sdax de la siguiente manera: /dev/sda1 cambia a UUID=xxxxxxxxxxxxxxxxxx .

Me funcionó, espero que esta información sea útil.

    
respondido por el Lord Ferm 23.04.2017 - 11:30
1

Mi arranque se ralentizó porque cambié mi disco y el UUID no coincidía. Esto causó que Ubuntu hiciera un escaneo durante el arranque.

Con frecuencia cambio unidades. Si tus montajes están siempre en el mismo lugar (como el mío), puedes eliminar el UUID y colocar la ruta directa para evitar que ocurra ese error de escaneo ...

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/sda1 /               ext4    errors=remount-ro 0       1
/dev/sda2 none            swap    sw              0       0
    
respondido por el Dan 25.01.2017 - 19:43
1

Puede omitir la espera e ir directamente a la pantalla de inicio de sesión utilizando ' Ctrl + c ' y luego trabajar en la solución. A veces esto continuará para siempre si no.

    
respondido por el Ramon Suarez 27.02.2017 - 12:55
0

Además de verificar /etc/fstab o /etc/crypttab como se menciona en las otras respuestas, también verifique los UUID provenientes de los parámetros del kernel en /etc/default/grub . Por un tiempo, estaba muy confundido por un sistema que tenía un /etc/fstab perfectamente cromático, solo para descubrir un parámetro del kernel resume=… en la configuración de GRUB.

    
respondido por el Random Poster 03.07.2018 - 16:03

Lea otras preguntas en las etiquetas