Virtualbox no ve ningún dispositivo usb en la configuración de filtros usb

62

Estaba siguiendo esta pregunta pero encontré un problema. Usar mi webcam con Ubuntu ejecutándose en VirtualBox

Utilicé guvcview para probar la cámara, funciona. Instalé el lanzamiento de 12.04 virtualbox desde su sitio web e instalé el paquete de extensión. Pero cuando hago clic en el usb con el signo más verde, dice que no hay dispositivos disponibles.

    
pregunta Alex 25.10.2013 - 22:25

8 respuestas

99

Esto puede ayudarlo a acceder a los dispositivos USB en su sistema operativo invitado alojado en Ubuntu

Primero instala dkms :

  • sudo apt-get install dkms

Siguiente instalación Gnome-System-Tools

  • sudo apt-get install gnome-system-tools

Ahora inicie la aplicación - Usuarios y grupos . Si está utilizando la unidad, puede hacerlo tocando la tecla Súper y escribiendo usuario, luego haga clic en el icono Usuarios y grupos para iniciar la Configuración del usuario.

Haga clic en Administrar grupos , busque vboxusers , haga clic en Propiedades, agregue su propio nombre de usuario y cualquier otro usuario deseado a los vboxusers grupo . Haga clic en Aceptar.

A continuación, deberá cerrar la sesión ( sudo restart lightdm si está utilizando este DM) y volver a ingresar. Ahora inicie VirtualBox y continúe agregando los dispositivos USB.

    
respondido por el precise 08.11.2013 - 06:37
49

Este comando agregará su cuenta al grupo de usuarios de vbox. Le permitirá a su VirtualBox detectar unidades flash USB.

sudo usermod -G vboxusers -a $USER

$USER value es tu nombre de usuario. Puedes verlo con echo $USER

$ whoami
foo
$ echo $USER
foo

También puede reemplazar $USER por su nombre de usuario de Casa.

Luego cierre la sesión o reinicie su computadora y VirtualBox ahora detectará dispositivos USB.

Fuentes:
Documentación de Virtualbox en Ubuntu (francés)
VirtualBox / USB - Wiki de ayuda de la comunidad (inglés)

    
respondido por el Artegor 11.11.2013 - 15:11
5

Debería ser suficiente para ejecutar

sudo gedit /etc/group

luego encuentra la línea vboxusers y agrégale tu nombre de usuario final.

Después de este reinicio se sugiere, pero cerrar sesión o kill -9 -1 e iniciar sesión debería ser suficiente.

    
respondido por el kcpr 21.07.2014 - 15:16
2

Tuve el mismo problema con Linux Mint 17 (Ubuntu 14.04) usando la versión estándar de distribución 4.3.20. gnome-system-tools y dkms ya estaban instalados pero open-vm-dkms no. Hice esto:

sudo apt-get install open-vm-dkms

Después de reiniciar, pude ver los dispositivos USB. El paquete también existe en Ubuntu 12.04 y 14.04, así que supongo que también funcionaría allí.

¿Podría ser un problema de dependencia?

    
respondido por el Gannet 09.12.2014 - 23:31
1

Después de haberse agregado al grupo vboxusers :

sudo gpasswd -a $USER vboxusers

Si, naturalmente, no desea que cierre la sesión o se reinicie por los motivos que sean, puede ejecutar VirtualBox con un grupo efectivo forzado:

sg vboxusers virtualbox

Esto debería ser innecesariamente después del próximo reinicio.

    
respondido por el sanmai 31.01.2017 - 05:21
0

Prueba esto. Una vez en VirtualBox, haga clic en Dispositivos - & gt; Dispositivos USB - & gt; haga clic en su dispositivo USB deseado. ¿Ves el dispositivo deseado?

    
respondido por el Mitch 26.10.2013 - 08:58
0

Tengo Ubuntu 14.04 Lts. Instalado 5.0.8 versión de Oracle Vm y ext. paquete. Intenté todas las soluciones anteriores. No podía ver mis dispositivos usb. Reduje la versión de Oracle VM virtualbox y el paquete de extensión a 4.3.32 y funcionó. Estoy desactualizado, pero al menos funciona.

    
respondido por el Makis 08.11.2015 - 22:56
0

Mi solución fue simple ...

Tuve este problema hoy, y creo que fue porque ignoré una advertencia de instalación sobre la ejecución de algún servicio de virtualbox. Tuve que reiniciar mi host, pero luego el USB se rompió, lo que me trajo aquí.

Reinstalé Virtualbox desde cero, lo eliminé por completo usando "Programas y características", y luego lo instalé nuevamente.

Ahora que el USB funciona correctamente, tengo dispositivos que aparecen. Sin embargo, tuve que desconectar y volver a conectar uno de mis dispositivos para que funcione en el cliente.

    
respondido por el Mike 19.02.2016 - 15:34

Lea otras preguntas en las etiquetas