Las redes inalámbricas no funcionan después de reanudar en Ubuntu 14.04

78

[Actualización]:
El mismo problema existe en Kubuntu y se resuelve de la misma manera.
[Solucionado]:
Al aplicar el siguiente comando nmcli nm obtuve lo siguiente:

Antes de suspender

RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN      
running         connected       enabled         enabled    enabled         enabled  

como puede ver, el estado está conectado y el resto están habilitados y en ejecución

Después de suspender

RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN      
running         asleep          enabled         enabled    enabled         disabled

como puede ver, el estado está dormido, lo que significa que nuestro querido administrador de red todavía está durmiendo la siesta, así que para resolver use la siguiente línea de comando:
sudo nmcli nm sleep false
esto le dice al administrador de red que se despierte. para hacer este permanente:
cree un script en /etc/pm/sleep.d que contenga lo siguiente (y no olvide marcar el script como ejecutable):

#!/bin/sh

case "" in
        resume|thaw)
        nmcli nm sleep false
                ;;
esac

Gracias a this

El problema original:

Acabo de descargar Ubuntu 14.04 e instalado en mi computadora portátil: ASUS X61SL con procesador Intel P8400 Core2Duo x64.
Cuando cierro la tapa, el sistema se suspende, pero cuando abro la tapa y reanudo, la red inalámbrica no se activa (la conexión en red está deshabilitada) y cuando selecciono "Habilitar red" no ocurre nada.
Esta es la información sobre mi adaptador inalámbrico:

$ lspci | grep -i wireless
02:00.0 Network controller: Qualcomm Atheros AR928X Wireless Network Adapter (PCI-Express) (rev 01)  

Este problema no estaba presente en Ubuntu 13.04, Linux Mint Debian Edition o Debian 7 wheezy (GNOME o KDE).

Editar: pocas pruebas con los siguientes resultados:
El problema afecta a mi red inalámbrica y por cable.
Nota: Necesito agregar la línea pci=nomsi a grub para iniciar.
Al cerrar la sesión manualmente, suspender, reanudar y luego iniciar sesión, todo funciona bien.
Cuando se suspende directamente mientras está conectado, ocurre el problema.
Bloquear y suspender causa el mismo problema que suspender directamente.
Además, este problema aparentemente afecta a la función de cierre de sesión: si elige cerrar sesión en el menú de usuario en el panel de unidad, entonces no quiere cerrar la sesión, pero si utiliza la línea de comando gnome-session-quit --logout , puede cerrar la sesión.
Ahora con lshw -C network output:
Normal (red completamente funcional):

  *-network               
       description: Ethernet interface
       product: 191 Gigabit Ethernet Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: pci@0000:00:04.0
       logical name: eth0
       version: 02
       serial: 00:24:8c:1e:f8:53
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.4 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 memory:fddfcc00-fddfcc7f ioport:cc00(size=128)
  *-network
       description: Wireless interface
       product: AR928X Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:15:af:e2:13:db
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.13.0-24-generic firmware=N/A ip=6.6.6.8 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:fdff0000-fdffffff

Después del currículum ("/etc/pm/config.d" no contiene "descargue_modulos"):

 *-network DISABLED      
       description: Ethernet interface
       product: 191 Gigabit Ethernet Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: pci@0000:00:04.0
       logical name: eth0
       version: 02
       serial: 00:24:8c:1e:f8:53
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.4 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 memory:fddfcc00-fddfcc7f ioport:cc00(size=128)
  *-network DISABLED
       description: Wireless interface
       product: AR928X Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:15:af:e2:13:db
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.13.0-24-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:fdff0000-fdffffff

Cuando agregué el archivo unload_modules al directorio "/etc/pm/config.d" como lo sugería aquí , después de cerrar la sesión, suspender, reanudar e iniciar sesión, la red funciona pero no puedo conectarme a mi red inalámbrica.
Nuevamente el resultado de lshw -C network Después del currículum ("/etc/pm/config.d" contiene "descargue_modulos"):

 *-network DISABLED      
       description: Ethernet interface
       product: 191 Gigabit Ethernet Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: pci@0000:00:04.0
       logical name: eth0
       version: 02
       serial: 00:24:8c:1e:f8:53
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.4 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 memory:fddfcc00-fddfcc7f ioport:cc00(size=128)
  *-network DISABLED
       description: Wireless interface
       product: AR928X Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: 00:15:af:e2:13:db
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.13.0-24-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:fdff0000-fdffffff

El contenido de 'download_modules' donde:

SUSPEND_MODULES="$SUSPEND_MODULES ath9k"
SUSPEND_MODULES="$SUSPEND_MODULES sis190"

Donde 'ath9k' es mi módulo inalámbrico y 'sis190' es mi módulo Ethernet.

    
pregunta Ossama Nasser 22.04.2014 - 15:13

5 respuestas

27

Las respuestas anteriores no funcionaron para mí en 14.10. Después de un poco de prueba y error, terminé con esto,

#!/bin/sh

case "" in
  resume|thaw)
    nmcli r wifi off && nmcli r wifi on ;;
esac

Pon esto en /etc/pm/sleep.d/10_resume_wifi
Hazlo ejecutable sudo chmod 755 /etc/pm/sleep.d/10_resume_wifi y el problema debe arreglarse de inmediato.

    
respondido por el Owais Lone 13.04.2015 - 22:03
21

Recibí una solución, pero es solo para reiniciar tu administrador de red.

sudo service network-manager restart

No es la solución permanente.

    
respondido por el hmjha 20.03.2016 - 11:40
4

El guión que finalmente funcionó para mí:

$ cat /etc/pm/sleep.d/10_resume_wifi 
#!/bin/sh

case "" in
  resume|thaw) nmcli nm sleep false ;;
esac

$ ll /etc/pm/sleep.d/10_resume_wifi
-rwxr-xr-x 1 root root 70 mars  31 09:09 /etc/pm/sleep.d/10_resume_wifi

La otra respuesta tiene errores ortográficos (se pueden arreglar, lo sé), pero de todos modos nunca funcionó para mí.

    
respondido por el Augustin Riedinger 31.03.2015 - 09:21
0

Esto funcionó para mí en Ubuntu 14.04 en la computadora portátil Dell Precision.

En una terminal, ingrese:

sudo nano /etc/pm/sleep.d/10_resume_wifi

Luego pegue (ctrl + v):

#!/bin/sh
case "" in
resume|thaw)
    nmcli nm wifi on
    ;;
esac

Luego, haga que el script sea ejecutable:

sudo chmod +x /etc/pm/sleep.d/10_resume_wifi

Prueba a suspender y despertarte para ver el wifi encendido.

    
respondido por el FizxMike 15.05.2016 - 02:05
-3

Has intentado hacer que otro script como este ingrese en kate:

#/bin/sh

    case ![1] in
        ./bin/sh
        network="true"
        nmcli nm -c sleep=false -network
    endasc

y guárdalo como un archivo jsin7 en / etc / network, y llámalo network.d y esto podría funcionar bien.

    
respondido por el Michael 30.05.2014 - 11:45

Lea otras preguntas en las etiquetas