"Requiere instalación de paquetes que no son de confianza" mientras se actualiza con el administrador de actualizaciones

65

No solucionó el error. Entonces, ¿cómo arreglo la actualización de mi GUI?

Para cada software, tengo que instalarlo desde la línea de comandos porque tengo el mismo error cuando instalo el software desde el Centro de Software de Ubuntu.

    
pregunta One Zero 29.03.2012 - 13:55

7 respuestas

63
  1. Escribe en una terminal: sudo apt-get update && sudo apt-get upgrade o edita la configuración de Update Manager (prueba esto primero si ya has configurado Update Manager).

  2. Inicie Update Manager y vuelva a intentarlo.

La ejecución de la actualización a través de un terminal brinda la opción de permitir o no permitir paquetes que no sean de confianza.

WARNING: The following packages cannot be authenticated!
  playonlinux
Install these packages without verification [y/N]?

Si confía en el origen del paquete, escriba y .

    
respondido por el Zlatan 29.03.2012 - 19:14
43

Esto sucede debido a la falta de algunas teclas GPG. Para solucionar esto, abra un terminal y ejecute los siguientes comandos:

sudo apt-get update

Recibirá un error que indica que alguna clave pública no está disponible. Tenga en cuenta la cadena de teclas (después de NO_PUBKEY, por ejemplo: D6B6DB186A68F637)

 gpg --keyserver keyserver.ubuntu.com --recv XXXXX

Reemplace el XXXXX con la cadena de teclas

p. ej .: gpg --keyserver keyserver.ubuntu.com --recv D6B6DB186A68F637

gpg --export --armor  XXXXX | sudo apt-key add -

p. ej .: gpg --export --armor D6B6DB186A68F637 | sudo apt-key add -

sudo apt-get update

Ahora intenta actualizar tu sistema nuevamente.

Aquí hay una publicación similar: "Requiere instalar actualizaciones que no son de confianza" Error en Update Manager

Espero que esto ayude.

    
respondido por el aneeshep 01.12.2010 - 10:05
13

Puede instalarlo a través de la línea de comando: sudo apt-get install --allow-unauthenticated exiv2 .

Para "confiar" permanentemente en el repositorio, ejecuta esto: sudo apt-add-repository ppa:pmjdebruijn/darktable-release && sudo apt-get update . Creo que ese es el PPA que estás usando.

    
respondido por el evgeny 01.12.2010 - 10:12
5

En respuesta a su pregunta, no puede "corregir" la actualización de la GUI (es decir, el Administrador de actualizaciones), porque es evidente que esa aplicación no tiene actualmente la capacidad de instalar paquetes que no son de confianza. Si desea instalar paquetes que no son de confianza, debe hacerlo en la línea de comando.

Sin embargo, hay dos formas de evitar que Update Manager informe este error: elimine el software que no es de confianza de su sistema O confíe en el repositorio en cuestión, como se indica en la respuesta al otro pregunta ( Las actualizaciones no se instalan debido a "paquetes que no son de confianza" ) .

El primer paso es averiguar qué repositorio está causando el problema. Puede averiguarlo escribiendo apt-cache policy ambiance-colors en la línea de comando.

Sin embargo, un google rápido revela que ambiance-colors y radiance-colors son de ppa:ravefinity-project . Entonces, debería poder solucionar su problema escribiendo

sudo add-apt-repository ppa:ravefinity-project/ppa
sudo apt-get update
sudo apt-get install ambiance-colors radiance-colors

tomado de enlace

    
respondido por el stackex humanoid 10.06.2012 - 22:06
1

por qué significa que los paquetes que intenta instalar son de terceros. Por eso, si desea instalarlos, active la casilla de verificación de Canonical en la pestaña de otro software en la configuración del administrador de actualizaciones y vuelva a intentarlo instalando.

espero que ayude

    
respondido por el Ten-Coin 29.03.2012 - 19:21
1

Tuve el mismo problema. Para mí, este comando funcionó:

sudo apt-get update --fix-missing

La ventaja de esto en comparación con las otras soluciones es su simplicidad. Puede seguir utilizando la GUI y no necesita averiguar qué repositorio está roto. Encontré la solución aquí en un comentario. No sé lo suficiente de Ubuntu para explicarlo, pero supongo que obtiene las claves necesarias para que funcionen todos los repos.

    
respondido por el smoortema 20.09.2013 - 10:58
0

Su pregunta no está clara: "corrige la actualización de su GUI" al corregir el error. La otra pregunta le mostrará qué hacer.

Puede anular la selección de las actualizaciones que dependan de una fuente que no sea de confianza, o puede continuar y usar la línea de comando para confiar en esa fuente en particular de forma permanente. Una vez que haya hecho uno de estos, el mensaje no aparecerá. Si haces esto último, entonces el mensaje nunca volverá a aparecer para esa fuente específica.

    
respondido por el Mei 29.03.2012 - 19:04

Lea otras preguntas en las etiquetas