¿En qué versión de Debian se basan las diferentes versiones de Ubuntu?

71

Tengo algunos paquetes de software personalizados para Ubuntu 10.04, 10.10 y 12.10, pero ahora debo instalarlos en Debian Squeeze. No he podido buscar un mapeo entre versiones específicas de Debian y Ubuntu. ¿Alguien aquí puede ayudar?

Específicamente, quiero saber qué versión de Ubuntu corresponde a Debian Squeeze.

    
pregunta xkcd 09.04.2014 - 16:28

2 respuestas

139

Puede encontrar la versión de Debian en la que se basa su versión de Ubuntu en el archivo: /etc/debian_version

Desde el 10.04 hasta el 17.04:

   Ubuntu      |       Debian  
18.04  bionic     buster  / sid   - 10
17.10  artful     stretch / sid   - 9
17.04  zesty      stretch / sid
16.10  yakkety    stretch / sid
16.04  xenial     stretch / sid
15.10  wily       jessie  / sid   - 8
15.04  vivid      jessie  / sid
14.10  utopic     jessie  / sid
14.04  trusty     jessie  / sid
13.10  saucy      wheezy  / sid   - 7
13.04  raring     wheezy  / sid
12.10  quantal    wheezy  / sid
12.04  precise    wheezy  / sid
11.10  oneiric    wheezy  / sid
11.04  natty      squeeze / sid   - 6
10.10  maverick   squeeze / sid
10.04  lucid      squeeze / sid

sid es la distribución de desarrollo de Debian (sid - testing - stable)

Puede encontrar el contenido del archivo sin instalar un sistema completo consultando las fuentes del paquete basefiles en Launchpad .

    
respondido por el Jacob Vlijm 09.04.2014 - 16:43
5

Desafortunadamente no hay un mapeo directo de / etc / debian_version como se menciona en la respuesta de Jacob da una idea aproximada, pero solo refleja un paquete y dicho paquete es un paquete modificado localmente en Ubuntu, por lo que no se extraerá automáticamente de Debian.

En particular, Ubuntu a menudo está por delante de Debian en paquetes principales como libc6. Es probable que intentar instalar un paquete creado en Ubuntu en una versión contemporánea de Debian termine con errores de versión en libc6.

De acuerdo con enlace Debian squeeze tenía libc6 2.11. De acuerdo con enlace ubuntu 10.04 lucid también tenía libc6 2.11 . Entonces, los paquetes para 10.4 lúcidos son IMO con mayor probabilidad de funcionar en Squeeze.

Dependiendo de las otras bibliotecas que necesite su programa, es posible que encuentre que se necesita una compilación específica para Debian squeeze.

    
respondido por el Peter Green 20.04.2016 - 17:42

Lea otras preguntas en las etiquetas