¿Cómo puedo eliminar el segundo Unity Launcher duplicado en una configuración de pantalla doble?

146

En mi pantalla doble, tengo Unun Launcher en la pantalla de la izquierda y también en la pantalla de la derecha. Ambos funcionan perfectamente bien.

Sin embargo, no quiero que este segundo iniciador esté presente en la pantalla de la derecha. ¿Cómo podría eliminar esto? Si es importante, estoy usando controladores NVIDIA con una configuración TwinView.

    
pregunta Eugene van der Merwe 25.02.2012 - 09:46

6 respuestas

216

Ahora puedes.

Abre Preferencias de visualización, y luego puedes elegir entre tener el iniciador en una pantalla o todas ellas.

Este diálogo también permite encender o apagar los bordes adhesivos (es decir, la ralentización del mouse) entre las pantallas.

    
respondido por el jrg 31.03.2012 - 19:46
33

La ralentización es una función que permite usar el iniciador cuando está configurado para ocultarse automáticamente. Creo que es un error que se usa cuando el iniciador está siempre visible. Lo reporté en Launchpad.net, donde se archivan los errores, y es posible que desee configurarlo para que lo afecte. Puede encontrarlo aquí: enlace

Mientras tanto, puede configurarlo usted mismo usando /apps/compiz-1/plugins/unityshell/screen0/options/overcome_pressure y /apps/compiz-1/plugins/unityshell/screen0/options/stop_velocity en gconf-editor

También puede configurar estos parámetros en CCSM (Administrador de configuración de Compiz Config), en el complemento Unity, pestaña Experimental

    
respondido por el Jo-Erlend Schinstad 03.03.2012 - 21:44
8

Acabo de encontrar una configuración en gconf-editor que te permitirá configurar el iniciador solo en tu escritorio principal: /apps/compiz-1/plugins/unityshell/screen0/options/num_launchers . Si lo configura en 1, el iniciador de Unity solo se mostrará en el escritorio principal. Si lo configura en 0, el iniciador estará disponible en todos los escritorios.

Además de esta configuración, también configuro la presión de superar ( /apps/compiz-1/plugins/unityshell/screen0/options/overcom_pressure=1 ) y detener la velocidad ( /apps/compiz-1/plugins/unityshell/screen0/options/stop_velocity=20 ).

    
respondido por el Todd Wallentine 17.05.2012 - 15:27
4

Lo resolví usando disper. Escriba una terminal:

sudo apt-get install disper

Después de resolver el problema con el método propuesto por Paŭlo Ebermann o nvidia-settings o lo que sea que funcione para usted, escriba una terminal:

disper --export < /path-to-my-file/my-disper-file.metamode

my-file.metamode es el siguiente:

backend: nvidia
associated displays: DFP-0, DFP-1
metamode: DFP-0: 1366x768 @1366x768 +1920+312, DFP-1: 1920x1080 @1920x1080 +0+0
scaling: stretched, stretched
xinerama info order: DFP-1, DFP-0

La tercera fila tiene en cuenta el posicionamiento particular de dos pantallas con diferentes alturas. Tu caso puede ser más simple. Podría intentar crear el archivo que se ajuste a su configuración (sin usar otros métodos + disper --export). El punto importante es el orden de las pantallas en la segunda y en las últimas filas.

Puede usar el script y ejecutarlo al inicio:

#!/bin/sh
#Auto switch single/extend display with disper on Multiple Monitor.
lines=$(disper -l | wc -l)
display_count=$((lines / 2))
if [ $display_count -eq "1" ]; then
   disper -s
else
   disper --import < /path-to-my-file/my-disper-file.metamode
fi

Funcionó con mi tarjeta gráfica NVIDIA (precisa y cuántica).

Espero que ayude.

    
respondido por el cesare sodi 26.10.2012 - 12:14
3

Probé la configuración combinada desde arriba:

/apps/compiz-1/plugins/unityshell/screen0/options/num_launchers=1
/apps/compiz-1/plugins/unityshell/screen0/options/overcom_pressure=1
/apps/compiz-1/plugins/unityshell/screen0/options/stop_velocity=20

Eso fue más que nada exitoso para mí. Un iniciador aparece solo en la pantalla principal, y el mouse se mueve de una pantalla a la siguiente sin dudar indebidamente. Sin embargo, descubrí que el iniciador restante no se revelaría sin usar la súper clave. Esto se puede corregir estableciendo lo siguiente:

/apps/compiz-1/plugins/unityshell/screen0/options/reveal_pressure=1

Por cierto, esto es con controladores de NVidia.

    
respondido por el David Sowerby 15.07.2012 - 11:59
0

Simplemente cambiando /apps/compiz-1/plugins/unityshell/screen0/options/stop_velocity a 1 solucionó el problema para mí ... No necesariamente quise quitar la segunda barra de tareas, simplemente no me gustó la pausa cuando pasé de una pantalla a la otra.

    
respondido por el brbcoding 03.08.2012 - 22:17

Lea otras preguntas en las etiquetas