Fuentes feas en Netbeans - ¿Cómo puedo hacer que use la fuente del sistema?

67

Tengo problemas para que la fuente de Netbeans se vea bien, esto ha sido un problema desde que probé Ubuntu ~ 8. Por alguna razón, parece que las fuentes no están obteniendo un suavizado de píxel en Netbeans solamente, para el resto de las aplicaciones se ven perfectas.

Mira qué fea es la captura de pantalla:

No es solo el área de código, pero todas las fuentes de la aplicación se ven de esta manera. Estaba mirando alrededor y, aparentemente, agregando la siguiente línea al archivo .bashrc debería solucionar el problema, pero en mi caso no fue así:

export _JAVA_OPTIONS='-Dawt.useSystemAAFontSettings=lcd'

Creo que solo podría afectar las aplicaciones basadas en Java, pero no he podido probar otra aplicación Java para verificar las fuentes.

¿Alguien sabe qué puedo hacer para arreglar esto? ¿Cómo puedo hacer que Netbeans use la fuente del sistema?

    
pregunta javiervd 30.03.2011 - 07:58

16 respuestas

38

Como se ha indicado en los comentarios, este es un problema con las aplicaciones Java Swing en Linux. Swing utiliza la configuración de suavizado de fuente de Gnome (desactivada, en escala de grises o subpíxel); sin embargo, ignora las configuraciones de sugerencias. Siempre usa sugerencias completas, y si está ejecutando Ubuntu con poca o ninguna sugerencia de fuente (como la mayoría de las personas lo hacen, dado que la sugerencia es la configuración predeterminada), la fuente parecerá significativamente diferente que en otras aplicaciones. Las aplicaciones SWT como Eclipse están bien, pero si te gusta Netbeans esto no te ayudará.

Advertencia: para la siguiente solución, solo estoy hablando de la fuente del editor, porque en un IDE eso es lo importante para mí. También podría aplicarlo a las fuentes del menú, etc., pero eso podría ser un poco exagerado.

La única solución utilizable que encontré aquí : use Fontforge para editar la fuente de editor de su elección y elimine toda la información de sugerencias del fuente, luego guárdela como una nueva fuente y úsela en Netbeans.

  1. sudo apt-get install fontforge
  2. Ejecuta Fontforge
  3. Abra su fuente de elección
  4. Ctrl + A o edit -> Select -> Select all para seleccionar todos los caracteres
  5. Sugerencias ⇒ Instrucciones claras
  6. Ctrl + Shift + F o element -> font info para abrir la información de la fuente
  7. Cambiar el nombre de la fuente (por ejemplo, al nombre original + '_nohints')
  8. Guarde la fuente editada en el directorio .fonts en su hogar, a través de file -> generate fonts , asegurándose de usar un formato que Ubuntu lea (consulte el siguiente paso)
  9. Borrar caché de fuente fc-cache -rv - siguiendo su salida para asegurarse de que su nuevo archivo de fuente fue recogido (por ejemplo, .sfd no lo hace, pero .ttf lo hace).
  10. Ejecute Netbeans y use la fuente que creó como fuente del editor

No, no es perfecto y sí, es un poco complicado, pero sigue siendo un mundo de diferencia. Espero que ayude.

    
respondido por el nem75 21.04.2011 - 23:12
16

Añadir

--laf Nimbus -J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd

o

-J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd --laf Metal

al archivo: netbeans.config. Puede encontrarlo en $ NETBEANS_HOME / etc / folder. Reduzca la fuente de su aplicación de las preferencias del sistema.

Fuente

    
respondido por el user24789 11.09.2011 - 10:03
7

Sé que esta es una vieja pregunta, pero en mi búsqueda del mismo problema, intenté todos los trucos sin suerte. Pensé que iba a tener que vivir con un texto terrible en netbeans.

Luego encontré esto: enlace

Básicamente: Ubuntu 13.10, Netbeans (7.3), parches de fuente de Infinality a freetype, OpenJDK7, y parches para arreglar el manejo sombrío de fuentes de Swings. ¡Y "simplemente funcionó" !!!

Copiado aquí en caso de que ese enlace muera:

  1. instalar freetype

    $ sudo apt-get install libfreetype6
    
  2. instalar parche de infinidad

    $ sudo add-apt-repository ppa:no1wantdthisname/ppa
    $ sudo apt-get update
    $ sudo apt-get install fontconfig-infinality
    

    Tuve que hacer lo siguiente después:

    $ sudo rm /etc/fonts/conf.avail/52-infinality.conf
    $ sudo ln -s /etc/fonts/infinality/infinality.conf /etc/fonts/conf.avail/52-infinality.conf
    

    Para usar Windows 7 como la representación de fuentes, haga lo siguiente:

    $ sudo /etc/fonts/infinality/infctl.sh setstyle win7
    

    Establezca USE_STYLE en "WINDOWS7" en /etc/profile.d/infinality-settings.sh

  3. install font fixed OpenJDK

    $ sudo add-apt-repository ppa:no1wantdthisname/openjdk-fontfix
    $ sudo apt-get update
    $ sudo apt-get install openjdk-7-jdk
    

    En .../etc/netbeans.conf ,

    netbeans_default_options incluye: -J-Dawt.useSystemAAFontSettings=lcd y -J-Dsun.java2d.xrender=true"

    y establecer netbeans_jdkhome="/usr/lib/jvm/java-1.7.0-openjdk-amd64"

Esto cambió mis fuentes de Netbeans de los 90 aceptables a los modernos. Y ahora puedo usar Inconsolata como mi fuente de editor de Netbeans y se ve EXCELENTE.

Captura de pantalla solicitada: (el texto real es más claro que esta captura, algo en la captura lo borró ligeramente).

    
respondido por el Chris Holt 31.01.2014 - 06:28
5

El suavizado de las fuentes no funciona correctamente en las aplicaciones Ubuntu Java Swing.

Agregar:

-J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd

a netbeans.config al final de la cadena netbeans_default_options .

Puede encontrar el archivo de configuración en la carpeta $ NETBEANS_HOME / etc / (por ejemplo, /home/<user_name>/<neatbeans_folder>/etc/netbeans.conf )

Ejemplo:

netbeans_default_options="-J-client -J-Xss2m -J-Xms32m -J-XX:PermSize=32m -J-Dnetbeans.logger.console=true -J-ea -J-Dapple.laf.useScreenMenuBar=true -J-Dapple.awt.graphics.UseQuartz=true -J-Dsun.java2d.noddraw=true -J-Dsun.java2d.dpiaware=true -J-Dsun.zip.disableMemoryMapping=true -J-Dnetbeans.extbrowser.manual_chrome_plugin_install=yes -J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd"
    
respondido por el R. Oosterholt 24.01.2014 - 10:53
2

No es tan malo esa fuente ...

Sin embargo, esta es una aplicación de Java y una forma particular de manejar fuentes.

Si solo quiere cambiar el tamaño de la fuente, puede iniciar Netbeans con " - fontsize "parámetro :

netbeans --fontsize 12

Si desea cambiar el tipo de fuente, es un poco más difícil cambiar los parámetros del entorno, y este artículo explica muy bien:

enlace

Esto es para ArchLinux pero creo que funcionará también en Ubuntu ya que Java es un software universal.

    
respondido por el Pisu 10.10.2011 - 23:52
2

Tuve el mismo problema en Ubuntu 12.04 y Netbeans 7.2.

Intenté agregar -J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd a netbeans.conf pero no resolvió el problema.

Luego vi el comentario sobre la altura de la línea en error Netbeans 215785 . Configurar la altura de la línea del editor en 1.0 junto con la configuración de AA en netbeans.conf resolvió mi problema.

    
respondido por el Caner 01.09.2012 - 15:48
1

Pude hacer esto así (estoy usando Ubuntu 12.10, también funcionó en Ubuntu 13.04):


Paso 1 (Esto probablemente funcione en todas las versiones de Ubuntu):

Primero limpié los menús con este complemento Tools -> Plugins -> Settings -> Add :

http://java-swing-ayatana.googlecode.com/files/netbeans-catalog.xml

Una vez que se agrega esa ubicación, debe instalar el complemento, buscando Java Ayatana (la descripción estará en español). Esto hará que el menú superior y contextual sea el mismo que el sistema operativo.


Paso 2 (no sé si esto funcionará en todas las versiones de Ubuntu):

A continuación, probablemente quieras que las fuentes de los proyectos también se vean mejor, lo que hice para arreglar esto fue ejecutarlo en la terminal: sudo apt-get install gnome-tweak-tool Lo inicié y elegí un default font diferente ¡Ahora Netbeans se ve muy bien!

Aquí hay una captura de pantalla:

    
respondido por el Get Off My Lawn 22.12.2012 - 23:49
1

Acabo de ver estas publicaciones y traté de solucionar el problema de mis fuentes, también tuve problemas, pude elegir solo 4 fuentes, todas estaban cojas, y me pregunté qué pasó con que los netbeans solo proporcionaran 4 tipos de letra y también el cuadro selector de fuente cojo, Soy un gran admirador de netbeans y sabía que puedo encontrar una solución aquí.

de cualquier manera que seguí todo guid posible. Uso Ubuntu 13.10 y Netbeans 7.3 (sí, me encantan las cosas inestables)

  1. crea la carpeta .font en mi carpeta de usuario.
  2. copié todas las fuentes que tenía en esa carpeta.
  3. agregó la siguiente línea al archivo netbeans.conf

encuéntrelo ejecutando:

locate netbeans.conf

edítelo y agregue lo siguiente dentro de las comillas como se sugiere arriba

-J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd --laf Metal
  1. ejecuta la actualización de netbeans, que creo que hizo la magia, ahora tengo un seleccionador de fuentes hermoso y tengo más fuentes para elegir y luego código para escribir (broma sin gracia).

Espero que te ayude.

    
respondido por el talsibony 01.01.2014 - 15:24
0
#!/bin/sh

gsettings set org.gnome.desktop.interface font-name 'Ubuntu 10'
sh /home/xxx/netbeans-7.2/bin/netbeans &
sleep 5
gsettings set org.gnome.desktop.interface font-name 'Ubuntu 11'
    
respondido por el demonige 19.09.2012 - 13:53
0

Personalmente, creo que la apariencia predeterminada general de Netbeans en Linux es un poco decepcionante, especialmente si tenemos en cuenta lo bien que se ve en otras plataformas. Afortunadamente, cambiar el aspecto y amp; feel (LAF) se puede hacer fácilmente desde dentro del IDE. Dependiendo de su selección, esto a menudo mejorará la apariencia de las fuentes.

Para cambiar LAF, haga lo siguiente: Haga clic en Herramientas & gt; & gt; Opciones En el cuadro de diálogo, seleccione Aspecto y luego la pestaña Aspecto y sensación Simplemente seleccione una de las LAF. Mi preferencia es Nimbus, pero es posible que prefiera algo más.

También hay dos plugins 'Dark LAFs' disponibles: Dark Metal y Dark Nimbus.

    
respondido por el Larry Hignight 24.07.2014 - 03:12
0

Yendo un paso más allá de las formas manuales, he preparado una fuente dedicada llamada "Ubuntu Mono Nohinting" para solucionar un problema de renderizado con aplicaciones Java Swing como NetBeans IDE, IntelliJ IDEA y PyCharm. La información de sugerencias de fuentes se ha eliminado de la familia original de fuentes de Ubuntu Mono.

Cómo instalar

  • descargue el archivo zip desde aquí
  • extraerlo
  • abrir * .ttf con Font Viewer para instalar.
  • o puede copiar manualmente * .ttf en ~/.local/share/fonts/ .

Cómo usar

  • Seleccione "Nohinting Ubuntu Mono" en la configuración de los editores.

Capturas de pantalla

Ubuntu Mono Font con PyCharm Monokai theme

Ubuntu Mono Nohinting Font con el tema PyCharm Monokai

    
respondido por el Nobuto Murata 11.04.2015 - 18:15
0

Yo mismo he hecho algo diferente: en mi caso, hablando de NetBeans versión 8.0.1 , el problema era el JDK instalado en el sistema (Oracle JDK 8.0). Después de pasar a OpenJDK aparecieron 8 fuentes más bonitas en los elementos de la interfaz de usuario.

No sé si esa es una buena respuesta, porque puede que no funcione en todas partes, pero sin duda: al intentar cambiar JDK (ya sea OpenJDK u Oracle JDK), es posible que vea una diferencia.

    
respondido por el spectre 21.12.2015 - 18:18
0

Agregue el siguiente código al final del archivo netbeans_default_options your netbeans.conf .

-J-Dawt.useSystemAAFontSettings=on

Esto hará uso de las fuentes del sistema.

    
respondido por el Kevin RED 29.11.2017 - 13:25
0

Intenté literalmente todas las soluciones que pude encontrar y ninguna funcionó, excepto el uso de un JDK predeterminado diferente para NetBeans.

Oracle JDK no procesa bien las fuentes. OpenJDK tampoco parece funcionar para NetBeans, pero funciona de maravilla para IntelliJ y sus hermanos.

El que funcionaba para NetBeans se llama TuxJDK , que es esencialmente OpenJDK mejorado para desarrolladores de Java que trabajan en Linux. Una de las mejoras es representación de fuentes excelente .

Así es cómo usarlo:

  1. Descargue el binario de TuxJDK de aquí . ("tuxjdk-static-8.92.03.tar.xz" al momento de escribir)
  2. Extraiga tar.xz donde lo desee.
  3. Copie la ubicación del directorio TuxJDK.
  4. Abra netbeans.conf ubicado en NetBeansInstallationDirectory / etc /.
  5. Encuentre la línea que comienza con "netbeans_jdkhome" y reemplace la ruta con la copiada en el Paso 3.
  6. ¡Arranca y NetBeans y trata a tus ojos con hermosas fuentes!

Antes: NetBeans antes de usar TuxJDK

Después: NetBeans después de usar TuxJDK

    
respondido por el Rohit Awate 23.03.2018 - 17:26
0

Simplemente instale zulu jdk desde enlace :)

    
respondido por el Arun 30.03.2018 - 14:39
-1

Estaba teniendo el mismo problema en Mint 12. Lo resolví ingresando la "Configuración avanzada" - & gt; "Fuentes" y reduciendo la fuente predeterminada de 11 a 10. Bajé todas las fuentes de la lista para mantener la coherencia.

Debe haber algún problema con la fuente Cantarell 11.

    
respondido por el Alan B. Dee 23.12.2011 - 19:25

Lea otras preguntas en las etiquetas