"ctrl + space" ha estado obligado a invocar algún método de entrada y no funciona en Emacs o Eclipse autocompletar

81

En Emacs se ejecuta en la terminal, ctrl + espacio es una tecla de método abreviado estándar para seleccionar la región. Pero en Ubuntu 12.04, invocará algún método de entrada para el idioma que no es inglés. Me preguntaba si puedo reservarlo solo para Emacs.

En System Settings -> Keyboard -> Shortcuts , no pude encontrar a qué ctrl + espacio se ha vinculado. Extraño.

Otros programas, especialmente autocompletar en Eclipse, también parecen tener problemas para manejar ctrl + espacio .

    
pregunta Tim 16.01.2013 - 00:55

7 respuestas

119

Parece que ejecuta Ibus, que usa Ctrl + Espacio de forma predeterminada para habilitar / deshabilitar el editor de entrada.

Puede cambiar la tecla de acceso directo asignada en Preferencias de Ibus.

Si Ibus se está ejecutando en la barra de menú, puede hacer clic con el botón derecho para seleccionar Preferencia en el menú. Si Ibus no se está ejecutando en la barra de menú, puede iniciar el diálogo de Preferencias desde el Tablero ejecutando Métodos de entrada del teclado o desde el terminal con ibus-setup .

Actualización de 14.04

ibus-setup ya no está disponible para 14.04. Las funciones del antiguo ibus-setup están integradas en Configuración del sistema & gt; & gt; Entrada de texto .

La conmutación de entrada ahora está configurada de forma predeterminada en Super + Espacio , pero Ibus aún puede robar el foco del Control + Espacio enlazar y causar otros problemas del sistema, especialmente el autocompletado en Eclipse.

La integración de la conmutación de entrada Ibus en la nueva configuración de entrada de texto sigue siendo un trabajo en progreso, y esto está causando el problema ya que la configuración más antigua todavía existe detrás de las escenas.

Si se actualizó desde 12.04, ibus-settings aún debería estar disponible.

En 14.04, puede editar la configuración directamente es dconf-editor .

Si no está instalado:

sudo apt install dconf-editor

Luego, vaya a Desktop & gt; & gt; ibus & gt; & gt; general & gt; & gt; tecla de acceso rápido . Las configuraciones trigger y triggers seguirán mostrando 'control + espacio'. Edite estos ajustes, teniendo cuidado de dejar los corchetes vacíos [] en triggers .

    
respondido por el chaskes 16.01.2013 - 01:59
10

Deshabilita el desencadenador IBUS usando la línea de comando:

gsettings set org.freedesktop.ibus.general.hotkey triggers @as []

O si esto no funciona, intente si el primero produce un error:

gsettings set org.freedesktop.ibus.general.hotkey triggers []
    
respondido por el aba 24.06.2014 - 09:46
4

ibus no me causa más que dolores de cabeza. Cada vez que intento cambiar la configuración, cuando reinicio, la Ctrl + Space vuelve. Aquí está mi solución:

sudo apt-get purge ibus
sudo killall ibus

Ahora todo funciona hasta que Ubuntu decida su siguiente estupidez. ¿Tal vez la letra 'o' corresponda a apagar la computadora?

    
respondido por el Eyal 11.02.2015 - 13:47
2

Después de actualizar a ubuntu 14.04, tuve el mismo problema. Lo que hice.
En las preferencias de Ibus: System > Preferences > Keyboard Input Methods .
Hay una opción: Next input method se configuró en ctrl + espacio, lo eliminé y luego todos comenzaron a funcionar nuevamente.

    
respondido por el wmlynarski 24.07.2014 - 11:04
1

Ubuntu Studio 14.04 (XFCE) aquí. No tuve ningún problema con Autocompletar ( Ctrl + Space ), pero con Copiar línea ( Ctrl + Alt + Down ).

Esto funcionó para mí:

  • Abra el Administrador de Windows: xfwm4-settings
  • Ir a la pestaña Teclado
  • Desplácese hasta Acción en conflicto
  • Presione el botón Borrar o cambie la acción a un atajo diferente
respondido por el luboskrnac 04.04.2015 - 13:34
0

Tengo Ubuntu 14.04 GNOME con LXDE. Aparentemente este escritorio tiene ibus-setup. Entonces, para mí, cambiar la configuración de ibus era la solución correcta. Quizás fue solo Unity quien eliminó la aplicación ibus-setup.

    
respondido por el JamesH 28.12.2014 - 05:28
0

El cambio de dconf-editor no fue suficiente para mí. Tengo instalada la fuente de entrada Mozc (japonesa).

En Ubuntu 16.04, también tuve que:

  1. Vaya a Configuración del sistema - & gt; Entrada de texto
  2. Haga clic en Mozc para resaltar
  3. Haga clic en el icono de llave inglesa / destornillador a continuación
  4. pestaña Configuración global
  5. El primer ajuste allí, "Método de entrada del disparador", fue CTRL_SPACE. Hice clic en él y luego presioné Escape para desactivar la vinculación.
respondido por el TalkLittle 08.09.2016 - 19:18

Lea otras preguntas en las etiquetas