¿Cómo desactivo el sonido del ritmo del tambor en la pantalla de inicio de sesión?

110

Hubiera esperado Sistema ▸ Administración ▸ Pantalla de inicio de sesión ▸ Reproducir sonido de inicio de sesión para controlar esto, pero desmarcarlo no impide que se reproduzca el sonido del ritmo del tambor.

    
pregunta ændrük 05.02.2011 - 19:05

15 respuestas

57

El sonido de inicio se puede desactivar editando la configuración de Unity Greeter. Ejecutar lo siguiente desde un terminal hará esto:

echo -e '[com.canonical.unity-greeter]\nplay-ready-sound = false' \
    | sudo tee -a /usr/share/glib-2.0/schemas/50_unity-greeter.gschema.override
sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

Si está ejecutando Ubuntu 12.04 LTS, asegúrese de tener instaladas las actualizaciones ya que esta característica se agregó en una actualización.

    
respondido por el Andrejs Cainikovs 25.04.2016 - 23:34
58

para Ubuntu 12.04 +

LightDM Way

También conocido como FluteFlute Slap, LightDM Way implica cerrar la sesión y en la pantalla de inicio de sesión de LightDM puede cambiar el volumen o incluso silenciar el sonido.

En el Inicio de Sesión puede ver el Volumen en la parte superior derecha. Ajustar el volumen allí no afecta el volumen cuando se inicia la sesión, por lo que puede silenciar el sonido en el Greeter sin silenciar el sonido cuando comienza la sesión:

Ubuntu Tweak Way

El modo Ubuntu Tweak implica tener que descargar la aplicación Ubuntu Tweak y luego desactivar el sonido desde allí. Haga los siguientes pasos y puede hacerlo de esta manera:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

Abre Ubuntu Tweak y en la pestaña Tweak selecciona la opción "Configuración de inicio de sesión", deberías ver la opción Reproducir sonido de inicio de sesión. Necesito hacer clic en el botón de bloqueo de arriba para poder cambiar esto.

para Ubuntu 11.10 y debajo

Ir a System -> Preferences -> Startup Applications

Deshabilita el llamado Sonido de inicio de sesión de GNOME

(desmarque la casilla y haga clic en Cerrar)

también puede ir a System -> Preferences -> Sound y desactivar todo el sistema de sonido (como sonidos de Windows, alertas, etc.)

En la versión anterior, puede ir a la parte de Preferencias de sonido y seleccionar cada sonido y lo que quería hacer. Fue eliminado alrededor del 9.04 o 9.10. Sería bueno si regresara.

    
respondido por el Luis Alvarado 05.02.2011 - 19:20
54

12.04 - 16.10 (LightDM)

Esto es lo que funcionó para mí después de instalar 12.04 la semana pasada.

Los pasos son estos, adaptados de enlace :

gksudo gedit /usr/share/glib-2.0/schemas/50_unity-greeter.gschema.override

Agregue estas líneas:

[com.canonical.unity-greeter]
play-ready-sound = false

Guardar, luego ejecutar:

sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

Reinicia y disfruta.

    
respondido por el K. P. MacGregor 10.09.2012 - 13:11
20

11.10 (LightDM y GDM)

Solución rápida:

Abra una terminal y ejecute el comando

sudo mv /usr/share/sounds/ubuntu/stereo/desktop-login{,-disabled}.ogg  

El sonido del bombo lightdm para el sistema listo se puede desactivar de manera similar

sudo mv /usr/share/sounds/ubuntu/stereo/system-ready{,-disabled}.ogg  
    
respondido por el RobinJ 15.10.2011 - 13:23
11

para 12.04

Por defecto, está desactivado. Para habilitarlo, abre un terminal y ejecuta

gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop

Luego, cambie el valor de X-GNOME-Autostart-enabled a "verdadero", es decir X-GNOME-Autostart-enabled=true

para 11.10

Escriba en un terminal gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop y cambie el valor NoDisplay de verdadero a falso :

Ahora ve a tus aplicaciones de inicio y deberías ver y poder deshabilitar la opción necesaria:

    
respondido por el Bruno Pereira 15.10.2011 - 13:26
10

10.10 (GDM)

Parece que hay un error en la pantalla de inicio de sesión al respecto. No puedo encontrar un informe oficial, sin embargo, esta publicación del foro confirma una arreglar.

Ir a Sistema / Administración / Pantalla de inicio de sesión. Desbloquéalo, luego marca "Reproducir sonido de inicio de sesión".

Cierra la ventana, luego vuelve a la aplicación, desbloquéala y luego desmarca la misma opción.

    
respondido por el Scaine 05.02.2011 - 20:43
7

Si está utilizando GDM con 12.04

Para desactivar los sonidos de inicio de sesión, la tecla evento-sonidos en org.gnome.desktop.sound para el usuario gdm debe establecerse en falso.

Para esto, primero debemos darle a GDM la propiedad de su propio directorio personal. Abra una terminal y escriba: sudo chown -R gdm:gdm /var/lib/gdm

Luego ejecuta:

sudo xhost +SI:localuser:gdm
sudo -u gdm gsettings set org.gnome.desktop.sound event-sounds false

y cierre la sesión (o reinicie).

Si está utilizando LightDM con 12.04

Abra una terminal con Ctrl + Alt + T, y escriba / pegue lo siguiente, una línea a la vez:

sudo xhost +SI:localuser:lightdm
sudo su lightdm -s /bin/bash
gsettings set com.canonical.unity-greeter play-ready-sound false
exit

Lo que hace es deshabilitar la configuración de play-ready-sound para la pantalla de inicio de sesión / usuario del administrador de escritorio (lightdm).

    
respondido por el ish 10.09.2012 - 12:15
5

11.10 (LightDM y GDM)

Para eliminar el sonido de inicio:

mv /usr/share/sounds/ubuntu/stereo/system-ready.ogg /usr/share/sounds/ubuntu/stereo/system-ready.ogg.old 

Para habilitar el sonido de inicio

mv /usr/share/sounds/ubuntu/stereo/system-ready.ogg.old /usr/share/sounds/ubuntu/stereo/system-ready.ogg

Para eliminar el sonido de inicio de sesión (después de iniciar sesión):

mv /usr/share/sounds/ubuntu/stereo/desktop-login.ogg /usr/share/sounds/ubuntu/stereo/desktop-login.ogg.old

Para habilitarlo de nuevo:

mv /usr/share/sounds/ubuntu/stereo/desktop-login.ogg.old /usr/share/sounds/ubuntu/stereo/desktop-login.ogg
    
respondido por el Vibhav Pant 07.03.2012 - 09:03
3

11.10 (LightDM y GDM)

Esto debería funcionar para usted.

gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop

Luego cambie NoDisplay = a falso, ect.

o para eliminarlo:

sudo rm /usr/share/sounds/ubuntu/stereo/system-ready.ogg
    
respondido por el Ringtail 07.03.2012 - 09:02
3

11.10 (GDM)

gsettings set org.gnome.desktop.sound event-sounds false
    
respondido por el blueyed 30.09.2011 - 09:13
1

12.10 (GDM)

Nada de lo anterior funciona para mí con gdm. Si desactivo el sonido listo para sistema (los bongos), aún se emite un sonido corto de batería (un tiempo).

La forma de deshabilitarlo es:

  • Arranque, entre en gdm.
  • Cambia a la consola ( Ctrl + Alt + F1 )
  • Iniciar sesión
  • Entrar:

    export DISPLAY=:0
    sudo -H -u gdm pavucontrol
    
  • Volver a gdm ( Ctrl + Alt + F8 )

  • Deshabilita el sonido en el mezclador. Lo silenciaré en "Reproducción" y "Dispositivos de salida".
  • Cierre el mezclador, es posible que obtenga un error al escribir el archivo de configuración, esto es inofensivo.
  • Vuelve a la consola e ingresa

    sudo service gdm restart
    

    para probar y exit para cerrar la sesión.

respondido por el jdm 17.07.2012 - 18:02
1

11.04 y anterior (GDM)

¿Ejecutar este comando en una terminal?

sudo -u gdm gconftool-2 --set /desktop/gnome/sound/event_sounds --type bool false

    
respondido por el Jorge Castro 11.09.2012 - 05:49
1

12.10 (LightDM)

Ejecute el mismo comando Jorge Castro dio , solo con gdm reemplazado por lightdm :

sudo -u lightdm gconftool-2 --set /desktop/gnome/sound/event_sounds --type bool false
    
respondido por el C Schilder 27.06.2012 - 09:51
1

La manera más fácil es silenciar el sonido en el saludo. Simplemente haga clic en el volumen y haga clic en "silenciar".

Esto silenciará el sonido solo en el portavoz.

    
respondido por el Pilot6 15.06.2015 - 12:48
0

12.04 (LightDM)

El sonido bongo LightDM no se puede desactivar mediante ninguna opción de GUI en 12.04 y aquí hay un informe de error:

Los métodos de línea de comandos anteriores pueden deshabilitarlo.

El sonido después del inicio de sesión se puede deshabilitar fácilmente con las respuestas anteriores.

    
respondido por el Eric Nemchik 07.04.2012 - 04:04

Lea otras preguntas en las etiquetas