¿Cómo rebajar Firefox de 30 a 28?

17

Accidentalmente sudo apt-get upgrade (mientras escribía instrucciones para hacer algo y no me daba cuenta de que no era sudo apt-get update ) y actualizaba Firefox de 28 a 30. Ahora mis menús están completamente en mal estado , entonces quiero recuperar FF28 y no me interesan las opiniones sobre cómo las versiones más nuevas son mejores (hay muchas en los foros de soporte de Mozilla en lugar de las respuestas reales).

Además, descargar firefox-mozilla-build_28.0-0ubuntu1_i386.deb e intentar usarlo aparentemente no funciona, el centro de software de Ubuntu dice:

Breaks existing package 'firefox' that conflict: 'firefox'.

    
pregunta Danijel 21.07.2014 - 13:45

3 respuestas

3

Intente eliminarlo primero por:

sudo apt-get purge firefox

Luego puede instalar utilizando firefox-mozilla-build_28.0-0ubuntu1_i386.deb

    
respondido por el Back.Slash 21.07.2014 - 13:47
60

Ejecutar

apt-cache show firefox | grep Version

para obtener una lista de las versiones de Firefox disponibles. En mi 14.04 resulta:

Version: 32.0+build1-0ubuntu0.14.04.1
Version: 28.0+build2-0ubuntu2

A continuación, indique a APT exactamente qué versión instalar:

sudo apt-get install firefox=28.0+build2-0ubuntu2

Luego debe decirle a APT que no actualice a la versión más nueva nuevamente. De acuerdo con enlace hay muchas formas de hacerlo, elegí:

sudo apt-mark hold firefox

Una vez que quiera soltar su Firefox 28 y seguir los lanzamientos habituales nuevamente, solo haga lo siguiente:

sudo apt-mark unhold firefox
sudo apt-get upgrade

Alternativamente, puede enumerar las versiones disponibles con:

apt-cache policy firefox

PD: Firefox almacena todas sus configuraciones en la carpeta ~ / .mozilla. Esta carpeta no ha sido modificada por los comandos anteriores, por lo que todas sus configuraciones deberían persistir. Si quiere estar seguro, haga una copia de seguridad de la configuración antes de degradar:

cp -ra ~/.mozilla ~/.mozilla.backup
    
respondido por el alfonx 11.09.2014 - 09:21
1

Después de leer las respuestas, mi respuesta es ligeramente diferente de las anteriores, ya que cumplió mi propósito. La instrucción es degradar a cualquier versión, cuando la versión existente de firefox aún está en el sistema.

  1. Primero encuentra una versión de Firefox que quieras:

    • Ir al enlace: enlace
    • Vaya a una versión específica (por ejemplo, /35.0.1/linux-x86_64/en-US/ ) y descargue el archivo .tar.bz2
  2. Vaya al directorio donde descargó el archivo .tar.bz2 y ejecute en el terminal (descomprimirá su archivo):

    tar xvjf firefox-35.0.1.tar.bz2 (cambie el nombre del archivo a su gusto)

    Este comando descomprimirá su archivo tar.bz2 y creará una carpeta firefox

  3. Luego ejecuta en la terminal:

    which firefox

    Te dará algo como: /usr/bin/firefox . Esa es la ubicación de tu Firefox. Borre la carpeta (ya que la reemplazará más tarde con la otra carpeta de Firefox)

  4. Elimina los perfiles de Firefox anteriores de los directorios:

    • .mozilla/firefox/

    Y tal vez esto también (pero no lo he hecho):

    • /etc/firefox/
    • /usr/lib/firefox/
    • /usr/lib/firefox-addons/
  5. Copia la carpeta firefox del paso 2. al /usr/bin/firefox y todo está hecho. Ejecute su Firefox como si se ejecutara normalmente y ejecutará esa versión descargada específica.

  6. Desactiva la actualización en Preferencias - & gt; Avanzado - & gt; Actualizaciones, si necesita conservar la versión.

Nota al pie:

Si necesita esto para ruby y selenium driver, antes de eso, compruebe qué versión de firefox realmente necesita.

Vaya a enlace y busque su versión de selenio y compruebe qué versión de Firefox admite. Por ejemplo, busca algo como esto: Firefox support up to 35

    
respondido por el Aleks 09.09.2016 - 08:45

Lea otras preguntas en las etiquetas