Forzar la pantalla de inicio de sesión de gdm en el monitor primario

22

Tengo dos monitores conectados a mi tarjeta de video. El monitor principal tiene una resolución igual a 1280x1024 y el segundo tiene 1920x1200. Mi gdm pantalla de inicio de sesión siempre aparece en el segundo monitor, incluso si está apagado. Mi pregunta es cómo forzar gdm a mostrar la pantalla de inicio de sesión siempre en el monitor principal con una resolución de 1280x1024?

Uso la videcard Nvidia GT9500 en modo Twinview. No puedo usar Xinerama porque vpdau no funciona correctamente en este modo.

Lo que he encontrado es que el puntero del mouse siempre aparece en el centro de unión de las pantallas y el centro siempre está en el monitor con una resolución más alta. La pantalla de inicio de sesión siempre muestra dónde está el cursor del mouse.

Ahora mi monitor principal tiene una resolución igual a 1920x1080. El problema persiste, el cursor del mouse siempre aparece en la esquina inferior derecha del segundo monitor.

    
pregunta Kirill V. Lyadvinsky 06.11.2010 - 12:26

6 respuestas

1

Recientemente, actualicé el sistema a la versión 11.10. Ubuntu 11.10 usa un nuevo administrador de pantalla (lightgdm) y parece que la pantalla de inicio de sesión siempre aparece en el monitor principal. Esto resuelve mi problema.

    
respondido por el Kirill V. Lyadvinsky 03.12.2011 - 20:12
20

Para versiones más nuevas de Ubuntu como 13.10 o actualizado 13.04 utilizando Gnome 3.8, este procedimiento es diferente porque el archivo de configuración X ya no controla el diseño del monitor. Debe hacer lo siguiente:

  1. Configure correctamente el monitor como usuario registrado (consulte Establezca el monitor como principal )

  2. Copie el archivo de configuración a la configuración de gdm

    cp ~/.config/monitors.xml ~gdm/.config/
    

Para obtener más información, consulte enlace

    
respondido por el Andrew Mao 18.09.2013 - 18:40
1

¿está usando una tarjeta Nvidia con una configuración de pantalla doble?

De ser así, tuve el mismo problema y lo resolví de la siguiente manera: apague la computadora, desenchufe el segundo monitor, vuelva a encender la computadora, ejecute 'sudo nvidia-settings', vuelva a conectar el segundo monitor, ejecute 'Detectar pantallas' en la GUI de Nvidia y realice las configuraciones necesarias antes de guardar la configuración. El punto IMPORTANTE es que la pantalla en la que desea que se muestre el inicio de sesión se establece en 'Número de pantalla: 0'.

En mi caso, dejar el segundo monitor conectado antes de ejecutar 'nvidia-settings' lo dejó como pantalla 0 por alguna razón, pero al conectarlo después, esto fue ordenado.

    
respondido por el spinoza666 07.11.2010 - 07:47
0

intenta cambiar el orden de tus monitores hacia la izquierda / derecha, no cambia cuál es el principal, pero podría ayudar a que aparezca tu GDM.

    
respondido por el hansioux 06.11.2010 - 13:59
0

Si twinview lo hace de la misma manera que lo hace el centro de control de catalizadores de ATI, existe un xorg.conf que puede editar con gksu gedit /etc/X11/xorg.conf

La parte relevante de la mina se ve así:

Section "ServerLayout"
    Identifier     "amdcccle Layout"
    Screen      0  "amdcccle-Screen[1]-0" 0 0
    Screen         "amdcccle-Screen[1]-1" 1400 0
EndSection

Todo lo que tienes que hacer (después de hacer una copia de seguridad de tu xorg.conf por supuesto) es cambiar el ServerLayout intercambiando las entradas de la Pantalla (y adaptando los números de la pantalla), en mi caso sería:

Section "ServerLayout"
    Identifier     "amdcccle Layout"
    Screen      0  "amdcccle-Screen[1]-1" 1400 0
    Screen         "amdcccle-Screen[1]-0" 0 0
EndSection
    
respondido por el Tobias Kienzler 12.01.2011 - 10:57
0

Puede probar "Configuración de pantalla X separada" en la configuración del servidor NVIDIA X. Si configura la pantalla deseada en 0, la ventana de inicio de sesión aparecerá allí. Está funcionando para mí.

    
respondido por el kissgyorgy 30.11.2011 - 11:08

Lea otras preguntas en las etiquetas