Ubuntu 16.04 LTS Network Manager no puede agregar VPN - en gris

22

Estoy intentando agregar una VPN a mi red, pero la opción es en gris.

Captura de pantalla del indicador atenuado

Instalé network-manager-openvpn pero todavía no tuve suerte. La edición de mi conexión no muestra ninguna configuración o pestaña VPN.

¡Agradecería que alguien pudiera señalarme en la dirección correcta!

EDITAR : en caso de que alguien más tenga este problema, la frase "Agregar una conexión VPN" es muy engañosa ya que te dice que debes agregar una conexión VPN , no se supone que debes hacer clic para agregar uno desde allí.

Seleccione Editar conexiones, Agregar y luego seleccione su VPN desde allí.

    
pregunta Harmonic 09.04.2017 - 17:52

3 respuestas

37

En caso de que alguien más tenga este problema, la frase "Agregar una conexión VPN" es super engañosa ya que le dice que necesita agregar una conexión VPN , no que se supone que debe hacer clic para agregue uno de allí.

Seleccione Editar conexiones, Agregar y luego seleccione su VPN desde allí.

    
respondido por el Harmonic 09.04.2017 - 18:05
8

Recientemente configuré VPN en Xubuntu 16.04 LTS por primera vez. Esto es lo que tenía que hacer:

sudo apt install openvpn
sudo apt install network-manager-openvpn-gnome 

Utilicé network-manager-openvpn-gnome en lugar de network-manager-openvpn para obtener la opción de importar los archivos de configuración de VPN.

Después de eso, pude ir a:

  1. Editar conexiones en la parte inferior del menú
  2. Haz clic en el botón Añadir en la siguiente ventana
  3. Elija el tipo de conexión
  4. Importar una configuración de VPN guardada

Después de eso, pude editar la conexión VPN por

  1. Editar conexiones ... en la parte inferior del menú
  2. Seleccione la conexión VPN que deseo editar
  3. Haga clic en el botón Editar

    
respondido por el fliegenpilzmann 10.04.2017 - 00:23
3

La manera más fácil es usar un comando en la terminal:

nm-connection-editor

nm-applet normalmente comienza al iniciar sesión por el administrador de sesión del escritorio y no necesita ejecutarse manualmente.

En algunas versiones de Ubuntu había problemas en la política de seguridad.

Para resolver esto, debe editar el archivo 'org.freedesktop.NetworkManager.policy' en / usr / share / polkit-1 / actions /

sudo -H gedit /usr/share/polkit-1/actions/org.freedesktop.NetworkManager.policy

Y cambie esta acción:

<action id="org.freedesktop.NetworkManager.settings.modify.own">
.
.
.
<allow_inactive>no</allow_inactive>

a

<allow_inactive>yes</allow_inactive>

Luego, reinicie el administrador de red

sudo systemctl restart network-manager
    
respondido por el Marco A. Pivetta 28.01.2017 - 20:50

Lea otras preguntas en las etiquetas