Cómo solucionar problemas de arranque en una pantalla negra en virtualbox

19

Estaba usando 13.04 como sistema operativo invitado en mi Virtualbox 14.2.18. El anfitrión es Windows 8. Después de la actualización a 13.10, Ubuntu no se inicia. Puedo ver una pantalla negra y un cursor parpadeante.

¿Alguien puede ayudar? Soy bastante nuevo en ubuntu. Mi sensación es que algo falla con los controladores gráficos. Puedo acceder a tty y todos los archivos (/ home) están ahí.

    
pregunta don 05.11.2013 - 11:16

12 respuestas

10

Así es como soluciono un problema de Ubuntu que no arranca en Virtual Box (asumiendo ajustes óptimos para una máquina virtual ya estaban hechos):

  1. Asegúrese de haber instalado más versión reciente de Virtual Box .
  2. Pruebe un reinicio ingresando un terminal TTY ( Host + F1 )

    sudo reboot
    
  3. Instalar adiciones de invitados desde la línea de comandos .

  4. Reinicia después de instalar las adiciones de invitados.
  5. Actualice el sistema operativo invitado de TTY ( Host + F1 ):

    sudo apt-get update && sudo apt-get dist-upgrade
    
  6. Es posible que sea necesario volver a instalar las adiciones de invitado después de una actualización.

  7. Inicie lightdm manualmente desde un TTY ( Host + F1 ) con

    sudo lightdm
    
  8. Pruebe varios reinicios de la VM. Debido a problemas de tiempo, puede ayudar con el tiempo.
  9. Intente reiniciar el host.
  10. Consulte los foros y virtualbox.org para conocer los errores conocidos.
respondido por el Takkat 05.11.2013 - 11:55
19

Tuve este problema y mi solución fue simple.

De alguna manera, mi configuración de VirtualBox para la VM (Ubuntu) se modificó después de una actualización de Virtual Box. Mi invitado VM era Ubuntu 64 bits y se configuró como versión de 32 bits. Para cambiar:

  1. Abrir cuadro virtual
  2. Seleccione su máquina virtual y haga clic en "Configuraciones"
  3. Ir a "General"
  4. Cambie la versión a "Ubuntu (64-bit)"
respondido por el Dherik 01.11.2015 - 23:50
8

Para mí, ninguna de las respuestas anteriores funcionó. He resuelto este problema al deshabilitar la aceleración 3D en la página de configuración de vm. Esto es bastante extraño ya que he estado usando la aceleración 3D sin problemas durante meses en esa máquina virtual.

    
respondido por el pomarc 19.06.2017 - 11:01
4

Quizás sea una respuesta:

  1. Usted (y yo) accedemos a esta pantalla a través de un host (accidental) + f9 . Sin embargo, no te dice lo que sucedió.

  2. El hechizo de magia inversa es alt + f7 (todo restaurado en su antiguo esplendor).

Tuve que descubrir esto yo mismo. Aunque meterse en problemas fue bastante fácil.

    
respondido por el user287749 02.06.2014 - 16:37
2

Esto me sucede hoy después de actualizar VBox a 5.1.30. La pantalla de inicio de sesión parece normal. Sin embargo, después de iniciar sesión, la pantalla se vuelve negra y permanece negra, mientras que la vista previa del administrador de VBox muestra el escritorio.

Intenté varias sugerencias, lo único que funciona es desactivar la aceleración 3D para el sistema operativo invitado (Linux Mint18).

La actualización adicional no tiene ningún efecto.

    
respondido por el user750199 21.10.2017 - 18:52
1

Cuando llegué a la pantalla de inicio de sesión, apagué el modo de pantalla completa, inicié sesión y luego lo volví a encender. Funcionó. Sin embargo, podría haber tenido suerte.

    
respondido por el aomimezura 17.03.2014 - 14:32
1

Hice lo siguiente, ya que funcionó para mí.

  1. Abrir TTYL ( Ctrl + Alt + F1 )

  2. Inicie sesión en una cuenta de usuario normal (no como invitado).

  3. Ingrese sudo dpkg --configure -a

  4. Presione ( Ctrl + F7 )

respondido por el Ankit 30.11.2016 - 16:23
0

Tuve el mismo problema al instalar Kali en VirtualBox, los cursores parpadeantes en la esquina superior izquierda. La solución más sencilla para mí fue ingresar al BIOS al presionar F10 durante el arranque y habilitar la virtualización.

    
respondido por el WilliamR 22.09.2016 - 23:02
0

Así es como resolví el problema. Instalé Hadoop en mi sistema operativo invitado openSuse. Hay varios servicios que se deben iniciar para comenzar a trabajar en Hadoop, como

start-dfs.sh
start-yarn.sh

Agregué el comando de inicio anterior en mi archivo .bashrc para no tener que iniciarlos explícitamente cada vez que inicio sesión. .bashrc se ejecuta cada vez que se inicia sesión.

$cd ~
$vi .bashrc

Comenté mis comandos de inicio de servicio como se muestra a continuación.

    
respondido por el Vinayak Dornala 07.04.2017 - 14:00
0

Lo siguiente funciona para mi Ubuntu 16.04 dentro de VirtualBox:

  1. Shutdown Ubuntu guest OS
  2. vaya a Configuración - & gt; Sistema - & gt; Placa base
  3. Cambia Chipset de ICH9 a PIIX3
  4. Reinicia Ubuntu y el modo gráfico se vuelve normal

Extrañamente, ICH9 funciona bien hasta que un día actualicé VirtualBox de 5.0.18 a 5.1.28 .

    
respondido por el Joe X Zhu 21.09.2017 - 08:34
0

Nada funcionó, así que inicié en modo de recuperación y seleccioné la opción DPKG (reparar paquetes rotos) y después lo hice.

    
respondido por el Vindolin 20.11.2017 - 13:06
0

Tuve un problema similar, lo que hice fue:

  1. Entrar en configuración - & gt; Sistema - & gt; Procesador
  2. Configure el procesador en 2CPU en lugar de 1CPU
  3. Haz clic en Aceptar y reinicia.

Me funcionó bien después de

    
respondido por el V.Novice 09.07.2018 - 01:40

Lea otras preguntas en las etiquetas