El autocompletado no funciona mientras se registra como root

18

Acabo de encontrar algo que realmente me molesta. El autocompletado en ubuntu funciona como un amuleto, pero cuando inicio sesión como root, p. su Obtengo tab autocompletado solo algunas veces.

¿Por qué funciona así? ¿Puede uno cambiar eso?

    
pregunta Patryk 12.02.2012 - 18:34

5 respuestas

36

Verifique su archivo /root/.bashrc para estas líneas

if [ -f /etc/bash_completion ]; then
  . /etc/bash_completion
fi

Si no existen, agréguelos al final del archivo con su editor de texto favorito.

    
respondido por el Bruno Pereira 27.06.2012 - 11:00
7

No ha mencionado qué versión de Ubuntu usa.

  • Comprueba si tienes instalado el paquete bash-completion :

    sudo apt-get install bash-completion
    
  • El mío funciona si inicio sesión usando: sudo -i

respondido por el Savvas Radevic 12.02.2012 - 20:24
3

Para Ubuntu 13.10, marque /etc/bash.bashrc para

# enable bash completion in interactive shells
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi

Pueden ser comentados. Dejar de comentarlos funciona.

    
respondido por el dbtek 18.11.2013 - 08:42
0

Se encontró que esto funcionó (similar a las respuestas anteriores pero con un giro)

El archivo que necesita ser editado (al menos en mi caso con 12.04) fue /root/.bashrc. Esto tiene sentido en mi caso, dado que mi usuario habitual se autocompletaba bien, pero mi raíz no.

De todos modos en dicho archivo encontré todo el código necesario pero fue comentado:

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
#if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
    #. /etc/bash_completion
#fi

Simplemente no comentado:

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
    . /etc/bash_completion
fi

Guardado, y funcionó bien.

Espero que esto ayude a alguien.

    
respondido por el neanderslob 13.12.2013 - 00:59
0

En Linux Mint 18 (basado en Xenial), debe editar su bashrc:

sudo nano /etc/bash.bashrc

y comentar (eliminar el # delante de cada línea) esta sección:

if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
     . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
     . /etc/bash_completion
  fi
fi

Eso es todo.

    
respondido por el le hollandais volant 15.08.2016 - 17:10

Lea otras preguntas en las etiquetas