Error SSH: Permiso denegado, por favor intente de nuevo

17

Tengo una configuración de servidor Ubuntu usando la instancia de amazon ec2. Necesito conectar mi computadora de escritorio (que también es una máquina ubuntu) al servidor ubuntu usando SSH.

He instalado open-ssh en el servidor de Ubuntu. Necesito todos los sistemas de mi red para conectar el servidor de ubuntu usando SSH (no es necesario conectarse a través de las teclas de pem o pub).

Por lo tanto, abrí el puerto SSH 22 para mi IP estática en grupos de seguridad (AWS).

Mi archivo SSHD-CONFIG es:

# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

A través de webmin (shell de comandos), creé un nuevo usuario llamado 'senthil' y agregué este nuevo usuario al grupo 'sudo'.

sudo adduser -y senthil
sudo adduser senthil sudo

Intenté iniciar sesión usando este nuevo usuario 'senthil' en 'webmin'. Pude iniciar sesión con éxito.

Cuando traté de conectar el servidor de ubuntu desde mi terminal a través de SSH,

ssh senthil@SERVER_IP

Me pidió que ingresara la contraseña. Después de la entrada de la contraseña, se muestra:

Permission denied, please try again.

En algunas investigaciones me di cuenta de que tengo que controlar el registro de autenticación de mi servidor para esto. Obtuve el siguiente error en mi registro de autenticación (/var/log/auth.log)

Jul  2 09:38:07 ip-192-xx-xx-xxx sshd[3037]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=MY_CLIENT_IP  user=senthil
Jul  2 09:38:09 ip-192-xx-xx-xxx sshd[3037]: Failed password for senthil from MY_CLIENT_IP port 39116 ssh2

Cuando intenté depurar usando:

ssh -v senthil@SERVER_IP


    OpenSSH_5.9p1 Debian-5ubuntu1, OpenSSL 1.0.1 14 Mar 2012
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to SERVER_IP [SERVER_IP] port 22.
debug1: Connection established.
debug1: identity file {MY-WORKSPACE}/.ssh/id_rsa type 1
debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048
debug1: Checking blacklist file /etc/ssh/blacklist.RSA-2048
debug1: identity file {MY-WORKSPACE}/.ssh/id_rsa-cert type -1
debug1: identity file {MY-WORKSPACE}/.ssh/id_dsa type -1
debug1: identity file {MY-WORKSPACE}/.ssh/id_dsa-cert type -1
debug1: identity file {MY-WORKSPACE}/.ssh/id_ecdsa type -1
debug1: identity file {MY-WORKSPACE}/.ssh/id_ecdsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.8p1 Debian-7ubuntu1
debug1: match: OpenSSH_5.8p1 Debian-7ubuntu1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.9p1 Debian-5ubuntu1
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: sending SSH2_MSG_KEX_ECDH_INIT
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ECDSA {SERVER_HOST_KEY}
debug1: Host 'SERVER_IP' is known and matches the ECDSA host key.
debug1: Found key in {MY-WORKSPACE}/.ssh/known_hosts:1
debug1: ssh_ecdsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: password
debug1: Next authentication method: password
senthil@SERVER_IP's password: 
debug1: Authentications that can continue: password
Permission denied, please try again.
senthil@SERVER_IP's password: 

Para la contraseña, he ingresado el mismo valor que normalmente uso para el usuario 'ubuntu'.

¿Puede alguien indicarme dónde está el problema y sugerir alguna solución para este problema?

    
pregunta Senthil Kumaran 02.07.2013 - 11:14

7 respuestas

2

Encontré el problema y lo solucioné.

Creé un nuevo usuario (llamado: senthil) y lo usé para SSH. En Ubuntu, creo que cuando creamos un nuevo usuario, de manera predeterminada, la contraseña del usuario raíz se asignará al nuevo usuario. Incluso entonces, restablezca y asigne alguna nueva contraseña a los usuarios recién creados.

Una vez que el usuario restablece la contraseña y realiza los siguientes cambios en sshd_config, ahora puedo conectar todos mis sistemas (desde mi red) al servidor remoto.

Tenga en cuenta: Apagué todas las autenticaciones SSH (como RSAAuthentication, PubkeyAuthentication y KerberosAuthentication). He activado solo PasswordAuthentication.

Gracias.

    
respondido por el Senthil Kumaran 03.07.2013 - 12:04
10

Has bloqueado la cuenta.

Desde la página de manual de usermod(8) :

-L, --lock
           Lock a user's password. This puts a '!' in front of the encrypted password,
           effectively disabling the password.

Ahora mira tu línea shadow :

ubuntu:!$rWDSG...HSi1:15347:0:99999:7:::

Desbloquearlo:

usermod -U ubuntu

¡Nota importante! Si este usuario está preinstalado en el sistema, puede estar bloqueado por algún motivo (por razones de seguridad), pero no puedo decidirlo porque aparentemente no es una instalación regular de Ubuntu.

Si lo anterior te hace sentir incómodo, puedes crear un usuario por separado:

sudo adduser username

y responde las preguntas. Deberías poder iniciar sesión sin problemas. También haga que sea capaz de convertirse en root (use sudo ) agregándolo al grupo sudo :

sudo adduser username sudo

En caso de que necesite cambiar al usuario ubuntu en la línea de comando, tendrá que usar sus privilegios elevados, ya que no puede proporcionar credenciales por el mismo motivo por el que no puede iniciar sesión usando SSH. Ahora, inicie sesión usando SSH como username , y ejecútelo para convertirse en ubuntu :

sudo su -l ubuntu

Por razones de seguridad, no recomendaría usar root para iniciar sesión directamente.

    
respondido por el gertvdijk 02.07.2013 - 11:25
6

Tengo el mismo problema y me toma muchas horas.

Sin embargo, observo que es una contraseña incorrecta debido a la diferencia entre el diseño del teclado del servidor y el cliente:

En Server, pensé que configuré la contraseña: WEwd@ds Y, observo que @ es " en el diseño del teclado del servidor.

Así que la contraseña correcta es: WEwd"ds

Por lo tanto, debe verificar:

Disposición del teclado del servidor [vs] Disposición del teclado de la estación de trabajo

    
respondido por el Abdennour TOUMI 12.06.2014 - 14:48
4

Esta no es una respuesta exacta para esta pregunta. Pero en mi caso, hubo líneas redundantes. (hubo la misma línea dos veces)

PermitRootLogin yes

y también

AllowUsers otheruser

Debería agregar usuario 'root' a esta línea o comentar esta línea.

Y reinicie ssh service sshd restart

    
respondido por el Sadee 24.03.2017 - 15:25
1

Tengo una solución para ti En su archivo sshd_config, agregue la siguiente línea al final del archivo:

AllowUsers senthil

Esta línea permitirá que su servidor se conecte al nombre del usuario: senthil. Otro usuario será denegado. Luego de ir a tu terminal en tu servidor escribe este comando:

ssh senthil@yourhostname

¡Hecho! Buena suerte para ti Más información puede venir aquí y ver. enlace

    
respondido por el Dang_Ho 15.09.2016 - 03:49
0

Para los desesperados, comprueba tu archivo /etc/hosts para asegurarte de que no estás engañando a tu computadora para que piense que un determinado nombre de host tiene una dirección IP diferente a la que realmente tiene. & gt;. & lt;

    
respondido por el Alexander Taylor 18.10.2014 - 06:24
0

Comprobar sshd Lista de acceso para usuarios permitidos (archivo de configuración)

  1. cat /etc/ssh/sshd_config
  2. AllowUsers

no se debe establecer, se debe comentar # como se muestra en el ejemplo a continuación.

# Example of overriding settings on a per-user basis
#Match User anoncvs
#       X11Forwarding no
#       AllowTcpForwarding no
#       ForceCommand cvs server
Ciphers aes128-ctr,aes192-ctr,aes256-ctr
ClientAliveInterval 432000
ClientAliveCountMax 0
#AllowUsers TestUser
    
respondido por el willer 02.06.2017 - 22:04

Lea otras preguntas en las etiquetas