Ubuntu Desktop 17.04 de 64 bits con inicio encriptado, arranque lento

18

Volví a instalar Ubuntu 17.04 Desktop 64-bit UEFI en mi computadora portátil en un disco duro.

Ordenador portátil: Intel Core i5-5200U, Intel HD Graphics 5500, 16 GB Ram.

El arranque tarda ~ 120 segundos (desde presionar el interruptor de encendido a la pantalla de inicio de sesión, con Ubuntu 16.04.2 en un ssd toma menos de 20 segundos).

syslog

$ systemd-analyze blame
          5.187s dev-sdb2.device
          4.268s ModemManager.service
          3.138s accounts-daemon.service
          2.852s fwupd.service
          2.688s grub-common.service
          2.421s irqbalance.service
          2.367s apport.service
          2.360s gpu-manager.service
          2.269s NetworkManager.service
          1.641s thermald.service
          1.632s polkit.service
          1.567s rsyslog.service
          1.336s keyboard-setup.service
          1.241s lightdm.service
          1.240s plymouth-quit-wait.service
          1.231s speech-dispatcher.service
          1.172s udisks2.service
          1.159s apparmor.service
          1.019s alsa-restore.service
           976ms repowerd.service
           957ms upower.service
           900ms bluetooth.service
           821ms systemd-resolved.service
           792ms dev-hugepages.mount
           792ms dev-mqueue.mount
           789ms avahi-daemon.service
           755ms sys-kernel-debug.mount
           689ms systemd-cryptsetup@cryptswap1.service
           663ms systemd-modules-load.service
           638ms rtkit-daemon.service
           599ms systemd-backlight@backlight:intel_backlight.service
           540ms systemd-rfkill.service
           511ms systemd-udevd.service
           505ms systemd-fsck@dev-disk-by\x2duuid-F685\x2d7079.service
           456ms systemd-machine-id-commit.service
           455ms openvpn.service
           444ms systemd-timesyncd.service
           386ms systemd-user-sessions.service
           326ms systemd-journald.service
           321ms kmod-static-nodes.service
           273ms systemd-logind.service
           243ms colord.service
           239ms systemd-udev-trigger.service
           227ms wpa_supplicant.service
           199ms networking.service
           192ms console-setup.service
           191ms systemd-tmpfiles-setup-dev.service
           188ms pppd-dns.service
           184ms systemd-hostnamed.service
           171ms user@1000.service
           170ms systemd-localed.service
           165ms setvtrgb.service
           162ms systemd-tmpfiles-setup.service
           131ms dns-clean.service
           101ms systemd-journal-flush.service
            92ms resolvconf.service
            91ms sys-fs-fuse-connections.mount
            82ms systemd-sysctl.service
            79ms systemd-remount-fs.service
            70ms systemd-random-seed.service
            51ms ufw.service
            44ms systemd-update-utmp.service
            42ms boot-efi.mount
            37ms snapd.socket
            14ms plymouth-start.service
            11ms plymouth-read-write.service
             6ms snapd.autoimport.service
             4ms ureadahead-stop.service
             4ms dev-mapper-cryptswap1.swap
             3ms systemd-update-utmp-runlevel.service
             1ms swapfile.swap

diagrama de análisis del sistema

¿Alguna idea?

    
pregunta user58634 15.04.2017 - 08:55

2 respuestas

29

Entendido, es un problema de ubicuidad con la opción de inicio encriptada: el sistema se cuelga debido a que ecryptfs-setup-swap no funciona con archivos de intercambio !

Configuré Ubuntu con Inicio encriptado como siempre hago, con la corrección tal como se describe en el arranque del enlace pasó de ~ 200 segundos a ~ 30 segundos, esto está en un disco duro.

Editar: el problema es cuando se instala Ubuntu con el hogar encriptado, 17.04 crea un archivo de intercambio en lugar de una partición de intercambio como las versiones anteriores, luego el instalador escribe un archivo de configuración defectuoso.

Cita, del Informe de error original:

  

En particular, ecryptfs-setup-swap pone en / etc / crypttab una línea como   esto:

cryptswap1 UID=XXXXXXXX /dev/urandom
swap,offset=1024,cipher=aes-xts-plain64
     

(como si hubiera una partición de intercambio con UID = XXXXXXXX) mientras con un   swapfile debe poner la siguiente línea:

cryptswap1 /swapfile /dev/urandom
swap,offset=1024,cipher=aes-xts-plain64
     

Si cambia manualmente esa línea y reinicia, se deshace de la   problema: antes de reiniciar, verifique también que su archivo / etc / fstab termine   con:

#/swapfile none swap sw 0 0
/dev/mapper/cryptswap1 none swap sw 0 0

Debido a este error, Ubuntu pasa mucho tiempo esperando el intercambio.

culpa del análisis del sistema fija

diagrama fijo del análisis del sistema

    
respondido por el user58634 18.04.2017 - 18:09
1

La instalación con LVM habilitado también previene este problema, (para Ubuntu MATE de todos modos) ya que crea una partición de intercambio.

    
respondido por el u2764 03.05.2017 - 23:58

Lea otras preguntas en las etiquetas