Problema al reiniciar Apache 2 [duplicado]

74

Estoy intentando reiniciar Apache 2:

sudo service apache2 restart

Pero obtenga el siguiente error:

* Restarting web server apache2 

AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1.

Set the 'ServerName' directive globally to suppress this message

Intenté cambiar

sudo gedit /etc/apache2/httpd.conf

Aparece un archivo en blanco y agregué esto:

ServerName localhost

¡Pero ese error no desaparece!

¿Cómo puedo solucionar este problema?

    
pregunta Hamed Kamrava 06.08.2013 - 15:42

4 respuestas

111

Encontré esto: ¿Cómo reinicio / recargo Apache cuando no puede determinar el nombre de dominio?

  

¡Buenas noticias! Apache se reinicia exitosamente. Apache simplemente no está seguro   donde desea servir, por lo que es elegir su servidor local (127.0.0.1)   por defecto. Para evitar que aparezca este mensaje, aclare que   desea servir desde localhost (127.0.0.1) agregando la siguiente línea   en su archivo /etc/apache2/apache2.conf :

ServerName localhost
    
respondido por el Meintjes 06.08.2013 - 15:52
34

Especificar ServerName localhost en los archivos de configuración fuera de las secciones del host virtual es la forma de hacerlo.

Otras respuestas sugieren que debe modificar /etc/apache2/httpd.conf . Este archivo se sobrescribe cuando apache se actualiza desde apt. Para la configuración de Apache que no desea sobrescribir, debe crear un nuevo archivo. Aquí está la "forma de Debian" para hacer que esta configuración cambie:

# create the configuration file in the "available" section
echo "ServerName localhost" | sudo tee /etc/apache2/conf-available/servername.conf
# enable it by creating a symlink to it from the "enabled" section
sudo a2enconf servername
# restart the server
sudo service apache2 restart
    
respondido por el Stephen Ostermiller 10.03.2014 - 21:03
4

Su dirección IP de host local debería ser 127.0.0.1, en lugar de 127.0.1.1. Configure su archivo /etc/hosts correctamente. Luego edite el archivo httpd.conf :

sudo -H gedit /etc/apache2/httpd.conf

Cuando aparece un archivo en blanco, agregue esta línea, luego guárdelo:

ServerName localhost
    
respondido por el Masabza 02.03.2014 - 13:36
0

Aquí hay otra Solución:

Antes:

[root@centos ~]# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd: httpd: apr_sockaddr_info_get() failed for centos.wks.local
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
                                                           [  OK  ]

Se agregó 192.168.226.131 centos.wks.local en /etc/hosts archivo

Nota: 192.168.226.131 es mi dirección IP del servidor Apache.

Después:

[root@centos ~]# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd:                                            [  OK  ]
    
respondido por el Rahul Patil 06.08.2013 - 16:02

Lea otras preguntas en las etiquetas