El movimiento del mouse hace que la computadora deje de funcionar ¿cómo desactivar esto?

24

Es realmente molesto ya que tengo que desenchufar el mouse después de una suspensión para asegurarme de que un golpe ocasional no active el sistema. No he encontrado nada en la configuración del sistema que pueda deshabilitar esto ni buscar en Google.

    
pregunta user129498 08.02.2013 - 13:40

7 respuestas

21

Todavía no revisé el BIOS, pero encontré una solución.

Resumen breve: en /proc/acpi/wakeup , puede ver qué dispositivos están actualmente habilitados para reanudar desde la suspensión. Esa lista muestra nombres (abreviados) de los llamados "Dispositivos". Ejemplo "PWRB" significa "botón de encendido".

Si escribe nombres de dispositivos en ese archivo, puede alternar entre habilitar / deshabilitar.

Escribí un pequeño HowTo para deshabilitar el despertador por ratón , basado en un blog donde encontré esa información.

    
respondido por el user138339 08.03.2013 - 07:14
10

Gracias a todos los carteles, ya que el despertar del mouse es un gran inconveniente y obtuve mis respuestas aquí. Deseo agregar mi giro a las soluciones ya que eso puede ayudar en más casos. Tuve que deshabilitar 3 elementos diferentes en /proc/acpi/wakeup . Mis dispositivos: EHC1, EHC2, XHCI . Los primeros 2 son usb2 y el tercero una entrada usb3. Tenga en cuenta que aunque el transceptor usb para mi mouse está conectado a un puerto usb2 y no hay nada en ningún puerto usb3, la computadora se reactivará con los movimientos del mouse hasta que los 3 elementos estén deshabilitados.

$ cat /proc/acpi/wakeup | sort 
Device  S-state   Status   Sysfs node
EHC1      S3    *disabled  pci:0000:00:1d.0
EHC2      S3    *disabled  pci:0000:00:1a.0
GLAN      S4    *enabled   pci:0000:08:00.0
.. ,, ..
USB7      S3    *disabled
WLAN      S3    *disabled  pci:0000:03:00.0
XHCI      S3    *disabled  pci:0000:07:00.0

Para tener los elementos de activación desactivados en cada inicio, puede agregar algo como esto a /etc/rc.local ..

echo EHC1 > /proc/acpi/wakeup
echo EHC2 > /proc/acpi/wakeup
echo XHCI > /proc/acpi/wakeup

editar por cipricus:

Estoy editando esto porque necesitaba agregar más detalles para poder hacer otra pregunta por mi cuenta. ser cerrado como duplicado de lo anterior basado en esta respuesta; Creo que es más útil que publicar como una respuesta separada.

*** Compruebe qué elementos deben desactivarse, como se indica aquí - para cada uno de los elementos que se publicaron como enabled en cat /proc/acpi/wakeup | sort ejecutando en el terminal cada uno de los comandos siguientes y luego probando si el mouse activa el sistema (sin la necesidad de reiniciar):

sudo sh -c "echo EHC1 > /proc/acpi/wakeup"
sudo sh -c "echo EHC2 > /proc/acpi/wakeup"
sudo sh -c "echo XHCI > /proc/acpi/wakeup"

(en mi caso, el primero fue suficiente incluso después de probar con otros puertos USB)

*** Si el archivo /etc/rc.local no existe, de acuerdo con esta publicación:

printf '%s\n' '#!/bin/bash' 'exit 0' | sudo tee -a /etc/rc.local
sudo chmod +x /etc/rc.local

El archivo debería tener el siguiente aspecto:

#!/bin/bash
echo EHC1 > /proc/acpi/wakeup
echo EHC2 > /proc/acpi/wakeup
echo XHCI > /proc/acpi/wakeup

exit 0

Reiniciar

    
respondido por el Randy Skretka 17.11.2013 - 20:55
3

Mi sistema es Ubuntu 15.10

Intenté usar el comando lsusb para encontrar qué dispositivo de mouse es. Es muy simple, escribe lsusb , luego desconecta el mouse (en mi caso, es un receptor Bluetooth) y escribe lsusb nuevamente. El dispositivo se ve así:

Bus 007 Device 008: ID 24ae:2000

Ahora encuéntrelo en la carpeta /sys/bus/usb/devices/ utilizando el mismo método (desconecte / tape). En mi caso, descubrí que están en algún lugar de las carpetas que comienzan con 7-2* .

Ahora intenta leer el idProduct y idVendor. Por ejemplo: cat /sys/bus/usb/devices/7-2.3/idProduct = & gt; 2000 , cat /sys/bus/usb/devices/7-2.3/idVendor = & gt; %código%. Eso es todo.

Finalmente, creo un script en el directorio 24ae , asígnele el nombre que desee.

#! /bin/sh

if [ ! -r /sys/bus/usb/devices/7-2.3/power/wakeup ]; then
    exit 0
fi
case "" in
    pre )
    echo disabled > /sys/bus/usb/devices/7-2.3/power/wakeup
;;
esac

Todo listo.

    
respondido por el Minh Nguyen 25.12.2015 - 04:17
1

Este es mi "tutorial" paso a paso para que funcione para usted:

  1. Use el comando cat /proc/acpi/wakeup para mostrar la lista de dispositivos de activación
  2. Use el comando sudo sh -c "echo XXXX >/proc/acpi/wakeup" (reemplace "XXXX" con el código de su dispositivo) para alternar el estado del dispositivo (habilitado / deshabilitado). Vaya de un dispositivo a la vez e intente suspender el equipo y reactivarlo con el dispositivo que desee desactivar hasta que el dispositivo que se merece no pueda reactivarlo. No olvide activar siempre los dispositivos que no desea desactivar.
  3. Cuando encuentre el dispositivo correcto, cree en su archivo de escritorio "acpi_wakeup" que contenga el siguiente código: %código% (no olvide reemplazar "XXXX" con el código de su dispositivo)
  4. Mueva o copie el archivo a la carpeta #!/bin/sh printf "XXXX" > /proc/acpi/wakeup . Para copiar el archivo, use el siguiente comando: %código% (reemplace "NOMBRE DE USUARIO" con su nombre de usuario real)
  5. Hacer el archivo ejecutable: %código%
  6. Luego use 'update-rc.d' para hacer los enlaces simbólicos requeridos automáticamente en otros directorios: %código% (muestra /etc/init.d/ pero está correcto. No necesita preocuparse)
  7. Reinicia tu computadora.

Fuentes y lecturas adicionales:

enlace enlace

    
respondido por el Juraj.Lorinc 30.10.2014 - 08:10
0

Puede haber una forma específica para su hardware, en cuyo caso la opción puede estar disponible a través de la configuración del BIOS de su sistema.

Ir al menú de la BIOS para cambiar la configuración también es específico del sistema. Por lo general, presione una tecla justo después de reiniciar, y la tecla para presionar se muestra a menudo en la pantalla.

Sin embargo, la respuesta del usuario138339 parece una forma más general de lograr lo que necesita, y puede hacerlo desde el sistema en ejecución.

    
respondido por el Robie Basak 07.03.2013 - 11:44
0

este script resolvió mi problema. échale un vistazo.

    #!/bin/bash

# allow only one instance
r=$(pidof -x -o $$ ssmonoff.sh)
set -- $r
if [ "${#@}" -ge 1 ]; then
    echo "Script already running. Exit..."
    exit
fi

dbus-monitor --session "type='signal',interface='org.gnome.ScreenSaver'" | ( while read line; do
    if echo $line | grep "boolean true" &> /dev/null; then
            xinput --set-prop "Dell Premium USB Optical Mouse" "Device Enabled" "0"
            xset dpms force off
    else
            xinput --set-prop "Dell Premium USB Optical Mouse" "Device Enabled" "1"
    fi
done )

Todo lo que tienes que hacer es, primero, ejecutar sudo xinput list , encuentre el nombre dado de su mouse USB y póngalo en el script. Luego, guarde el archivo como "ssmonoff.sh", hágalo ejecutable y configúrelo para que se ejecute al inicio.

    
respondido por el yurividal 26.04.2013 - 14:17
0

Gran explicación. Simplemente agregué a rc.local el siguiente comando

for d in 'cat wakeup |grep enabled|grep -v PS2K|cut -b -4'; do echo $d >/proc/acpi/wakeup ; done

para desactivar todos los dispositivos que no sean PS2K (teclado PS2) después de la activación. ¡Simple y funcional!

    
respondido por el MeS Fet 09.11.2017 - 11:46

Lea otras preguntas en las etiquetas