Cómo deshabilitar los atajos alt-f1 / alt-f2?

18

Puedo asignar Alt + F1 y Alt + F2 a cualquier función que me guste en la configuración del teclado ventana, pero no se está utilizando. Alt + F1 siempre es 'guiar a casa' y Alt + F2 siempre se 'ejecuta'

    
pregunta remco hosman 28.04.2012 - 08:18

4 respuestas

23

Me senté con el mismo problema después de actualizar a 12.04 e instalar Gnome Shell. Traté de desactivar ALT + F1 desde cualquier lugar que pude, en vano.

Cuando estaba a punto de darme por vencida, encontré esta esencia: enlace

gsettings set org.gnome.desktop.wm.keybindings panel-main-menu "[]" # disable Alt+F1

Créditos para enlace

    
respondido por el johanmynhardt 30.04.2012 - 18:14
21

Con el plugin ubuntu unity instalado, el fragmento musinsky gist en la terminal no era suficiente.

Deshabilitar con compizconfig-settings-manager:

sudo apt-get install compizconfig-settings-manager
sudo apt-get install compiz-plugins-extra
ccsm
ubuntu unity plugin

pestaña general

  • Clave para mostrar el HUD - desactivar
  • Tecla para ejecutar un comando - desactivar

pestaña de inicio

  • Tecla para enfocar el teclado al Iniciador - desactivar
respondido por el andersoyvind 23.08.2013 - 09:09
2

En Ubuntu 16.04 puedes hacerlo usando el siguiente comando:

gsettings set org.compiz.unityshell:/org/compiz/profiles/unity/plugins/unityshell/ keyboard-focus ''
    
respondido por el rmaruszewski 08.12.2017 - 22:17
1

A pesar de que johanmynhardt nos dio la respuesta correcta para el Alt-F1, no nos dijo qué es para Alt-F2. Con el bucle for como lo muestra Jesse Glick, calculé el comando Alt-F2. Así para eliminar AMBAS teclas:

gsettings set org.gnome.desktop.wm.keybindings panel-main-menu "[]" # disable Alt+F1
gsettings set org.gnome.desktop.wm.keybindings panel-run-dialog "[]" # disable Alt-F2
    
respondido por el Alexis Wilke 22.09.2013 - 07:36

Lea otras preguntas en las etiquetas