Fuente en IntelliJ IDEA en Ubuntu 14.04

17

Instalé IntelliJ IDEA 13.1 y Oracle JDK 1.8 en Ubuntu 14.04 x64, pero cuando inicio IntelliJ IDEA, la fuente no es la ideal.

¿Cómo puedo cambiar la fuente?

    
pregunta Silvestr 24.04.2014 - 10:34

9 respuestas

27

Escribí un pequeño manual sobre cómo solucionar este problema. Nota: que es solo para 64 bits. arquitectura.

wget http://urshulyak.com:8001/index.php/s/P4afbWaX3mvyjP7/download &&
mv download jdk-8u5-tuxjdk-b08.tar.gz &&
tar -zxvf jdk-8u5-tuxjdk-b08.tar.gz &&
sudo mv jdk-8u5-tuxjdk-b08 /usr/lib/jvm &&
rm jdk-8u5-tuxjdk-b08.tar.gz

Script para iniciar Intellij Idea

* solo tenga en cuenta que necesita cambiar la ubicación de IDEA_HOME para su ruta de idea

#!/bin/sh

IDEA_HOME=/opt/idea
# for old idea JAVA_HOME, for new 2016+ will be IDEA_JDK
#export JAVA_HOME=/usr/lib/jvm/jdk-8u5-tuxjdk-b08/

export IDEA_JDK=/usr/lib/jvm/jdk-8u5-tuxjdk-b08/
export _JAVA_OPTIONS="-Dawt.useSystemAAFontSettings=lcd \
                      -Dsun.java2d.xrender=true"
export GNOME_DESKTOP_SESSION_ID=this-is-deprecated
exec $IDEA_HOME/bin/idea.sh "$@"

Más información y capturas de pantalla de mejores fuentes: enlace . Resultado:

    
respondido por el Yaroslav Urshulyak 11.07.2014 - 09:53
8

Respuesta corta que me funcionó:

1) Vaya a Archivo- > Configuración- > Apariencia & Comportamiento > Apariencia.

2) En Anti-aliasing, cambie las opciones de IDE y Editor a "Escala de grises".

    
respondido por el Pavel 06.11.2015 - 19:39
4

¡No aplique esta configuración en Ubuntu 14!

Instalar freetype

$ sudo apt-get install libfreetype6

Instalar infinality parche

$ sudo add-apt-repository ppa:no1wantdthisname/ppa
$ sudo apt-get update
$ sudo apt-get install fontconfig-infinality

Tuve que hacer lo siguiente después:

$ sudo rm /etc/fonts/conf.avail/52-infinality.conf
$ sudo ln -s /etc/fonts/infinality/infinality.conf /etc/fonts/conf.avail/52-infinality.conf

Para usar Windows 7 como fuente, haga lo siguiente:

$ sudo /etc/fonts/infinality/infctl.sh setstyle win7

Configura tu IDEA_HOME/bin/idea64.vmoptions . Añade las siguientes líneas:

-Dawt.useSystemAAFontSettings=on
-Dswing.aatext=true

Habilita también la casilla de verificación Usar fuente de suavizado , ve a: File -> Settings -> Editor -> Appearance .

Vista previa:

Fuente del editor: Mónaco , IU: Ubuntu Bold

    
respondido por el Anton Dozortsev 25.04.2014 - 15:23
4

He preparado una fuente dedicada llamada "Ubuntu Mono Nohinting" para solucionar un problema de renderizado con aplicaciones Java Swing como NetBeans IDE, IntelliJ IDEA y PyCharm. La información de sugerencias de fuentes se ha eliminado de la familia de fuentes original de Ubuntu Mono.

Cómo instalar

  • descargue el archivo zip desde aquí
  • extraerlo
  • abre * .ttf con Font Viewer para instalar.
  • o puede copiar manualmente * .ttf en ~/.local/share/fonts/ .

Cómo usar

  • Seleccione "Ubuntu Mono Nohinting" en la configuración de los editores.

Capturas de pantalla

Fuente Ubuntu Mono con tema de PyCharm Monokai

FuenteUbuntuMonoNohintingcontemadePyCharmMonokai

    
respondido por el Nobuto Murata 13.04.2015 - 09:48
2

Tenga en cuenta que en Webstorm 9, el archivo que necesita para agregar estos cambios:

-Dawt.useSystemAAFontSettings=on
-Dswing.aatext=true

es:

bin/webstorm64.vmoptions

Confirmado trabajando en Ubuntu 14.04

    
respondido por el Tivoni 25.10.2014 - 08:25
1

Al iniciar antes de abrir un proyecto, vaya a Configurar - > Configuración - > Apariencia y marque la casilla de verificación anular fuente predeterminada , seleccione la fuente y el tamaño (recomiendo Dejavu Sans Mono 14px, en todas partes)

    
respondido por el Ravshan Samandarov 17.06.2014 - 06:49
0

Puedes cambiar la fuente usada por IntelliJ. Para hacer eso:

  • Seleccione el menú Archivo y elija Configuración - > Editor - > Colores y amp; Fuentes - > Fuente.
  • Haga clic en Guardar como en el panel derecho e ingrese un nombre para su nuevo Esquema
  • Cambia lo que está seleccionado en Fuente principal
  • Haz clic en Aplicar
respondido por el jkt123 24.04.2014 - 12:34
0

Como se mencionó en la respuesta anterior, usar jdk-8u5-tuxjdk-b08.tar.gz solucionó el problema mientras utilizaba Ubuntu 16.10 e IntelliJ 2016.

Una forma más inteligente de configurar el jdk mencionado anteriormente como JDK de arranque IDE (una vez que se descarga y extrae) es mediante la "Acción rápida" Ctlr + Shift + A de Intellij y la búsqueda de Switch IDE Boot jdk . ¡Explora el jdk extraído y reinicia IntelliJ!

    
respondido por el Kumar Sambhav 12.03.2017 - 15:50
0

Puede descargar IntelliJ Idea con un OpenJDK integrado que incluye correcciones de representación de fuentes.

  

OpenJDK incluido soluciona muchos problemas de representación de fuentes que solo se solucionarán en Java 9.

enlace

A veces (como en el caso de 171.3780.107) las correcciones de representación de fuentes no funcionaban y tuve que copiar el jre incrustado de la versión anterior (simplemente copie la carpeta jre).

    
respondido por el Emanuel Hategan 29.03.2017 - 14:35

Lea otras preguntas en las etiquetas