No hay sonido en Ubuntu 13.04, solo el dispositivo de salida simulado aparece

18

Mis sonidos de repente dejaron de jugar en Ubuntu 13.04 64bit. Solo puedo ver el dispositivo de salida ficticio en la configuración de sonido y no se reproduce ningún sonido durante la prueba.

Puedo hacer que el sonido funcione temporalmente al matar uno de los procesos extraños, pero tengo que repetir lo mismo después de reiniciar

jan@jan-HP-Desktop:~$ ps -ef|grep pulseaudio
112       1405     1  0 09:38 ?        00:00:00 /usr/bin/pulseaudio --start --log-target=syslog
112       2132  1405  0 09:38 ?        00:00:00 /usr/lib/pulseaudio/pulse/gconf-helper
jan       2575     1  0 09:39 ?        00:00:00 /usr/bin/pulseaudio --start --log-target=syslog
jan       2597  2575  0 09:39 ?        00:00:00 /usr/lib/pulseaudio/pulse/gconf-helper
jan       3160  2975  0 09:40 pts/2    00:00:00 grep --color=auto pulseaudio

jan@jan-HP-Desktop:~$ sudo kill 1405

¿Existe una solución permanente para este problema?

    
pregunta theczechsensation 11.05.2013 - 16:50

7 respuestas

8

Siguiendo las instrucciones en enlace , desactivé speech-dispatcher de la siguiente manera:

sudo vi /etc/default/speech-dispatcher

Y cambié RUN=yes a RUN=no , luego reinicié.

Mi sistema ahora se inicia con sonido, y mucho más rápido.

    
respondido por el Geoff 25.05.2013 - 15:06
9

Tuve este problema después de tener un problema con Xorg, desinstalar unity y volver a instalar xfce. Mi probablem probablemente giró alrededor de no volver a agregar gconf y volver a instalar las secuencias de comandos para no volver a agregar a mi usuario a los diversos grupos de audio. Funcioné bien después de:

sudo apt-get install pulseaudio-module-x11 \
    pulseaudio-module-zeroconf \
    pulseaudio-module-gconf

Y también agregué mi nombre de usuario a grupos relacionados con el audio en /etc/groups :

audio:x:29:pulse,jreynolds
pulse:x:123:jreynolds
pulse-access:x:124:jreynolds

Y por supuesto, vaciar mis diversas configuraciones relacionadas con el pulso:

pulseaudio -k
sudo alsa force-reload
rm ~/.pulse-cookie
rm -rf ~/.config/pulse
sudo shutdown -r now

Cuando reinicié mi sistema (y no sé si era necesario) ejecuté un cheque:

pacmd list-sinks

¡Y esto muestra mis tarjetas de sonido y no el dispositivo ficticio!

    
respondido por el memnoch_proxy 15.10.2013 - 13:44
7

Esto es lo que hice, funcionó para mí. Asegúrese de que la utilidad de control de pulseaudio esté instalada:

sudo apt-get install pavucontrol

ejecuta la utilidad

pavucontrol

Mover a la pestaña más a la izquierda (configuración), hay una lista de abajo de perfiles. Trabaja en esto hasta que algo se bifurca (para mí fue "Analog Stereo Output", mientras que el predeterminado era "Salida de Digital Stereo (IEC958)")

HTH

Rob

    
respondido por el rtmie 13.05.2013 - 14:25
1

También lo tenía: ¿Funciona el sonido antes de reiniciar después de una actualización? Si es así, probablemente sea el mismo.
Es error relacionado con kernel 3.8.0-18.

  1. Ejecute uname -r para verificar su versión de Kernel. Si es 3.8.0-18-generic , prueba los siguientes pasos
  2. Reinicia y en GRUB selecciona Advanced options
  3. Elija Ubuntu with Kernel ... (Cualquiera antes de -18 )

También puedes suscribirte a este error en Launchpad, espero que lo arreglen pronto

    
respondido por el kubahaha 13.05.2013 - 16:12
1

He estado usando Ubuntu 13.04 64 bits con Kernel versión 3.8.0-19-generic. Obtuve el mismo problema con el dispositivo de salida ficticio pero lo resolví siguiendo la primera solución provista en el siguiente sitio web:

enlace

¡Espero que esto ayude!

    
respondido por el user139352 21.05.2013 - 10:06
1

Tuve el mismo problema con kernel 3.8.0-19-generic instalado. Y el kernel actualizado estaba disponible, pero estaba siendo retenido por apt-get . Así que utilicé Synaptic para instalar la actualización del kernel (3.8.0-25-generic), reinicié el sistema y el sonido volvió a funcionar.

Entonces, la solución puede ser tan simple como actualizar su kernel.

    
respondido por el Serrano 17.06.2013 - 23:25
0

Para mí, lo que funcionó fue un

sudo apt-get install linux-image-3.8.0-25-generic

reiniciar, notando, para mi horror, que ni la tarjeta de video ni la tarjeta wlan funcionaban, emitiendo un pánico

sudo apt-get remove linux-image-3.8.0-25-generic

reiniciar y, para mi alivio, encontrar nuevos (video, wlan) y viejos problemas (audio) desaparecidos de una vez.

    
respondido por el user170824 27.06.2013 - 22:42

Lea otras preguntas en las etiquetas