¿Cómo ejecuto scripts ejecutables en Nautilus?

144

Cuando hago doble clic en un script en Nautilus para ejecutarlo, el script se abre en mi editor de texto sin opción para ejecutarlo. Usando Nautilus, ¿cómo puedo ejecutar archivos de texto ejecutables y / o scripts?

    
pregunta Rob 27.04.2013 - 13:20

12 respuestas

186
  1. Abre Nautilus.

  2. Ábralo desde la barra de menú:

      

    Editar → Preferencias

  3. Seleccione la pestaña 'Comportamiento'.

  4. Seleccione "Preguntar cada vez" debajo de "Archivos de texto ejecutables".

  5. Cierre la ventana.

Ahora puedes hacer doble clic en tu archivo de texto ejecutable en Nautilus para que se te pregunte si ejecutar o editar tu script.

Respuesta de crédito: Nur

    
respondido por el Jorge Castro 13.04.2017 - 12:25
33

Sigue estos pasos:

Instalar dconf-editor porque no está instalado de manera predeterminada.

Pulse Alt + F2 , escriba dconf-editor y pulse Enter .

En dconfg-editor goto: orggnomenautiluspreferences

Haz clic en executable-text-activation y desde el menú desplegable selecciona:

lanzamiento : para iniciar scripts como programas.

O

pregunte : para preguntar qué hacer a través de un diálogo.

Cerrar dconf-editor . Eso es todo!

    
respondido por el Basharat Sialvi 27.04.2013 - 13:54
13

Creo que esto es una molestia causada por personas Gnome que decidieron cambiar esa conducta predeterminada a la que estábamos acostumbrados.

Para solucionarlo, puedes;

  1. instala (si no lo has hecho) y comienza Editor dconf ,
  2. vaya a: org & gt; gnome & gt; nautilus & gt; preferencias y
  3. cambie el valor de ejecutable-text-activation a pregunte (o incluso inicie , si lo prefiere).

Si también quieres el mismo comportamiento de Nautilus que Root, puedes repetir los pasos anteriores, iniciando Editor dconf esta vez como Root .

    
respondido por el Sadi 28.03.2013 - 15:43
8

en una terminal

gsettings set org.gnome.nautilus.preferences executable-text-activation ask
    
respondido por el OmaL 17.11.2013 - 17:49
5

Cambiar el comportamiento de Nautilus con archivos de texto ejecutables

Abrir Nautilus

  1. Archivos & gt; Preferencias
  2. Ir a la pestaña Comportamiento
  3. Seleccione Ask Each Time

Haz doble clic en el archivo de texto ejecutable en Nautilus

Voila!

Respuesta de crédito: Nur , Jorge Castro

    
respondido por el jtd 16.02.2014 - 05:54
4

GUI

  1. Según la versión de Ubuntu que tenga,

    • Antes del 13.04

      En Nautilus, ábralo desde la barra de menú:

        

      Editar → Preferencias

    • 13.04 o 13.10

      En Nautilus, ábralo desde la barra de menú:

        

      Archivos → Preferencias

    • 14.04 o 16.04

      En Nautilus, ábralo desde la barra de menú:

        

      Editar → Preferencias

  2. Luego, en la pestaña "Comportamiento", selecciona "Ejecutar archivos de texto ejecutables cuando se abren".

    Alternativamente, seleccione "Preguntar cada vez" en su lugar si desea un diálogo ( example ) preguntándole si para editar o ejecutar el archivo.

Línea de comando

Si prefiere un comando:

dconf write /org/gnome/nautilus/preferences/executable-text-activation "'launch'"

Nota: Tanto la GUI como los métodos de línea de comando solo funcionan para Nautilus (el administrador de archivos gráficos predeterminado en Ubuntu)

Originalmente de otra respuesta publicada por mí aquí .

    
respondido por el kiri 16.02.2014 - 05:57
2

Puede hacer esto para un solo archivo yendo a los permisos en las propiedades del archivo y seleccionando "ejecutar este archivo como un archivo ejecutable".

    
respondido por el cassiopeia 07.09.2014 - 11:03
2

Para eso, creo que la mejor manera será hacer que el lanzador .desktop haga que ese ejecutable sea ejecutable usando

chmod +x blah.desktop

Y después de eso, estará listo para ejecutarlo simplemente haciendo clic, y aún más puede agregarlo al iniciador. Para leer más acerca de cómo hacer que los archivos .desktop miren aquí . La parte principal es esto

[Desktop Entry]
Type=Application
Terminal=false
Icon=/path/to/icon/icon.svg
Name=give-name-here
Exec=/path/to/file/executable
    
respondido por el hingev 29.03.2013 - 08:12
1

También puede usar la respuesta más actualizada en Fedora 20 + GNOME:

Open Nautilus, check Preferences -> Behavior -> Executable Files, put as always ask
    
respondido por el gaboroncancio 22.10.2014 - 21:53
0

Debes verificar 3 puntos:

  • Configuración de Nautilus / Nemo: enlace
  • El archivo de script debe tener el permiso ejecutable : enlace
  • El sistema de archivos debe permitir la ejecución :
    1. Escriba "montar" en una consola
    2. Comprueba si tu sistema de archivos tiene noexec marca
    3. Quitar el indicador noexec al editar / etc / fstab y
respondido por el sangorys 17.05.2015 - 10:08
0

haga clic derecho en el archivo - & gt; abrir con - & gt; otra aplicación - & gt; ver todas las aplicaciones - & gt; ejecutar software - & gt; seleccione

a partir de ahora los scripts de shell se ejecutarán con doble clic.

    
respondido por el Ohad Cohen 02.07.2016 - 08:18
-1
  1. Abre Nautilus. (Explorador de archivos)

    1. En Ubuntu 17.04, ahora podemos compilar la barra para que las Preferencias estén disponibles en Archivos.

    2. Abre esto desde la barra de menú:

  2. Archivos → Preferencias

  3. Seleccione la pestaña 'Comportamiento'

  4. Seleccione "Preguntar qué hacer" en "Archivos de texto ejecutables".

  5. Ciérralo.

respondido por el HACK TECH 16.06.2017 - 08:05

Lea otras preguntas en las etiquetas