actualización de 15.10 a 16.04 apt no instalado

18

Al intentar actualizar usando el terminal, mi actualización se detiene. Esta es la línea que se muestra en la terminal:

The required dependency 'apt(>=1.0.10.2 ubuntu2)' is not installed.

mi problema es que no conozco el comando para instalar esta dependencia. Usando otros comandos, dice que apt está actualizado. ¿Soluciones?

    
pregunta paul 30.04.2016 - 22:57

4 respuestas

19

Tuvo el mismo problema, solucionado forzando la actualización de apt y limpiando la instalación actual como Andrew sugirió:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get -f install   # (not "install -f"!)
sudo apt-get -y install apt
sudo do-release-upgrade
    
respondido por el badger 02.05.2016 - 10:50
12

Tuve este error, para mí me faltaba la línea wily-updates de mi /etc/apt/sources.list:

deb http://archive.ubuntu.com/ubuntu/ wily-updates main restricted universe multiverse
    
respondido por el Neil 14.05.2016 - 06:47
4

También tuve este problema, esto actualizará todos tus regalos y también actualizarás de 15 a 16.

Ir a Software and Updates & gt; Updates

Marque las siguientes

  • Wily Security
  • Actualizaciones de Wily
  • Wily propuso

Actualizar y actualizar el sistema actual

sudo apt-get update && sudo apt-get upgrade

Obtenga la actualización

sudo apt-get dist-upgrade

Actualizar en CLI

sudo do-release-upgrade
    
respondido por el JREAM 04.08.2016 - 17:01
1

Tuve exactamente el mismo problema con 'apt'. Obtuve la solución de este enlace . Ejecutar código%. Puede ver esta entrada en el resultado del comando:

ii  apt 1.0.10.2ubuntu1      amd64         commandline package manager

Si lo hace, necesitará obtener el apt ( requerido. Estos son los pasos que seguí:

  1. Ir a Software & amp; Actualización - & gt; Software de Ubuntu. Cambie el servidor al servidor principal. (En mi caso, cambié a Servidor para India). Estaba usando un espejo diferente anteriormente y, por lo tanto, tenía una versión 'apt' más antigua.

  2. Ejecutar

        sudo apt-get update
        sudo apt-get install --reinstall apt 
    
  3. Ejecute sudo dpkg -l | grep apt nuevamente para verificar que la versión haya cambiado. Esperemos que la entrada en la salida debería haber cambiado a: apt 1.0.10.2ubuntu2 .

  4. Ejecuta un sudo dpkg -l | grep apt y luego puedes continuar con la actualización a ubuntu 16.04.

respondido por el Rahul 07.05.2016 - 11:06

Lea otras preguntas en las etiquetas