¿Cómo habilitar ufw firewall para permitir la respuesta icmp?

20

Tengo una serie de servidores Ubuntu 10.04 y cada uno tiene habilitado ufw firewall. He permitido el puerto 22 (para SSH) y 80 (si es un servidor web). Mi pregunta es que estoy tratando de habilitar la respuesta de eco icmp (respuesta ping).

ICMP funciona de forma diferente que otros protocolos: sé que está por debajo del nivel de IP en un sentido técnico. Solo puede escribir sudo ufw allow 22 , pero no puede escribir sudo ufw allow icmp

    
pregunta Jeremy Hajek 14.10.2010 - 00:08

3 respuestas

14

ufw no permite especificar reglas icmp a través del comando de la interfaz de línea de comando. Le permite ajustar su conjunto de reglas a través de sus archivos de reglas, que son archivos de estilo de restauración de iptables.

ufw permite cierto tráfico icmp por defecto, incluida la respuesta de eco icmp, y esto ya está configurado por defecto en /etc/ufw/before.rules :

-A ufw-before-input -p icmp --icmp-type echo-request -j ACCEPT

Si su host no responde al ping, busque en este archivo para asegurarse de que la línea anterior esté presente y, si eso no funciona, observe el host que hace ping y los firewalls que hay entre ellos.

    
respondido por el jdstrand 29.10.2010 - 19:50
1

Para Ubuntu 18.04, debe tener las siguientes reglas en su archivo /etc/ufw/before.rules :

# ok icmp codes for INPUT
-A ufw-before-input -p icmp --icmp-type destination-unreachable -j ACCEPT
-A ufw-before-input -p icmp --icmp-type source-quench           -j ACCEPT
-A ufw-before-input -p icmp --icmp-type time-exceeded           -j ACCEPT
-A ufw-before-input -p icmp --icmp-type parameter-problem       -j ACCEPT
-A ufw-before-input -p icmp --icmp-type echo-request            -j ACCEPT

# ok icmp code for FORWARD
-A ufw-before-forward -p icmp --icmp-type destination-unreachable -j ACCEPT
-A ufw-before-forward -p icmp --icmp-type source-quench           -j ACCEPT
-A ufw-before-forward -p icmp --icmp-type time-exceeded           -j ACCEPT
-A ufw-before-forward -p icmp --icmp-type parameter-problem       -j ACCEPT
-A ufw-before-forward -p icmp --icmp-type echo-request            -j ACCEPT

Estos estaban en mi archivo predeterminado.

Por supuesto, asegúrese de que este es realmente el problema. Mi problema era que mi computadora estaba impidiendo que los pings llegaran a la red donde existía el servidor al que intentaba hacer ping. Terminé usando un sitio web que ya estaba en Internet para hacer el ping por mí (por ejemplo, enlace ).

    
respondido por el hoadlck 28.04.2018 - 12:29
0

Aquí hay un documento de ayuda que revela cómo habilitar / deshabilitar las respuestas de ping y otros.

Ayuda de UFW

    
respondido por el Casey Keller 14.10.2010 - 00:15

Lea otras preguntas en las etiquetas