Ratón parpadeando en una de mis dos pantallas

18

Acabo de instalar ubuntu 14.04 y ahora el mouse parpadea en una de mis dos pantallas . La otra pantalla no tiene ningún parpadeo. Anteriormente estaba usando ubunutu 13.10 sin ningún problema.

  • Si desactivo la pantalla que funciona correctamente, la segunda pantalla deja de parpadear y comienza a funcionar correctamente.
  • Si desactivo la pantalla que parpadea, la otra pantalla continúa funcionando correctamente.

Ya probé las soluciones que se encuentran aquí:

Así es como se ven mis configuraciones de visualización:

Estoy usando el controlador X.Org X Server - Nouveau display driver from xserver-xorg-video-nouveau (open source) . Si intento cambiar a una versión patentada de nvidia y hago clic en el botón Apply Changes , simplemente comienza y tarda en completarse, los cambios parecen no aplicarse nunca.

Aquí está qué salidas xrandr :

Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 8192 x 8192
VGA-1 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
   1920x1080      60.0*+
   1680x1050      59.9  
   1280x1024      75.0     60.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3     56.2  
   640x480        75.0     72.8     66.7     60.0  
   720x400        70.1  
HDMI-1 disconnected (normal left inverted right x axis y axis)
VGA2 disconnected
HDMI2 disconnected
DP1 disconnected
HDMI3 disconnected
HDMI4 connected 1920x1080+1920+0 521mm x 293mm
   1920x1080      60.0*+   50.0     59.9     30.0     25.0     24.0     30.0     24.0  
   1920x1080i     60.1     50.0     60.0  
   1680x1050      59.9  
   1280x1024      75.0     60.0  
   1280x720       60.0     50.0     59.9  
   1440x576i      50.1  
   1024x768       75.1     60.0  
   1440x480i      60.1     60.1  
   800x600        75.0     60.3     56.2  
   720x576        50.0  
   720x480        60.0     59.9  
   640x480        75.0     72.8     66.7     60.0     59.9  
   720x400        70.1  
DP2 disconnected
DP3 disconnected
VIRTUAL1 disconnected
  1920x1080 (0x4b)  148.5MHz
        h: width  1920 start 2008 end 2052 total 2200 skew    0 clock   67.5KHz
        v: height 1080 start 1084 end 1089 total 1125           clock   60.0Hz
  1680x1050 (0xa2)  119.0MHz
        h: width  1680 start 1728 end 1760 total 1840 skew    0 clock   64.7KHz
        v: height 1050 start 1053 end 1059 total 1080           clock   59.9Hz
  1280x1024 (0xa3)  135.0MHz
        h: width  1280 start 1296 end 1440 total 1688 skew    0 clock   80.0KHz
        v: height 1024 start 1025 end 1028 total 1066           clock   75.0Hz
  1280x1024 (0xa4)  108.0MHz
        h: width  1280 start 1328 end 1440 total 1688 skew    0 clock   64.0KHz
        v: height 1024 start 1025 end 1028 total 1066           clock   60.0Hz
  1024x768 (0xa5)   78.8MHz
        h: width  1024 start 1040 end 1136 total 1312 skew    0 clock   60.1KHz
        v: height  768 start  769 end  772 total  800           clock   75.1Hz
  1024x768 (0xa6)   65.0MHz
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock   48.4KHz
        v: height  768 start  771 end  777 total  806           clock   60.0Hz
  800x600 (0xa7)   49.5MHz
        h: width   800 start  816 end  896 total 1056 skew    0 clock   46.9KHz
        v: height  600 start  601 end  604 total  625           clock   75.0Hz
  800x600 (0xa8)   40.0MHz
        h: width   800 start  840 end  968 total 1056 skew    0 clock   37.9KHz
        v: height  600 start  601 end  605 total  628           clock   60.3Hz
  800x600 (0xa9)   36.0MHz
        h: width   800 start  824 end  896 total 1024 skew    0 clock   35.2KHz
        v: height  600 start  601 end  603 total  625           clock   56.2Hz
  640x480 (0xaa)   31.5MHz
        h: width   640 start  656 end  720 total  840 skew    0 clock   37.5KHz
        v: height  480 start  481 end  484 total  500           clock   75.0Hz
  640x480 (0xab)   31.5MHz
        h: width   640 start  664 end  704 total  832 skew    0 clock   37.9KHz
        v: height  480 start  489 end  491 total  520           clock   72.8Hz
  640x480 (0xac)   30.2MHz
        h: width   640 start  704 end  768 total  864 skew    0 clock   35.0KHz
        v: height  480 start  483 end  486 total  525           clock   66.7Hz
  640x480 (0xad)   25.2MHz
        h: width   640 start  656 end  752 total  800 skew    0 clock   31.5KHz
        v: height  480 start  490 end  492 total  525           clock   60.0Hz
  720x400 (0xae)   28.3MHz
        h: width   720 start  738 end  846 total  900 skew    0 clock   31.5KHz
        v: height  400 start  412 end  414 total  449           clock   70.1Hz
    
pregunta Timothée Jeannin 19.04.2014 - 14:04

9 respuestas

2

Tuve el mismo problema cuando conecté mi segunda pantalla al puerto VGA. Problema resuelto cuando cambié a DVI. Encontré otro problema al usar Display Port con un adaptador VGA. El sistema se vuelve loco y no puede detectar la resolución correctamente. Todo un desastre.

    
respondido por el Thiago Zanetti 09.04.2015 - 18:07
1

Intente conectar su monitor en el puerto VGA si es posible. Tengo una computadora portátil con 2 monitores externos conectados, uno en el puerto VGA y el otro en el puerto HDMI. El hardware es NVidia Optimus. Con los 2 monitores conectados, el cursor del mouse parpadea en la pantalla integrada (la pantalla HDMI funciona bien). Si desconecto el monitor HDMI, el parpadeo de la pantalla incorporada se detiene. Este es probablemente un error con los controladores nvidia de código abierto. Cuéntanos más sobre tu hardware.

    
respondido por el sмurf 29.04.2014 - 03:17
1

Ve a una terminal y escribe o copia & amp; pegue [ sudo apt-get install linux-source ] - presione enter, le preguntará si realmente desea instalar, solo diga SÍ.

Luego en el mismo tipo de terminal - [ sudo apt-get remove --purge nvidia-* ] - O - [ sudo apt-get remove nvidia-current ] - O - [ sudo apt-get remove nvidia-current-updates ] - luego apague y reinicie.

Después de reiniciar, su sistema usará un controlador genérico, vaya a Software & amp; actualizaciones (controladores adicionales) y haga clic en uno de los controladores binarios de NVIDIA enumerados, debe tener un par para elegir, ya sea (propietario, probado) o (propietario), no usaría el controlador de pantalla Nouveau, es un controlador genérico y no da una función completa.

Haga clic en uno de los controladores enumerados y haga clic en aplicar cambios en la esquina inferior derecha y permita que ese controlador se instale, después de su instalación completa, reinicie el sistema. Si el controlador en el que hizo clic funciona sin problemas, si todavía tiene problemas, debe eliminar completamente ese controlador utilizando el comando de eliminar como se indica arriba y probar el otro controlador que figura en su casilla (controladores adicionales). ¡La CLAVE es para eliminar completamente cualquier otro controlador que esté en su sistema o seguramente tendrá problemas!

Para que lo sepas, puedes copiar y pegar todos mis comandos sudo , son correctos :-) No uses [o] al copiar o escribir, solo son para la separación. Espero que esto haya ayudado, por lo que puedes DISFRUTAR de usar LINUX tanto como yo.

    
respondido por el jim frederick 31.10.2014 - 16:34
1

Tuve este problema en 14.04 con una configuración similar. También, en algún momento, tuve un problema de retraso en la edición de texto de uno de mis monitores.

Tenía dos tarjetas de video: una con 1 puerto DVI y la otra con un puerto VGA y DVI.

Al final, determiné que mi problema era que estaba mezclando tarjetas de video: estaba usando dos puertos DVI de dos tarjetas diferentes. Al usar solo una tarjeta de video, usando los puertos VGA y DVI de esa única tarjeta, todos mis problemas desaparecieron.

    
respondido por el graham 06.05.2016 - 23:52
0

Debajo de su monitor verde hay un monitor Desconocido. Mueva el monitor verde, seleccione el monitor Desconocido y desactívelo.

    
respondido por el 1 Ariel 1 27.04.2014 - 01:52
0

No tengo el mismo problema, pero uno similar.
En mi caso, la pantalla es táctil, resolví desactivar la pantalla táctil como entrada:

  1. sudo gedit /usr/share/X11/xorg.conf.d/10-evdev.conf del terminal
  2. Agregue Option "Ignore" "on" al final de la sección de pantalla táctil (dentro de ella)
  3. Reiniciar
respondido por el cloutz 01.01.2015 - 20:46
0

Tiene exactamente el mismo problema. Solucionado parcialmente con la solución en este informe de error: Partes de la IU parpadean aleatoriamente al mover el mouse

sudo add-apt-repository ppa:townsend/compiz-nvidia-refresh-test
sudo apt-get update
sudo apt-get dist-upgrade

Al menos ahora no parpadea cuando muevo el mouse.

    
respondido por el Karolis Šarapnickis 09.03.2015 - 15:27
0

He tenido este problema desde Ubuntu 14.10, con una configuración similar. Acabo de darme por vencido con Unity y ejecutar la sesión de flashback de Metacity en su lugar.

Me gusta la Unidad, pero no soporto el cursor jugando a las escondidas.

    
respondido por el ASalazar 05.04.2015 - 00:59
0

Tuve el mismo problema con Lenovo P50 con la tarjeta gráfica NVIDIA. Lo resolví cambiando la configuración de visualización a discreto desde híbrido. Ahora no parpadea.

    
respondido por el TonyParker 14.05.2017 - 15:09

Lea otras preguntas en las etiquetas