SLOW Boot and Login times Ubuntu 16.04

18

Ubuntu 16.04 64 bits tarda alrededor de 20 segundos desde la pantalla de inicio de sesión en el escritorio y alrededor de 20 segundos desde grub a la pantalla de inicio de sesión,

dime qué servicios puedo desactivar de forma segura, no uso Virtualbox y Bluetooth con frecuencia, todo lo demás se usa como impresora, wifi, etc.
salida de systemd-analyze

Startup finished in 5.145s (kernel) + 14.138s (userspace) = 19.284s

y salida de

systemd-analyze blame


 5.837s accounts-daemon.service
          5.444s dev-sda6.device
          4.864s grub-common.service
          4.105s lightdm.service
          4.075s ModemManager.service
          4.001s preload.service
          3.844s apparmor.service
          3.566s networking.service
          3.468s apport.service
          3.332s ondemand.service
          3.272s rsyslog.service
          3.269s systemd-logind.service
          3.253s alsa-restore.service
          3.241s gpu-manager.service
          3.226s avahi-daemon.service
          3.185s systemd-user-sessions.service
          3.185s pppd-dns.service
          2.508s NetworkManager.service
          2.003s user@1000.service
          1.640s plymouth-quit-wait.service
          1.245s colord.service
           712ms systemd-update-utmp.service
           687ms systemd-udevd.service
           669ms udisks2.service
           632ms polkitd.service
           602ms brltty.service
           572ms systemd-localed.service
           567ms systemd-backlight@backlight:intel_backlight.service
           543ms systemd-rfkill.service
           527ms systemd-tmpfiles-setup-dev.service
           519ms thermald.service
           490ms systemd-tmpfiles-setup.service
           464ms systemd-modules-load.service
           454ms systemd-tmpfiles-clean.service
           450ms systemd-timesyncd.service
           428ms systemd-journald.service
           371ms wpa_supplicant.service
           340ms ufw.service
           317ms systemd-random-seed.service
           284ms console-setup.service
           281ms plymouth-start.service
           270ms dev-hugepages.mount
           270ms sys-kernel-debug.mount
           224ms systemd-udev-trigger.service
           177ms dev-mqueue.mount
           168ms plymouth-read-write.service
           165ms upower.service
           131ms dns-clean.service
           103ms systemd-sysctl.service
           102ms dev-disk-by\x2duuid-8bd6db03\x2da87b\x2d4614\x2d927a\x2dd5916f3
            68ms systemd-hostnamed.service
            49ms systemd-journal-flush.service
            47ms kmod-static-nodes.service
            47ms snapd.socket
            32ms systemd-remount-fs.service
            28ms rc-local.service
            10ms resolvconf.service
            10ms rtkit-daemon.service
             9ms systemd-update-utmp-runlevel.service
             6ms ureadahead-stop.service
             4ms sys-fs-fuse-connections.mount lines 39-61/61 (END)

Además de:

systemd-analyze critical-chain

the time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @14.124s
└─lightdm.service @10.018s +4.105s
  └─systemd-user-sessions.service @6.731s +3.185s
    └─basic.target @6.625s
      └─sockets.target @6.625s
        └─snapd.socket @6.576s +47ms
          └─sysinit.target @6.574s
            └─swap.target @6.574s
              └─dev-disk-by\x2duuid-8bd6db03\x2da87b\x2d4614\x2d927a\x2dd5916f3c
                └─dev-disk-by\x2duuid-8bd6db03\x2da87b\x2d4614\x2d927a\x2dd5916f
lines 1-13/13 (END)

estoy usando un HDD con 7200 RPM, creo que el tiempo de arranque está bien, pero después de la pantalla de inicio de sesión, tengo que pasar 20 segundos con una pantalla en blanco, ya he desactivado algunos elementos de inicio como ORCA, BLUETOOTH, monitor de respaldo, accesibilidad, etc., compartir archivos personales y actualizar carpetas de usuarios, etc., nada mejora, cómo diagnosticar al culpable y tratarlo.

    
pregunta Kanhiya 25.05.2016 - 09:58

1 respuesta

5

Intente eliminar algunas dependencias no utilizadas y paquetes huérfanos. Esto ayudará.
Funcionó en mi caso. Ejecutar:

sudo apt autoremove && sudo apt autoclean

Además, puedes instalar Gtkorphan ( sudo apt-get install gtkorphan ) para eliminar todos los paquetes huérfanos y las dependencias dejadas por otras aplicaciones.

    
respondido por el Collin 10.09.2016 - 22:50

Lea otras preguntas en las etiquetas