Apt-get diciendo "No se pueden corregir los problemas, se han retenido los paquetes rotos." [duplicar]

18
  

TL; DR: sudo apt-get install ... que dice "No se pueden corregir los problemas; se han guardado paquetes rotos".

El problema

Intenté obtener la función WebApps para PP y QQ siguiendo esta publicación de blog .

Ejecuté el comando sudo add-apt-repository ppa:webapps/preview para agregar el repositorio, pero recibí un error de conexión. Como sé que mi ISP actual da una conexión inestable, lo intenté de nuevo y, efectivamente, funcionó.

Luego ejecuté sudo apt-get install unity-webapps-preview , pero me di cuenta de que teníamos que actualizar apt-get primero, así que presioné Ctrl + C para detenerlo. Luego ejecuté sudo apt-get update , que funcionó sin problemas, pero cuando ejecuté sudo apt-get install unity-webapps-preview más tarde, apareció un mensaje de error. Aquí está el volcado:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 unity-webapps-preview : Depends: xul-ext-unity but it is not going to be installed
                         Depends: xul-ext-websites-integration but it is not going to be installed
                         Depends: xul-ext-webaccounts but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Creo que esto podría deberse a que interrumpí el comando anterior. Sin embargo, no había tenido la oportunidad de producir nada, lo detuve bastante rápido.

Lo que probé

Comandos

Probé esto: -

  • sudo apt-get install --fix-broken
  • sudo apt-get autoclean
  • sudo apt-get autoremove
  • sudo apt-get -f install

Pero incluso después de ejecutar sudo apt-get upgrade después de cada intento, ninguno funcionó.

Purga

Intenté purgar el repositorio, pero tampoco funcionó. Primero, obtuve el paquete usando sudo apt-get install ppa-purge and then tried to purge the WebApps repo using sudo ppa-purge ppa: webapps / preview '.

Instalación manual de dependencias

Si observa cuidadosamente el volcado de error, dice:

  

Depende de: xul-ext-unity pero no se va a instalar   Depende de: xul-ext-websites-integration pero no va a ser instalado   Depende de: xul-ext-webaccounts, pero no se va a instalar

Intenté instalarlos manualmente. Ejecuté sudo apt-get install xul-ext-unity , pero obtuve esto:

  

Depende de: xul-ext-websites-integration pero no se va a instalar   Breaks: firefox (& gt; = 15. +) pero se instalará 16.0 ~ b6 + build1-0ubuntu0.12.04.1 ~ mfn4

No tengo idea de qué significa la segunda parte, pero traté de resolver la primera. Ejecutando sudo apt-get install xul-ext-websites-integration dio:

  

xul-ext-websites-integration: Breaks: firefox (& gt; = 15. +) pero se instalará 16.0 ~ b6 + build1-0ubuntu0.12.04.1 ~ mfn4

Como último recurso, probé sudo apt-get install xul-ext-webaccounts , pero también me dio el mismo mensaje:

  

Breaks: firefox (& gt; = 14. +) pero se instalará 16.0 ~ b6 + build1-0ubuntu0.12.04.1 ~ mfn4

¿Qué significa Breaks: firefox (>= 14.+) but 16.0~b6+build1-0ubuntu0.12.04.1~mfn4 is to be installed ?

Investigación

Intenté buscar Google , mirando un par de foros , mirando esta pregunta y búsqueda en AU, pero fue en vano. Ayuda sería apreciada.

    
pregunta Yatharth Agarwal 06.10.2012 - 14:39

1 respuesta

4

try sudo apt-get -f install command

    
respondido por el Vikramjeet 06.10.2012 - 15:03

Lea otras preguntas en las etiquetas