18.04, 16.04 Auriculares detectados, pero no se encienden automáticamente después del inicio

23

Editar: el problema parece afectar también a 18.04.

Tengo este problema desde 15.10, pero comenzó a aflorar realmente mis engranajes después de hacer una actualización a 16.04.

Digamos que tengo los auriculares enchufados. reinicio \ relog en \ boot a ubuntu y toco la música. Sale de altavoces incorporados en lugar de auriculares .

Veo que los auriculares se detectan en el menú de configuración de audio , pero solo después de cambiar el dispositivo o volver a conectar los auriculares, funcionan.

Esto era más fácil de ignorar en 15.10, porque en ese momento, después de un inicio, todo estaba silenciado. Auriculares y altavoces, si los auriculares estaban presentes antes de dicha puesta en marcha.

Añadiría registros a la pregunta, pero realmente no sé cuál, o cómo obtenerlos (estoy abierto para recibir sugerencias). El problema ocurre en una computadora portátil Dell Inspiron 3537 , tiene una tarjeta de sonido Realtek dentro.

Tiene una toma de salida lateral, que actúa como entrada y salida.

Salida de pacmd listcards

2 card(s) available.
    index: 0
    name: <alsa_card.pci-0000_00_03.0>
    driver: <module-alsa-card.c>
    owner module: 6
    properties:
        alsa.card = "0"
        alsa.card_name = "HDA Intel HDMI"
        alsa.long_card_name = "HDA Intel HDMI at 0xc0810000 irq 49"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:03.0"
        sysfs.path = "/devices/pci0000:00/0000:00:03.0/sound/card0"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.id = "0a0c"
        device.product.name = "Haswell-ULT HD Audio Controller"
        device.form_factor = "internal"
        device.string = "0"
        device.description = "Wbudowany dźwięk"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    profiles:
        output:hdmi-stereo: Wyjście Digital Stereo (HDMI) (priority 5400, available: unknown)
        output:hdmi-surround: Wyjście Digital Surround 5.1 (HDMI) (priority 300, available: unknown)
        output:hdmi-surround71: Wyjście Digital Surround 7.1 (HDMI) (priority 300, available: unknown)
        output:hdmi-stereo-extra1: Wyjście Digital Stereo (HDMI 2) (priority 5200, available: unknown)
        output:hdmi-surround-extra1: Wyjście Digital Surround 5.1 (HDMI 2) (priority 100, available: unknown)
        output:hdmi-surround71-extra1: Wyjście Digital Surround 7.1 (HDMI 2) (priority 100, available: unknown)
        output:hdmi-stereo-extra2: Wyjście Digital Stereo (HDMI 3) (priority 5200, available: unknown)
        output:hdmi-surround-extra2: Wyjście Digital Surround 5.1 (HDMI 3) (priority 100, available: unknown)
        output:hdmi-surround71-extra2: Wyjście Digital Surround 7.1 (HDMI 3) (priority 100, available: unknown)
        off: Wyłączone (priority 0, available: unknown)
    active profile: <output:hdmi-stereo>
    sinks:
        alsa_output.pci-0000_00_03.0.hdmi-stereo/#0: Wbudowany dźwięk Digital Stereo (HDMI)
    sources:
        alsa_output.pci-0000_00_03.0.hdmi-stereo.monitor/#0: Monitor of Wbudowany dźwięk Digital Stereo (HDMI)
    ports:
        hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "video-display"
        hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "video-display"
        hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "video-display"
    index: 1
    name: <alsa_card.pci-0000_00_1b.0>
    driver: <module-alsa-card.c>
    owner module: 7
    properties:
        alsa.card = "1"
        alsa.card_name = "HDA Intel PCH"
        alsa.long_card_name = "HDA Intel PCH at 0xc0814000 irq 48"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:1b.0"
        sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card1"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.id = "9c20"
        device.product.name = "8 Series HD Audio Controller"
        device.form_factor = "internal"
        device.string = "1"
        device.description = "Wbudowany dźwięk"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    profiles:
        input:analog-stereo: Wejście Analogowe stereo (priority 60, available: unknown)
        output:analog-stereo: Wyjście Analogowe stereo (priority 6000, available: unknown)
        output:analog-stereo+input:analog-stereo: Analogowy dupleks stereo (priority 6060, available: unknown)
        off: Wyłączone (priority 0, available: unknown)
    active profile: <output:analog-stereo+input:analog-stereo>
    sinks:
        alsa_output.pci-0000_00_1b.0.analog-stereo/#1: Wbudowany dźwięk Analogowe stereo
    sources:
        alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#1: Monitor of Wbudowany dźwięk Analogowe stereo
        alsa_input.pci-0000_00_1b.0.analog-stereo/#2: Wbudowany dźwięk Analogowe stereo
    ports:
        analog-input-internal-mic: Wewnętrzny mikrofon (priority 8900, latency offset 0 usec, available: unknown)
            properties:
                device.icon_name = "audio-input-microphone"
        analog-input-headphone-mic: Mikrofon (priority 8700, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "audio-input-microphone"
        analog-input-headset-mic: Mikrofon na słuchawkach (priority 8700, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "audio-input-microphone"
        analog-output-speaker: Głośniki (priority 10000, latency offset 0 usec, available: unknown)
            properties:
                device.icon_name = "audio-speakers"
        analog-output-headphones: Słuchawki (priority 9000, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "audio-headphones"
    
pregunta Błażej Michalik 09.05.2016 - 03:49

5 respuestas

6

Mi opinión sobre esto sería la siguiente aprovechando PulseAudio. Suponiendo que cuando inicie sesión en Ubuntu, siempre tenga sus auriculares conectados, entonces lo siguiente se asegurará de que cuando inicie Ubuntu, automáticamente lo configure como Entrada y Salida por defecto (suponiendo que quiera ambos).

En Ubuntu vaya a la terminal y escriba lo siguiente, de la cual solo obtendrá el número de índice:

Para sus DISPOSITIVOS DE SALIDA :

pacmd list-sinks - Habrá mucha información pero busque los Números de Índice y el dispositivo correspondiente que será su nuevo Dispositivo de Salida predeterminado.

Para sus DISPOSITIVOS DE ENTRADA :

pacmd list-sink-inputs OR pacmd list-samples - Habrá mucha información pero busque los Números de Índice y el dispositivo correspondiente que será su nuevo Dispositivo de Entrada predeterminado. Use los ejemplos de la lista en caso de que en la lista-sumidero-entradas no se muestre.

Hasta este punto, en Ubuntu, con los auriculares conectados, debería tener 2 números índices. Uno para su entrada y salida. Ahora iremos y editaremos tu configuración predeterminada de pulseaudio:

sudo nano /etc/pulse/default.pa

Ve a la última línea y simplemente agrega lo siguiente:

set-default-sink 1 - Esto corresponde a la Fuente de salida después de mirar el índice de pacmd list-sinks . El 1 es el índice, así que cámbialo por el que tienes.

set-default-source 5 - Esto corresponde a las Fuentes de entrada después de mirar el índice de pacmd list-sink-inputs o pacmd list-samples . El número 5 es el índice, así que cámbialo por el que tienes.

Guarde el archivo y reinicie la computadora para probar. La prueba implica comprobar si obtuvo el valor de índice correcto, ya que algunos dispositivos tienen nombres similares (como las fuentes de audio NVIDIA O INTEL).

Si todo está configurado correctamente, cada vez que inicie su computadora, debería ver que Ubuntu establece la entrada / salida predeterminada en sus auriculares. Ya que está hablando de Auriculares, para la reducción de ruido puede usar mi otra respuesta para ayudarlo con eso: ¿Eliminación de ruido en tiempo real con PulseAudio?

NOTA: También puede usar pacmd list-sources para ver todos los dispositivos y, además, en lugar de usar el número de índice, puede usar el nombre del dispositivo asignado, que se verá más o menos así:

alsa_input.usb-Logitech_Logitech_USB_Headset-00.analog-mono.echo-cancel para darte una idea de qué nombres buscar (Súper largo lo sé). Los nombres son más precisos de usar, pero más difíciles de recordar, por lo que tiene una opción aquí para usar uno u otro. El resultado final con un nombre sería así:

set-default-source alsa_input.usb-Logitech_Logitech_USB_Headset-00.analog-mono.echo-cancel en el archivo default.pa, solo para darle una idea.

Para una opción de GUI, recomiendo pavucontrol o PulseAudio Volume Control. Ofrece una opción para configurar un dispositivo como predeterminado / alternativo para dispositivos de Entrada y Salida. Usar ambas técnicas puede darte lo que quieres.

    
respondido por el Luis Alvarado 14.05.2016 - 18:49
3

Si sus dispositivos de sonido son 0 - HDMI y 1 - analógico, puede cambiar a auriculares con

$ pacmd set-sink-port 1 analog-output-headphones

Para que sea permanente, edita /etc/pulse/default.pa y en la parte inferior debajo de ### Make some devices default put:

set-default-sink 1
set-sink-port 1 analog-output-headphones

Todo debería funcionar ahora como se desee. Asegúrate de comentar esto cuando estés cansado de usar los auriculares.

    
respondido por el emk2203 15.05.2016 - 16:00
0

Lo siguiente debería ayudarlo a solucionar el problema hasta que encuentre una solución a su problema.

Los siguientes son algunos scripts que no hacen lo que quieren, pero probablemente contienen todas las piezas para lo que necesitan.

El segundo contiene un montón de cosas de pulseaudio que funcionan, pero que realmente no entiendo. Me disculpo de antemano. ;)

Aquí hay un script que solía usar para volver a encender mis altavoces después del arranque. Debe ser fácil de modificar para configurar su salida de audio como desee.

#!/bin/bash
## temporary kludge to turn the speakers back on at login

SOUND=1
if [ "" == "-q" ]
then
  shift
  SOUND=0
fi

amixer set Speaker unmute > /dev/null
amixer set Speaker 100 > /dev/null
(( SOUND )) && mplayer -quiet /usr/lib/libreoffice/basis3.4/share/gallery/sounds/kongas.wav > /dev/null 2>&1

Éste cambia automáticamente mi salida de sonido entre HDMI y salida analógica dependiendo de si HDMI está conectado o no. No es lo que quiere, pero sí detecta a dónde va la salida de audio y sabe cómo cambiarla a otra parte.

#!/bin/bash
## audio_select
## Copyleft 08/11/2014 - JPmicrosystems
## Last modified 05/14/2015
## Added code to detect ramdass vs halo to handle older pactl version
## Added code to tell if the audio was already selected
## If HDMI is connected, audio output is channelled to HDMI
## Otherwise it's channelled to internal audio

## From: https://ubuntusp.info/questions/12688/cambiar-hdmi-audio-cuando-hdmi-esta-conectado-una-computador"${NAME}" ]
  then
    SCRIPT_NAME="${NAME}"
  else
    SCRIPT_NAME="$(basename %pre%)"
  fi
}

## Get active audio port type
function get_active_audio_port {
  ## first very rough cut
  local ACTIVE_AUDIO_PORT_NAME
  RC=0 ## Success
  ACTIVE_AUDIO_PORT_NAME="$(pactl list | grep 'Active Port:' | awk '{print }')"
  case "${ACTIVE_AUDIO_PORT_NAME}" in
    "analog-output-speaker")
      ACTIVE_AUDIO_PORT="Speakers"
      ;;
     "analog-output-headphones")
      ACTIVE_AUDIO_PORT="Headphones"
      ;;
    "hdmi-output-0")
      ACTIVE_AUDIO_PORT="HDMI"
    ;;
    *)
      ACTIVE_AUDIO_PORT="Unknown"
      RC=1 ## Failure
    ;;
  esac

  return $RC
 }

##source "$HOME/bin/bash_trace" ## debug
script_name
HOST="$(hostname)"
HDMI_STATUS=$(cat /sys/class/drm/card0/*HDMI*/status)
INPUTS=($(pacmd list-sink-inputs | grep index | awk '{print }'))
DSPTIME=10            # yad message persistence time
YOPT="--center --on-top --title ${SCRIPT_NAME}"  # yad common options

get_active_audio_port ## Find out where audio is going now
if ((RC))
then
  yad ${YOPT} --info --button=gtk-ok:0 --text="Failed to detect current audio source" --width 250 --timeout=${DSPTIME}
  exit 1
fi

if [ $HDMI_STATUS = "connected" ]
then
  if [ "${ACTIVE_AUDIO_PORT}" == "HDMI" ]
  then
    yad ${YOPT} --info --button=gtk-ok:0 --text="Audio already set to HDMI" --width 250 --timeout=${DSPTIME}
    exit 1
  fi
  pactl set-card-profile 0 output:hdmi-stereo
  if [ "$HOST" == "ramdass" ]  ## Using newer version of pactl
  then
    pactl set-default-sink alsa_output.pci-0000_00_1b.0.hdmi-stereo
  else
    pactl set-sink-port alsa_output.pci-0000_00_1b.0.hdmi-stereo hdmi-output-0
  fi
  for i in ${INPUTS[*]}
  do
    pacmd move-sink-input $i alsa_output.pci-0000_00_1b.0.hdmi-stereo  &> /dev/null
  done

  yad ${YOPT} --info --button=gtk-ok:0 --text="Audio directed to HDMI" --width 250 --timeout=${DSPTIME}
else
  if [ "${ACTIVE_AUDIO_PORT}" == "Speakers" ] || [ "${ACTIVE_AUDIO_PORT}" == "Headphones" ]
  then
    yad ${YOPT} --info --button=gtk-ok:0 --text="Audio already set to Analog Output" --width 250 --timeout=${DSPTIME}
    exit 1
  fi
  pactl set-card-profile 0 output:analog-stereo
  if [ "$HOST" == "ramdass" ]  ## Using newer version of pactl
  then
    pactl set-default-sink alsa_output.pci-0000_00_1b.0.analog-stereo
  else
    pactl set-sink-port alsa_output.pci-0000_00_1b.0.analog-stereo analog-output-speaker                
  fi

  for i in ${INPUTS[*]}
  do
    pacmd move-sink-input $i alsa_output.pci-0000_00_1b.0.analog-stereo  &> /dev/null
  done

  yad ${YOPT} --info --button=gtk-ok:0 --text="Audio directed to Analog Output" --width 250 --timeout=${DSPTIME}
fi
    
respondido por el Joe 11.05.2016 - 22:25
0

De acuerdo, creo que tengo algo que puedes probar.
Si busca Seleccionar sistemas multimedia en el tablero. Ábrelo y ve a la pestaña Audio , donde puedes seleccionar los dispositivos de entrada y salida de audio predeterminados.

Esto debe instalarse por defecto. Si no es así, siempre puedes ejecutar %código%. Si no se muestra en el tablero, ejecute:

sudo apt-get install gnome-media . En el archivo de texto resultante, vaya a la línea que comienza con gksudo gedit /usr/share/applications/gstreamer-properties.desktop Cambie el NoDisplay=. a NoDisplay=true Espero que ayude!

    
respondido por el James 19.05.2016 - 00:05
-3

Hay dos posibilidades.

Ya sea en BIOS, elija audio HD a AC'97 (que funcionó para mí) o en tipo de terminal:

sudo apt-get install  kubuntu-desktop

y elige KDE.

    
respondido por el Tiago Costa 27.07.2016 - 23:27

Lea otras preguntas en las etiquetas