Ubuntu 17.10 toneladas de rezagos con fallas de mouse y ventanas

23

He instalado Ubuntu 17.10 en mi computadora portátil sin ningún problema, pero cuando uso el sistema todo se demora y no es fluido. Los fallos técnicos del mouse (estoy usando un mouse físico y un track-pad), como saltos, y no son fluidos.

Es lo mismo con las ventanas cuando las arrastro o simplemente abro cualquier aplicación. Lo mismo está sucediendo cuando abro la página de la aplicación de Gnome.

Intenté cambiar de Wayland a Xorg desde la pantalla de bloqueo y, al hacerlo, el mouse ahora funciona sin problemas, pero todavía tengo problemas de fallas y fluidez en todas partes.

¿Esto es un problema con mi computadora o Ubuntu tiene un problema de algún tipo con Gnome en algunos dispositivos y qué puedo hacer para solucionarlo?

Mi computadora portátil es una Asus Q501LA . No tengo una tarjeta gráfica dedicada.

    
pregunta vinid223 20.10.2017 - 21:09

5 respuestas

12

Desafortunadamente, no creo que esto sea solo un problema de Wayland. Después de actualizar desde 17.04, he encontrado una respuesta lenta / lenta con gnome-shell tanto en Wayland como en Xorg. Parece ser un poco peor en Wayland.

En mi caso, después de reiniciar, todo está bien por un tiempo, pero las cosas se degradan lentamente y después de unas pocas horas, el cambio entre escritorios virtuales o ventanas móviles se vuelve cada vez más lento. Cuando se activa la pantalla de bloqueo, después de presionar una tecla para que aparezca el mensaje de contraseña, hay un desfase definido, es decir, en un par de ocasiones 15 segundos antes de que se borre el fondo de pantalla de la pantalla de bloqueo y aparezca el mensaje de contraseña.

Esto está en una máquina de alta especificación, es decir, 12 core i7 3Ghz con 32 Gb de memoria. Estoy usando los controladores de gráficos oss predeterminados (tengo una tarjeta nvidia gforce, pero no uso el controlador nvidia ya que no es compatible con wayland).

No tuve estos problemas con 17.04 y el gnome ubuntu remix.

Ahora instalé MATE y veo si funciona mejor, ya que el gnome-shell se vuelve lo suficientemente lento para ser casi inutilizable a menos que reinicie cada pocas horas.

Usando journalctl para ver los registros, veo muchos errores y advertencias relacionados con gnome-shell.

Todo bastante decepcionante. También tuve la mala suerte de toparme con el error relacionado con algunos teclados Logitech, ¡así que tuve que cambiar mi teclado para que incluso funcionara el 17.10!

    
respondido por el Tim X 02.11.2017 - 06:02
5

GNOME tiene una historia de ser increíblemente lento. He experimentado los problemas que ha descrito en Ubuntu 17.10 y no pude encontrar una solución. Sugeriría degradar GNOME a la versión 3.24 o simplemente degradar Ubuntu a la versión 17.04.

    
respondido por el Chili Bebber 22.10.2017 - 21:46
1

Tengo instaladas extensiones gnome y el monitor del sistema está activado.

Esto ha causado mi retraso. La única solución fue cambiar el tiempo de actualización en el monitor del sistema a 50.

    
respondido por el Jacob Stermer 01.12.2017 - 15:03
1

Después de que el primer clic del mouse en la pantalla de inicio de sesión descubrí, el cursor del mouse USB comenzó a retrasarse y se comportaba de forma algo errática. La entrada del Trackpad funciona normalmente ... Probé las sugerencias anteriores en vano. En otro foro vi irqpoll kernel parameter como una posible solución. Me funcionó: ahora el mouse funciona bien en Ubuntu, Unity y Xfce predeterminados.

Editar /etc/default/grub :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash irqpoll"

(Normalmente digo noquiet nosplash - ¡Quiero ver los mensajes de arranque!)

Hardware:

  • McBook Pro, 5
  • NVidia GeForce 9400M (controlador nvidia 340)
  • Ratón USB
respondido por el tkam 16.01.2018 - 09:44
-2

De esta respuesta :

  

"Gnome / Wayland tiene problemas de rastreo de mouse (ver enlace )."

     

Ubuntu 17.10 usa wayland de forma predeterminada. Sin embargo, puede volver a cambiar   Xorg, sin instalar nada, todo lo que necesitas hacer es:

     
  1. Cerrar sesión de su usuario actual.

  2.   
  3. Debajo de la contraseña, cerca del botón "desbloquear", tendrá algo así como un icono de configuración.

  4.   
  5. Haz clic en él y elige la segunda opción (la que dice "xorg")

  6.   
  7. ¡Y ahí lo tienes! la buena sesión de xorg anterior, con ¡no más retardos de cursor!

  8.   

" Cambiar a una sesión de Xorg desde la pantalla de inicio de sesión debería resolver   it. "

También: parece que GDM3 también está usando Wayland por defecto. También necesité inhabilitar Wayland en GDM al descomentar el WaylandEnable=false en /etc/gdm3/custom.conf .

    
respondido por el Jacquesdupontd 25.10.2017 - 17:42

Lea otras preguntas en las etiquetas