Actualización de software: esto requiere la instalación de paquetes de fuentes no autenticadas

19

Al intentar instalar paquetes a través del software de actualización en Ubuntu 14.04.1 LTS, recibo el siguiente error:

Se trata de estos paquetes:

He seleccionado las siguientes configuraciones desde donde instalar las actualizaciones desde:

He ejecutado los siguientes comandos:

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade

sudo apt-get update da el siguiente resultado:

Reading package lists... Done
W: GPG error: https://download.01.org trusty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A902DDA375E52366
W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main i386 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-i386_Packages)

sudo apt-get upgrade da el siguiente resultado:

The following packages have been kept back:
  libegl1-mesa libegl1-mesa-drivers libgbm1 libgl1-mesa-dri libgl1-mesa-glx
  libglapi-mesa libgles1-mesa libgles2-mesa libosmesa6 liboxideqt-qmlplugin
  liboxideqtcore0 libwayland-egl1-mesa libxatracker2 linux-generic
  linux-generic-pae linux-headers-generic linux-headers-generic-pae
  linux-image-generic linux-image-generic-pae oxideqt-codecs
  python-cupshelpers system-config-printer-gnome
0 upgraded, 0 newly installed, 0 to remove and 22 not upgraded.

ACTUALIZAR

Con la pregunta ¿Cómo puedo hacerlo? tratar con errores de "fuentes no autenticadas" en el Centro de Software?

emitir los siguientes comandos:

sudo apt-get clean
cd /var/lib/apt
sudo mv lists lists.old
sudo mkdir -p lists/partial
sudo apt-get clean
sudo apt-get update

sigue dando el siguiente resultado:

Reading package lists... Done
W: GPG error: https://download.01.org trusty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A902DDA375E52366
W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main i386 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-i386_Packages)

Seguido de la segunda respuesta:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys A902DDA375E52366
sudo apt-get update

pero recibe el siguiente error:

W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main i386 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-i386_Packages)
W: You may want to run apt-get update to correct these problems

y la actualización apt-get no corrige el problema

    
pregunta Noosrep 27.01.2015 - 08:43

3 respuestas

8

Podrías ejecutar:

sudo apt-get update && sudo apt-get dist-upgrade
    
respondido por el Dustin 06.05.2015 - 15:32
1

Para corregir la entrada duplicada en su archivo sources.list:

Ábralo en un editor con derechos de root / sudo, por ejemplo:

sudo nano /etc/apt/sources.list

y eliminar la línea duplicada (no importa cuál):

http://dl.google.com/linux/chrome/deb/

Luego use ctrl-x para salir (y para guardar). Haga una actualización y actualización de apt-get como lo haría normalmente.

    
respondido por el NGRhodes 27.01.2015 - 11:06
0

Comenta las líneas que produce este error.

Abrir terminal

CTRL+ ALT+ T

usa comandos.

cd /etc/apt/

editar el archivo source.list

sudo nano source.list

Comenta las líneas con el símbolo # que se menciona en el registro de errores.

actualice source.list y actualice su software a través de la línea de comandos.

sudo apt-get clean    
sudo apt-get update 
sudo apt-get upgrade
    
respondido por el Hafiz Shehbaz Ali 26.10.2015 - 16:56

Lea otras preguntas en las etiquetas