¿Cómo puedo evitar que Skype se inicie automáticamente al arrancar?

27

Mi novia inició sesión en su cuenta de Skype desde mi netbook Xubuntu 12.10, y desde entonces Skype se inicia automáticamente cada vez que inicio. ¿Cómo evito que esto suceda?

Cosas que he intentado:

  • Al eliminarlo del Administrador de configuración- & gt; Session and Startup- & gt; Autostart de aplicación- no pudo encontrarlo en la lista.
  • Buscando una configuración relevante en Skype, no se pudo encontrar nada por el estilo. (Recuerdo que había una configuración de Skype similar en algún lugar cada vez que la usaba en Windows. Considerando que mi novia es usuario de Windows, ¿podría ser que esta es una configuración disponible en el cliente de Windows pero no en la de Linux y de alguna manera? ha sido transferido?)
  • Utilizando BUM para desactivarlo, nuevamente, no pude encontrarlo en la lista.
  • Desinstalar Skype con apt-get remove skype --purge y esperar que elimine también todas las configuraciones; no fue así.

Guardar para volver a instalar, ¿qué más puedo probar?

Con la misma nota: ¿cómo es posible que Skype arranque automáticamente sin pasar por la ruta Upstart normal?

EDITAR: Un par de cosas más que probé:

  • Buscando algo similar en el soporte de Skype: no esperaba encontrar nada, y no lo hice.
  • Buscando en la carpeta .Skype en mi directorio de inicio. Encontré un par de archivos que parecían prometedores ( .Skype/shared.xml , .Skype/[my username]/config.xml , .Skype/[girlfriend's username]/config.xml ), pero mirarlos no produjo nada. Sin embargo, hay muchos archivos SQLite. ¿Podría ser que esta configuración esté en algún lugar dentro de ella?
pregunta Andrey 17.03.2013 - 11:05

10 respuestas

23

Tuve el mismo problema y parece que se ha encargado de ello: vaya a (Xubuntu) Configuración & gt; Sesiones y inicio & gt; Sesión, busque Skype y haga clic izquierdo donde dice "Si se está ejecutando" y cámbielo a "Nunca".

    
respondido por el azeam 19.03.2013 - 09:15
28

Para la nueva versión 2017 de skype que es lo suficientemente impúdica como para agregarse al autoarranque cada vez que se inicia (¿en serio? Nunca lo instalo en mi propia máquina) es suficiente crear una carpeta con el mismo nombre que un archivo que intenta crear :

rm ~/.config/autostart/skypeforlinux.desktop
mkdir ~/.config/autostart/skypeforlinux.desktop
    
respondido por el int_ua 16.11.2017 - 12:48
13

Dado que parece que las respuestas aquí cambian todo el tiempo, a partir de una instalación de skypeforlinux a principios de esta semana (versión 8.11.0.4), logré que el autoarranque cesara con dos pasos.

Primero, abra Skype, vaya a Herramientas & gt; Configura y desmarca "Iniciar automáticamente Skype".

Luego, inspirado por la sugerencia de azeam, vaya a (Xubuntu) Configuración & gt; Sesiones y inicio & gt; Inicio automático de la aplicación y eliminar el elemento de Skype. No estoy seguro si la desactivación funciona; Intenté eso primero, pero puede haber entrado en conflicto con la configuración interna de Skype cuando lo probé.

    
respondido por el Dan 10.12.2017 - 17:47
7

Tuve este mismo problema. Pude evitar que se inicie automáticamente eliminando skypeforlinux.desktop de ~/.config/autostart/ . Estoy usando lubuntu; la ubicación de su carpeta de inicio automático puede variar. Puedes encontrar usando:

$ locate skypeforlinux.desktop

En realidad, solo querrá eliminar la copia en el directorio llamado autostart ; de lo contrario, no podrá iniciar la aplicación desde el ícono.

Supongo que la próxima vez que realmente ejecute Skype intencionalmente (espero, en aras de su cordura, que este día esté ahora en el futuro) que tratará de ponerlo ese archivo de vuelta. En ese caso, es posible que tenga que eliminarlo nuevamente o buscar en Skype la configuración que evitará ese comportamiento.

    
respondido por el Thismatters 01.11.2017 - 13:44
5

Ve a Herramientas - & gt; Opciones - & gt; Configuración general. Desmarque la opción "Iniciar Skype cuando comienzo". Guarde y salga de Skype.

    
respondido por el Massdon1 17.03.2013 - 11:23
2

En Kubuntu 14.04, el problema se solucionó yendo a Inicio y Apagado, luego a Administración de sesiones y marcando Comenzar con una sesión vacía y Aplicar.

    
respondido por el Craig 05.05.2014 - 18:07
1

Para la versión regular de Ubuntu 16.04, busque "Aplicaciones de inicio". Cuando se abra la ventana, simplemente quite la marca de Skype para evitar que comience en el arranque, luego haga clic en Eliminar mientras seleccionaba Skype para borrarlo de la lista.

    
respondido por el yusko 20.05.2018 - 18:55
0

Parece ser que "cerrar" Skype en realidad no lo está cerrando. Puedes notarlo también por el hecho de que si lo vuelves a abrir, ya está conectado.

Realmente puedes cerrarlo escribiendo la línea de comando:

killall skype

De esta forma no se guardará en su sesión de trabajo cuando cierre sesión en su computadora, y por lo tanto no se restaurará automáticamente cuando reinicie su computadora.

    
respondido por el Thijs 15.08.2014 - 22:54
0

Cerrar Skype no es lo mismo que salir de Skype. Hice tres cosas en Kubuntu 14.04. Después de abrir Skype, fui a Skype (Menú) & gt; Opciones & gt; General y marqué la opción "Iniciar Skype minimizado en la bandeja del sistema". Luego, Opciones & gt; Avanzado y sin marcar "Buscar actualizaciones en el Inicio". Finalmente, en lugar de "Cerrar sesión", hice clic en "Salir" en la parte inferior del menú. Creo que fue el paso final el que hizo el truco.

    
respondido por el WGCman 19.03.2015 - 00:41
0

Configuración de Skype (para Linux)

Abrir Skype - Menue: extras - & gt; configuraciones - & gt; categoría: inicio y cierre

1. Inicio automático de Skype

configuración del interruptor:

verdadero :

/home/$USER/.config/autostart/skypeforlinux.desktop

= & gt; existe el archivo

falso :

/home/$USER/.config/autostart/skypeforlinux.desktop

= & gt; ¡el archivo NO existe!

rm -rf /home/$USER/.config/autostart/skypeforlinux.desktop

Elimina el inicio automático, ¡pero este archivo se crea después de los cambios nuevamente!

Por lo tanto, es mejor cambiar el código que eliminar este archivo:

/home/$USER/.config/autostart/skypeforlinux.desktop

Autostart: X-GNOME-Autostart-enabled = verdadero

NO Autostart: X-GNOME-Autostart-enabled = falso

sed -i 's/X-GNOME-Autostart-enabled=true/X-GNOME-Autostart-enabled=false/g' $HOME/.config/autostart/skypeforlinux.desktop

2. Skype comienza en segundo plano

verdadero :

/home/$USER/.config/skypeforlinux/settings.json

"app.launchMinimized": verdadero

falso :

/home/$USER/.config/skypeforlinux/settings.json

"app.launchMinimized": falso

3. Skype se ejecuta en segundo plano

verdadero :

/home/$USER/.config/skypeforlinux/settings.json

"app.onCloseKeepRunning": true

falso :

/home/$USER/.config/skypeforlinux/settings.json

"app.onCloseKeepRunning": falso

Probado con:

  • skypeforlinux 8.18.0.6 amd64
  • Ubuntu 16.04.1 LTS
  • Canela
respondido por el Werner Nöbauer 09.04.2018 - 12:47

Lea otras preguntas en las etiquetas