¿Cómo cambiar los permisos predeterminados de los archivos creados por el daemon de transmisión?

19

Tengo una máquina que ejecuta el servidor Ubuntu 12.04 con el daemon de transmisión ejecutándose para manejar bitorrents. Todo funciona bien, excepto que el daemon de transmisión crea archivos como el usuario / grupo, debian-transmission y con 744 permisos de archivo.

  • Me gustaría poder eliminar y mover estos archivos desde un recurso compartido de samba.

  • Consideré cambiar el grupo primario de la transmisión de debian del usuario, pero me preocupaba que podría desordenar el acceso a otros archivos.

  • Pensé que sería mejor cambiar el permiso predeterminado de los nuevos archivos creados por debian-transmission a 774, y agregarme al grupo debian-transmission.

    Sé que esto se puede hacer con umask, pero tengo entendido que esto se establecerá en el archivo .profile y como debian-transmission no tiene carpeta de inicio, no estoy seguro de si ese archivo existía para el usuario. Entonces, ¿cómo puedo lograr esto?

    Sugerencias o soluciones alternativas son bienvenidas. Gracias de antemano.

pregunta jpetersen 29.06.2012 - 05:31

2 respuestas

39

Puede especificar umask en el archivo de configuración de la transmisión ( /etc/transmission-daemon/settings.json ). Umask normalmente representamos en octal, pero desafortunadamente, json no es compatible con eso, así que tenemos que convertirlo a base 10. Puedes hacer esto en el shell de esta manera:

$ echo $(( 8#022 ))
18

Ese es el valor predeterminado, pero probablemente quieras 002, que es el mismo en decimal, por lo que

sudo editor /etc/transmission-daemon/settings.json
# change "umask": 18 to "umask": 2 and save
sudo reload transmission-daemon # tells transmission-daemon to re-read the config 
                                # file. This is important, otherwise, the changes
                                # will be lost

Otra cosa. Si cambia la propiedad del grupo del directorio de descarga y agrega el bit setgid, todos los archivos creados en ese directorio tendrán la misma propiedad de grupo que ese directorio.

sudo chgrp "$USER" /path/to/transmission/download/dir
sudo chmod g+s /path/to/transmission/download/dir

No afectará a los archivos que ya existen. Consulte enlace para obtener más información.

    
respondido por el geirha 29.06.2012 - 06:29
0

Pruebe esto:

mkdir /your_path/progress
mkdir /your_path/completed
sudo usermod -a -G debian-transmission your_user
chgrp debian-transmission /your_path/progress
chgrp debian-transmission /your_path/completed
chmod 770 /your_path/progress
chmod 770 /your_path/completed
sudo service transmission-daemon stop
sudo adduser your_user debian-transmission
sudo nano /etc/init.d/transmission-daemon
sudo chown your_user -R /var/lib/transmission-daemon/info/
sudo chown your_user -R /your_path/progress
sudo chown your_user -R /your_path/completed
sudo chown your_user -R /etc/transmission-daemon/settings.json

Y cambie en el archivo:     sudo nano /etc/transmission-daemon/settings.json

"rpc-whitelist": "127.0.0.1" > "rpc-whitelist": "*.*.*.*",
"rpc-password": "password" > "rpc-password": "your_password",
"download-dir": "/var/lib/transmission-daemon/downloads" > "download-dir": "/your_path/completed"
"incomplete-dir": "/var/lib/transmission-daemon/downloads" > "incomplete-dir": "/your_path/progress"

Simplemente reinicie el daemon:

service transmission-daemon start
    
respondido por el costales 21.10.2013 - 18:11

Lea otras preguntas en las etiquetas