systemd-resuelve el uso de alta CPU después de la actualización a 17.04

22

Recientemente actualicé mi Xubuntu de 16.10 a 17.04.

Todo funciona bien excepto systemd-resolve. algunas veces hace que el uso de la CPU sea demasiado alto y no sé por qué se ha producido este problema.

Y aquí está el resultado del comando top :

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND                               
  1114 systemd+  20   0   51532   6744   4504 R   100  0.0   9:51.67 systemd-resolve                       
  1152 dnsmasq   20   0   64360   2892   2480 R  38.9  0.0   4:05.53 dnsmasq                               
  1245 root      20   0  376644  89644  64436 S   1.7  0.5   0:35.69 Xorg                                  
  1624 asus      20   0  370160  45820  28488 S   0.7  0.3   0:00.90 python2                               
  2238 asus      20   0 2562816 553112 128492 S   0.7  3.4   2:41.20 firefox                               
    16 root      20   0       0      0      0 S   0.3  0.0   0:01.05 ksoftirqd/1                           
   708 root     -51   0       0      0      0 S   0.3  0.0   0:01.20 irq/95-ELAN1000                       
  1302 root     -51   0       0      0      0 S   0.3  0.0   0:03.68 irq/142-nvidia                        
  1734 asus      20   0  483388  11060   8560 S   0.3  0.1   0:05.45 conky                                 
  2820 root      20   0       0      0      0 S   0.3  0.0   0:00.14 kworker/5:1                           
  3420 asus      20   0   53384   3932   3200 R   0.3  0.0   0:00.76 top                                   

No sé por qué se ha producido este problema, pero generalmente ocurre cuando ejecutas algunos comandos como sudo apt update .

(estoy usando tor y obfs4proxy, puede ser útil para la respuesta)

    
pregunta Ali Razmdideh 27.04.2017 - 14:50

4 respuestas

31

Tuve un conflicto similar entre systemd-resolve y dnsmasq en el puerto 53.

enlace

y

enlace

me llevó a agregar DNSStubListener=no en /etc/systemd/resolved.conf y luego sudo service systemd-resolved restart .

    
respondido por el MetricMike 27.04.2017 - 15:47
16

Causó problemas con otras aplicaciones (teamViewer en mi caso)

Sugerido por otro Pasos de la solución

Agregue la línea DNSMASQ_EXCEPT=lo a /etc/default/dnsmasq

sudo nano /etc/default/dnsmasq

Reinicia dnsmasq a través de

sudo service systemd-resolved restart

Di gracias. Si ayudé, volvió a la normalidad y NO se estropea con otras aplicaciones, como lo hizo el método anterior.

Saludos, marca

    
respondido por el markackerman8-gmail.com 23.10.2017 - 23:42
6

systemd-resolved se vuelve loco cuando alguien modifica el archivo /etc/resolv.conf , que apunta a su propia dirección de escucha 127.0.0.53.

Que alguien podría ser cualquier script activado por eventos de red (VPN subiendo, bajando, DHCP, etc.)

Si configuras el servidor de nombres de nuevo en 127.0.0.53, entonces systemd-resolved se "calmará" unos segundos más tarde.

Suponiendo que todo el mundo respete las reglas y solo use resolvconf para modificar la configuración del resolver, también puede hacer esto:

El archivo /etc/resolvconf/interface-order especifica el orden en el que se usarán los servidores de nombres, dependiendo de la interfaz de red de la que se recibieron.

Si agrega una entrada para systemd-resolved en la parte superior del archivo, siempre se considerará primero y el archivo no se modificará.

    
respondido por el xalkina 02.11.2017 - 17:12
2

Tuve el mismo problema en 18.04. systemd-resolved y dnsmasq tienden a repetirse. Lo resolví de esta manera:

Agregue o descomente la siguiente línea en /etc/default/dnsmasq :

IGNORE_RESOLVCONF=yes

Cree su propio archivo resolv ( /etc/resolv.personal ) para definir servidores de nombres. Puedes usar cualquier servidor de nombres aquí. Tomé dos de OpenNIC .

nameserver 5.132.191.104
nameserver 103.236.162.119

En /etc/dnsmasq.conf agrega o descomenta la siguiente línea:

resolv-file=/etc/resolv.personal

Luego, reinicia dnsmasq y deshabilita la resolución predeterminada: systemd-resolved .

sudo service dnsmasq restart
sudo systemctl stop systemd-resolved
sudo systemctl disable systemd-resolved
    
respondido por el Daniel Pernold 22.08.2018 - 20:45

Lea otras preguntas en las etiquetas