¿Puedo actualizar el kernel de mi 10.04 LTS al último kernel?

19

Quiero actualizar la versión del kernel de mi actual 10.04 LTS a al menos 2.6.37 (porque los controladores para mis interfaces eth0 y wlan0 están incluidos en dicho kernel).

Si es posible, ¿cómo hago esto? ¿Hay algún repositorio que añada a mi lista de fuentes?

    
pregunta baktin 09.06.2011 - 08:44

3 respuestas

10

No tiene que agregar el PPA. Simplemente instale el paquete linux-image-generic-lts-backport-oneiric del paquete lucid-updates:

sudo apt-get install linux-image-generic-lts-backport-oneiric

Si está usando módulos fuera de árbol como Virtual Box o controladores propietarios, es probable que también necesite los encabezados:

sudo apt-get install linux-headers-generic-lts-backport-oneiric

Se pueden encontrar otros nombres de paquetes en enlace

    
respondido por el ohitsanazn 27.11.2011 - 22:55
2

Ya no es necesario usar un PPA para instalar 2.6.38 en Ubuntu 10.04 Lucid.

El repositorio ubuntu-updates para lúcido lo tiene ahora. Probablemente ya tengas eso en /etc/apt/sources.list

$ apt-cache policy linux-image-2.6.38-12-generic 
linux-image-2.6.38-12-generic:
  Installed: (none)
  Candidate: 2.6.38-12.51~lucid1
  Version table:
     2.6.38-12.51~lucid1 0
        500 http ://packages/ubuntu-updates/ lucid-updates/main Packages
        500 http ://packages/ubuntu-security/ lucid-security/main Packages

$ sudo apt-get install linux-image-2.6.38-12-generic

Tenga en cuenta que "-12" se incrementará para versiones futuras, "-12" es la versión actual.

Para buscar versiones futuras:

$ apt-cache search linux-image-2.6.38

También ppa: kernel-ppa / ppa ha sido reemplazado por ppa: canonical-kernel-team / ppa
Consulte: enlace

    
respondido por el nutznboltz 27.10.2011 - 20:47
0

Siempre sigo estas instrucciones para Ubuntu / Mint, toma como 5 minutos + tiempo de descarga. Como siempre, tenga mucho cuidado al actualizar a un kernel nuevo: a veces rompe la compatibilidad con cierto software / hardware.  Nunca tuve ningún problema, pero huelga decir que es prudente y debe tener el último kernel en funcionamiento

enlace

    
respondido por el Wolver1n3 14.02.2012 - 11:16

Lea otras preguntas en las etiquetas