Permiso denegado al descargar con transmisión deamon

22

Instalé xubuntu y el daemon de transmisión, establecí la ruta de descarga a mi casa / usuario / programas de TV y obtuve un permiso denegado al intentar descargar torrents a través de la transmisión.

Intenté chmod -r 777 en esta carpeta sin éxito.

¡por favor ayuda!

salida de ps -ef | Transmisión grep

chen@htpc:~$ ps -ef | grep transmission
109       1023     1  1 21:46 ?        00:00:35 /usr/bin/transmission-daemon --config-dir /var/lib/transmission-daemon/info

chen@htpc:~$ ps aux | grep transmission
109       1023  3.2  0.4  47684 16620 ?        Ssl  21:46   1:20     /usr/bin/transmission-daemon --config-dir /var/lib/transmission-daemon/info
chen      1852  0.0  0.0   4200   772 pts/0    S+   22:27   0:00 grep --color=auto transmission

enter code here
    
pregunta Chen Kinnrot 23.11.2012 - 19:55

9 respuestas

41

Suponiendo que la ruta a la carpeta de descarga es /home/chen/TV shows , ejecute lo siguiente:

  • agrega chen al grupo de transmisión Debian

    sudo usermod -a -G debian-transmission chen
    
  • cambiar la propiedad de la carpeta

    sudo chgrp debian-transmission /home/chen/TV\ shows
    
  • otorgar acceso de escritura al grupo

    sudo chmod 770 /home/chen/TV\ shows
    
  • Detener el deamon con

    sudo service transmission-daemon stop
    
  • Lo último que debe hacer es cambiar la máscara de creación de archivos para que los archivos descargados puedan escribirse por chen.

    sudo nano /etc/transmission-daemon/settings.json
    

    ... y cambia "umask": 18 a "umask": 2 . Pulse Ctrl + O para guardar y Ctrl + X para salir.

Inicia el daemon con

sudo service transmission-daemon start
    
respondido por el mikewhatever 23.11.2012 - 20:58
4

Este es un problema de permiso basado en la identificación de usuario que está ejecutando Transmisión. La transmisión configura un usuario predeterminado que es posible que no espere en la primera instalación. El nombre de usuario es debian-transmission .

Explicaré cómo cambiar eso:

  1. Detener el daemon de transmisión sudo service transmission-daemon stop
  2. Abra el archivo de configuración de Transmisión para editarlo: sudo nano /etc/init.d/transmission-daemon
  3. Busca la línea que dice USER=debian-transmission y cámbiala al usuario que posee la carpeta en cuestión. Si no le preocupan los problemas de seguridad, también puede usar USER=root en este archivo. (No se recomienda, pero es bueno para la resolución de problemas).
  4. Alternativamente (en lugar del punto número 3), modifica el / etc / fstab carpeta para montar la carpeta con los permisos correctos para el usuario que ejecuta el daemon de transmisión.
  5. Iniciar el daemon de transmisión sudo service transmission-daemon start
respondido por el Terry 16.11.2013 - 07:09
4

Compruebe si está utilizando una carpeta "incompleta". El error puede ser engañoso en este caso y puede ser la carpeta incompleta a la que no tiene acceso de escritura.

    
respondido por el blockdor 23.09.2015 - 17:41
1

Esto simplemente me pasó a mí. Encontré esta página, me sentí intimidada por toda la jerga, así que reinicié Transmission, reservé el archivo torrent a una ubicación diferente y guardé los datos de torrent en la misma ubicación diferente (escritorio). Funcionó como un encanto ...

    
respondido por el Alexia 31.07.2015 - 15:02
0

Esto podría ser un problema de perfil de apparmor. La transmisión se ejecuta en el perfil sanitized_helper en apparmor.

Busque quejas en /var/log/kern.log. grep transm /var/log/kern.log , especialmente justo después de intentar ejecutar la transmisión y falla.

    
respondido por el Jim Salter 23.11.2012 - 23:58
0

Como este es el resultado de búsqueda más importante en Google, para cualquiera que lo lea, dedico más de una hora a intentar que funcione. Resulta que la carpeta de descargas especificada en settings.json es "Descargas" en lugar de "Descargas". Tenga en cuenta el caso.

    
respondido por el SomeGuest1425125125 23.11.2016 - 13:21
0

En mi caso, el problema era cómo se estaba montando la unidad. Usar esto en /etc/fstab me ha funcionado:

UUID=2069-1A05  /mnt/ext   vfat   rw,user,exec,umask=0000   0   0
    
respondido por el davidcm 02.01.2017 - 19:24
-1

Tuve el mismo problema, y ​​ese fue un error que cometí al sincronizar el directorio de descarga de la transmisión con mi directorio de inicio / usuario /, cambié la propiedad del archivo sym-linked, que por consecuencia también cambió la propiedad de el directorio de transmisión de 'descarga' ...

Me acabo de volver a la propiedad de 'debian-transmission' y funcionó a las mil maravillas (sin necesidad de reiniciar el servicio)

#chown debian-transmission:debian-transmission /var/lib/transmission/downloads

(bueno, tendrá que verificar según su propia distribución de Linux cuál es el propietario correcto y, finalmente, también su ruta correcta al directorio de descargas)

    
respondido por el baobab33 09.12.2014 - 10:37
-1

Tuve un problema similar con la transmisión. Obtuve un error de permiso durante la descarga, incluso con la configuración correcta de permisos de carpeta en el disco duro USB externo.

Acabo de montar el disco duro externo en /home/pi/ con los mismos permisos y funcionó bien.

mount /dev/sda /home/pi/USB-HDD-MOUNTED

los permisos son drwxrwxrwx (0777) pi:debian-transmission . el nombre de usuario se cambia a pi en /etc/init.d/transmisssion-daemon .

    
respondido por el Akos 12.02.2016 - 10:00

Lea otras preguntas en las etiquetas