Ubuntu 16.04 Los controladores de nvidia no funcionan

20

Acabo de instalar un nuevo ubuntu 16.04,
instalación reciente limpia, ingresé lo primero y lo único que hice fue seleccionar el controlador propietario 361 para nvidia, reinicié la máquina.
un reinicio de anfter puedo iniciar sesión pero la unidad no se muestra, todavía puedo hacer clic derecho y abrir terminal, intenté muchas respuestas:
link1 link2

no sirvió de nada, me sentí frustrado, me conecté al usb y lo volví a instalar, esta vez intenté 340 controladores con el mismo problema.
Quiero decir que esto es 16.04 LTS por los dioses.
Tengo tarjetas grahpic duales nvidia gt 740m, intel construido en la computadora portátil ASUS.

salida de grep "EE \ | WW" /var/log/Xorg.0.log:

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    23.758] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    23.758] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    23.758] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    23.758] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    23.758] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    23.761] (WW) "glamoregl" will not be loaded unless you've specified it to be loaded elsewhere.
[    25.323] (WW) Unresolved symbol: fbGetGCPrivateKey
[    25.448] (WW) NVIDIA(0): Unable to get display device for DPI computation.
[    25.613] (WW) modeset(G0): Option "AllowEmptyInitialConfiguration" is not used
[    25.613] (WW) modeset(G0): Option "IgnoreDisplayDevices" is not used
[    25.902] (EE) NVIDIA(0): Failed to initiate mode change.
[    25.902] (EE) NVIDIA(0): Failed to complete mode change
[    26.214] (WW) evdev: SteelSeries Sensei Raw Gaming Mouse: ignoring absolute axes.
[    26.216] (WW) evdev: SteelSeries SteelSeries Apex Raw Gaming Keyboard: ignoring absolute axes.
[    26.272] (II) XINPUT: Adding extended input device "USBest Technology SiS HID Touch Controller" (type: TOUCHSCREEN, id 16)

archivo de registro completo LOG

archivo xorg.conf:

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0@0:2:0"
    Option "AccelMethod" "None"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:4@0:0:0"
    Option "ConstrainCursor" "off"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
    Option "IgnoreDisplayDevices" "CRT"
EndSection
    
pregunta saeed hardan 23.04.2016 - 10:30

8 respuestas

1

Encontré la solución (esta vez de verdad),
Decidí ser un experto en ubuntu, así que fui a google y escribí:

  

depurar ubuntu

luego me dio la página Debug y seleccioné la unidad.
en alguna parte tuve que hacer:

$ unity --advanced-debug
GNU gdb (GDB) 7.2-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>

...

(gdb) set logging file unity.log
(gdb) set logging on
(gdb) b _exit
Function "_exit" not defined.
Make breakpoint pending on future shared library load? (y or [n])
[Answer yes (y)]

(gdb) run

[ and when compiz/unity crash, do...]

(gdb) bt full

[ then CTRL-D or re-run compiz to continue working ]

(gdb) run

después de ejecutar esto noté el error:
compiz (core) - Error: el complemento 'opengl' no está cargado.

busqué este error en google y me dio este hilo ¿Falta la unidad? No se pueden ver los paneles superiores o laterales , la respuesta aquí funciona.

    
respondido por el saeed hardan 27.04.2016 - 16:23
10

También instalé Ubuntu 16.04, limpio la instalación en un nuevo disco duro y todo funcionó bien hasta que cambié al controlador NVIDIA. Después de reiniciar, no pude pasar la pantalla de inicio de sesión. La solución que funcionó para mí fue la de desactivar el arranque seguro .

Mientras estaba atascado en el bucle de inicio de sesión, cambié a la consola Ctl+Alt+F1 , reinicié y desactivé el inicio seguro en UEFI . Ahora todo funciona con el controlador nvidia instalado.

    
respondido por el Karhu 27.04.2016 - 20:37
3

También tuve este problema. Simplemente ejecuto esto en una consola (presione Ctrl + Alt + F1 , en la página de inicio de sesión para mostrar el primer tty virtual):

sudo apt-get purge nvidia*

Después de esto, reinicié y pude iniciar sesión. Después de eso, instalé los controladores Intel primero, y luego nvidia-361.

Estos fueron los pasos que seguí:

  1. sudo apt-get purge nvidia*
  2. reiniciar (ahora tenía funcionando el controlador de pantalla noveau)
  3. sudo apt-get install intel-microcode
  4. sudo apt-get install intel-gpu-tools
  5. Reiniciar (para probar, todo funcionaba bien)
  6. sudo apt-get install nvidia-361 (creo que nvidia-current es la mejor opción a largo plazo).
  7. Reiniciar

Ahora tengo estos (lo siento, están en español):

Controladores adicionales

    
respondido por el Shosta 23.04.2016 - 16:36
2

También tengo un problema con 16.04 y el controlador Nvidia 361.42. Puede usar prime-select intel o el controlador Nouveau como solución temporal. He tenido problemas interminables con los controladores oficiales de Nvidia Ubuntu a través de los años, es muy al azar. Pensé que la introducción de Steam OS y el número creciente de usuarios / gamers de Linux podría animarlos a soportar mejor Linux: /

    
respondido por el neutreno 23.04.2016 - 10:52
1

Creo que encontré la solución. He tenido problemas terribles con la instalación de 16.04 en mi máquina principal. Los controladores de Nvidia se bloquean y no puedes iniciar sesión y debes recurrir a sudo apt-get purge nvidia- *. Chrome estaba fallando

No he tenido problemas con mi máquina secundaria que tiene una BIOS tradicional. Es solo mi máquina principal con firmware UEFI. Lo más frustrante es que había estado ejecutando 16.04 desde una versión diaria durante algunos meses y era sólido como una roca.

He notado que el instalador solicita una contraseña si descarga los controladores mientras los instala. La solución es APAGAR SEGURO SEGURO. Instalar Ubuntu (desde la opción UEFI en el Menú de Bios) luego continúa sin errores y el sistema parece estable. 16.04 no es perfecto, p. para instalar Chrome debes usar gdebi, pero al menos ahora es utilizable.

    
respondido por el Roderic Jones 03.05.2016 - 15:09
1

Para mí, la solución después de muchas búsquedas era desactivar UEFI en el BIOS. Mi máquina solo ejecuta Linux, así que deshabilitar UEFI no fue un gran problema.

Estaba teniendo problemas con VirtualBox y NVIDIA y tampoco pude trabajar con Ubuntu 16. Estaba buscando "Ubuntu UEFI Virtual Box Fail kernel build" y encontré un enlace con respecto a Virtualbox que me hizo preguntarme sobre UEFI y deshabilitarlo.

Después de deshabilitar UEFI reinstalé Ubuntu 16. Durante la instalación, el cuadro de diálogo que tenía la entrada "Secure boot" carecía de ese contenido.

Me complace informar que Ubuntu 16 se está ejecutando y que no tengo problemas con NVIDIA o VirtualBox. Ambos funcionan como se esperaba.

Gracias a aquellos que compartieron sus conocimientos para poder avanzar.

    
respondido por el D.Howland 06.05.2016 - 01:33
1

Ubuntu 16.04 viene con xserver Xorg 1.18 y la configuración es un poco diferente a la anterior. En una configuración de GPU doble, de la wiki de Arch Linux , la / etc / X11 / xorg.conf debería ser así:

Section "Module"
    Load "modesetting"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1:0:0"
    Option "AllowEmptyInitialConfiguration"
EndSection

Reemplace PCI: 1: 0: 0 por su ID de bus nvidia. Puede verificarlo con:

$ lspci | grep -E "VGA|3D"

Funciona para mi laptop HP con doble GPU: Intel (Skylake) y NVIDIA 940m. Recuerde que es posible cambiar entre ellos con prime-select command (como usuario root) o la aplicación oficial nvidia-settings y reiniciar su computadora.

    
respondido por el Jaime M. 23.05.2016 - 18:49
0

Tuve un problema similar, pero mi problema en particular fue causado por el antivirus ESET NOD32 .

La instalación del controlador, tanto de los repos de ubuntu como de la instalación manual del controlador NVIDIA, se estaba trabando al construir los módulos DKMS.

Encontré instrucciones en cómo desinstalar ESET y, después de desinstalar, configuré mi ejecución. -level a 3:

sudo systemctl enable multi-user.target
sudo systemctl set-default multi-user.target

Lista negra nouveau:

Editar /etc/modprobe.d/blacklist.conf como superusuario y agregar:

blacklist nouveau

Luego purgue NVIDIA y reinicie:

sudo apt purge nvidia*
sudo reboot

Una vez en el nivel de ejecución 3, instalé manualmente el último controlador de NVIDIA, establecí el nivel de ejecución nuevamente en 5 y lo reinicié.

sudo sh ./NVIDIA...
sudo systemctl enable graphical.target
sudo systemctl set-default graphical.target
reboot

Las cosas finalmente estaban funcionando, así que reinstalé el antivirus. Tendrá que esperar una actualización del kernel para asegurarse de que el controlador de NVIDIA se reconstruya en ese momento.

    
respondido por el DavidG 19.03.2017 - 03:18

Lea otras preguntas en las etiquetas