¿Actualización de firmware para iPod Touch (iPhone)?

18

Necesito actualizar el firmware de mi iPod Touch (iPhone) en Ubuntu y como tengo el iPod Touch con jailbreak Necesito iTunes para instalar aplicaciones, pero desafortunadamente aún no he encontrado ninguna forma de hacerlo en Ubuntu. Sé que es posible usar VirtualBox o Wine , pero en la mayoría de las veces iTunes no quiere trabajar en Wine y para VirtualBox necesito instalar de nuevo ese Windows desde el que cambié a Ubuntu hace unos meses y no quiero volver a él.

¿Qué hacen los usuarios de Linux que tienen iPod Touch (iPhone) en este caso?

Cualquier sugerencia para resolver el problema estará encantado.

Y finalmente, ¿cuánto tiempo pasará antes de que Apple desarrolle iTunes para el sistema operativo Linux?

    
pregunta Bakhtiyor 28.07.2010 - 22:30

6 respuestas

9

Aunque actualmente se puede hacer que algunas versiones anteriores de iTunes funcionen con Wine (o Crossover), no se pueden usar para actualizar o sincronizar iPods más nuevos

La razón es que Wine carece de un controlador para los controladores de dispositivo USB de Windows, y el iPod funciona como un dispositivo USB personalizado. Esta es la misma razón por la que el software que requiere un dongle de llave especial tampoco funciona (todavía) en Wine. Hay algunos parches preliminares disponibles para esto, y puede leer más historia en el wiki del vino , sin embargo, no espere que nada funcione. .

Los únicos iPod que actualmente funcionan en Wine son realmente iPods viejos que funcionan como simples dispositivos de almacenamiento masivo USB. Y aun así, todavía necesitas encontrar un iTunes más antiguo y funcional.

Debido a este problema en Wine, para realizar la actualización de firmware necesitará configurar una máquina virtual con Virtualbox o VMware o, quizás más simplemente, tomar prestada la computadora de otra persona.

    
respondido por el Scott Ritchie 30.09.2010 - 16:05
4

No sé si esto funciona con tu iPod touch, pero funciona para mis iPods antiguos: enlace

    
respondido por el manyxcxi 28.07.2010 - 22:37
3

Mirando Crossover página para iTunes , se ha informado que algunas versiones funcionan un poco. Crossover cuesta dinero, pero puede valer la pena para ti.

    
respondido por el mac9416 28.07.2010 - 22:36
3

Firmware-Upgrade no funcionó para mí: Ubuntu 8.04 LTS con vmplayer y un viejo XP con iTunes.

Ninguna posibilidad. el iphone estuvo fuera de servicio por el resto del día hasta que lo enchufé en mi PC de Windows en mi lado del trabajo.

Desde este punto de vista: ¡los productos de manzana son absolutamente No-Go! ¿Por qué necesito Windows o Mac con iTunes para tener un teléfono? ¿Dónde se afirma que al comprar ese 'thing-a-magic' necesito un iTunes que funcione para que funcione? ¿Quién sabe los costos antes?

    
respondido por el Ice 06.08.2010 - 21:36
2

libimobiledevice

Sigue siendo experimental, pero debe consultar libimobiledevice . Todavía no hay una GUI, pero están trabajando para que los modelos ipod touch funcionen en Linux (incluido el software para subir y bajar de categoría).

Editar: según el Wiki de Ubuntu , este es el valor predeterminado desde al menos 14.04 y se implementó en varios proyectos. Consulte las noticias y el estado en la página del proyecto libimobiledevice para obtener más información. Actualmente afirman que son compatibles con iOS 9, que todavía estaba en fase beta en el momento de la escritura.

    
respondido por el PierreS 05.12.2010 - 16:22
0

Me cansé de actualizar el firmware de mi iPhone desde v2 a v3 usando iTunes corriendo en VMware. El proceso se detuvo a mitad de la transmisión y el iPhone quedó inutilizado. Lo conecté a las máquinas de Windows de un amigo y después de varios intentos de actualización, volvió a la vida.

Las actualizaciones con las mismas versiones principales funcionaron bien en iTunes / VMware.

    
respondido por el A.B. 20.10.2010 - 08:10

Lea otras preguntas en las etiquetas