Steam no se abrirá en Ubuntu 15.10

19

He intentado una y otra vez, pero no pasa nada. Intenté reinstalar Steam junto con Ubuntu, pero eso tampoco hizo nada. Intenté otros foros con consejos útiles pero no buenos. Me estoy quedando sin ideas y no sé qué más puedo hacer. ¿Puede alguien ayudarme por favor antes de empezar a sacarme el pelo? Me estoy volviendo loco.

    
pregunta Travis Toompas 25.10.2015 - 06:43

2 respuestas

27

Basado en esta pregunta , ejecute los siguientes comandos :

mv ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1{,.disable}
mv ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6{,.disable}

¡La idea es que Steam use sus propias bibliotecas dinámicas, pero Ubuntu viene con algunas nuevas, o algo así, de cualquier forma que funcione!

NOTA: si solo está instalando Steam por primera vez, deberá ejecutar los comandos una segunda vez después de la actualización inicial. ¡Esto tomará un tiempo de espera!

ACTUALIZACIÓN:

Si usa 16.10, los chicos de Ubuntu proporcionaron un instalador modificado que se encarga de estos problemas. Recomendaría instalar Steam desde los repositorios de Ubuntu

    
respondido por el Dan 26.10.2015 - 18:42
3

Según la respuesta de Daniel (¡no tengo el representante para comentar!), en un ubuntu-gnome 15.10 vainilla donde hice un 'apt-get install steam' tuve que ejecutar estos comandos modificados:

mv ~/.steam/steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6{,.disable}
mv ~/.steam/steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1{,.disable}

Cambiando el .local / share que no estaba presente en mi sistema

    
respondido por el Henri Cook 12.11.2015 - 21:57

Lea otras preguntas en las etiquetas