libimobiledevice 1.2 (iOS 8 Support) para Ubuntu 14.04 Trusty

22

¿Hay un PPA disponible para la versión más reciente de libimobiledevice 1.2 con soporte para iOS 8 o alguien puede explicar cómo crearlo desde la fuente sin estropear todo?

enlace

    
pregunta tristank 20.03.2015 - 00:58

5 respuestas

23

Uso del repositorio de GitHub .

Tenga en cuenta que cada paso funciona solo si el paso anterior fue exitoso.

  1. Clonar el repositorio

    mkdir -p ~/src
    cd ~/src
    git clone https://github.com/libimobiledevice/libimobiledevice.git
    cd libimobiledevice
    
  2. Instalar las bibliotecas de desarrollo necesarias

    Es posible que necesite más bibliotecas o paquetes de encabezado como se detalla a continuación. Verá esto si tiene mensajes de error durante el paso de configuración posterior. Agregue un comentario si tiene problemas.

    sudo apt-get install libusbmuxd-dev libplist-dev  libplist++-dev libgnutls-dev libssl-dev python-dev
    
  3. Instalar algún software adicional

    El siguiente software es necesario para preparar el software para la compilación y luego compilarlo.

    sudo apt-get install usbmuxd make automake autoconf libtool pkg-config gcc
    
  4. Instalar software opcional

    El siguiente software se utiliza para hacer que las partes del paquete terminado se ejecuten más rápido y crear documentación.

    sudo apt-get install cython doxygen
    
  5. Instalar un ayudante de instalación

    Checkinstall crea un paquete Debian para que el administrador del paquete administre el software.

    sudo apt-get install checkinstall
    
  6. Configurar y compilar

    ./autogen.sh
    make
    
  7. Instalar

    Con el siguiente comando, se creará e instalará un paquete Deb con el nombre libimobiledevice .

    sudo checkinstall
    

    Verá esta advertencia:

    checkinstall 1.6.2, Copyright 2009 Felipe Eduardo Sanchez Diaz Duran
               This software is released under the GNU GPL.
    
    
    
    *****************************************
    **** Debian package creation selected ***
    *****************************************
    
    *** Warning: The package version "1.2.1
    1.2.1
    1.2.1
    1.2.1
    1.2.1
    1.2.1
    1.2.1
    1.2.1
    1.2.1
    1.2.1" is not a
    *** Warning: debian policy compliant one. Please specify an alternate one
    
    
    This package will be built according to these values: 
    
    0 -  Maintainer: [ root@aboettger-VirtualBox ]
    1 -  Summary: [ Package created with checkinstall 1.6.2 ]
    2 -  Name:    [ libimobiledevice ]
    3 -  Version: [  ]
    4 -  Release: [ 1 ]
    5 -  License: [ GPL ]
    6 -  Group:   [ checkinstall ]
    7 -  Architecture: [ i386 ]
    8 -  Source location: [ libimobiledevice ]
    9 -  Alternate source location: [  ]
    10 - Requires: [  ]
    11 - Provides: [ libimobiledevice ]
    12 - Conflicts: [  ]
    13 - Replaces: [  ]
    

    Simplemente presione 3 y escriba 1.2.1 y Enter

    Enter a number to change any of them or press ENTER to continue: 3
    Enter new version: 
    >> 1.2.1
    
  8. Verifique los archivos instalados

    dpkg -L libimobiledevice
    

    y verá algo como esto

    /.
    /usr
    /usr/share
    /usr/share/doc
    /usr/share/doc/libimobiledevice
    /usr/share/doc/libimobiledevice/COPYING.LESSER
    /usr/share/doc/libimobiledevice/AUTHORS
    /usr/share/doc/libimobiledevice/NEWS
    /usr/share/doc/libimobiledevice/README
    /usr/share/doc/libimobiledevice/docs
    /usr/share/doc/libimobiledevice/docs/idevice_id.1
    /usr/share/doc/libimobiledevice/docs/idevicenotificationproxy.1
    /usr/share/doc/libimobiledevice/docs/idevicepair.1
    /usr/share/doc/libimobiledevice/docs/ideviceprovision.1
    /usr/share/doc/libimobiledevice/docs/ideviceimagemounter.1
    /usr/share/doc/libimobiledevice/docs/Makefile
    /usr/share/doc/libimobiledevice/docs/idevicedebug.1
    /usr/share/doc/libimobiledevice/docs/idevicename.1
    /usr/share/doc/libimobiledevice/docs/idevicebackup.1
    /usr/share/doc/libimobiledevice/docs/idevicedebugserverproxy.1
    /usr/share/doc/libimobiledevice/docs/ideviceenterrecovery.1
    /usr/share/doc/libimobiledevice/docs/idevicecrashreport.1
    /usr/share/doc/libimobiledevice/docs/ideviceinfo.1
    /usr/share/doc/libimobiledevice/docs/Makefile.in
    /usr/share/doc/libimobiledevice/docs/Makefile.am
    /usr/share/doc/libimobiledevice/docs/idevicescreenshot.1
    /usr/share/doc/libimobiledevice/docs/idevicedate.1
    /usr/share/doc/libimobiledevice/docs/idevicesyslog.1
    /usr/share/doc/libimobiledevice/docs/idevicediagnostics.1
    /usr/share/doc/libimobiledevice/docs/idevicebackup2.1
    /usr/share/doc/libimobiledevice/COPYING
    /usr/local
    /usr/local/bin
    /usr/local/bin/idevicepair
    /usr/local/bin/idevicename
    /usr/local/bin/ideviceinfo
    /usr/local/bin/idevicebackup2
    /usr/local/bin/ideviceprovision
    /usr/local/bin/idevicecrashreport
    /usr/local/bin/ideviceimagemounter
    /usr/local/bin/idevice_id
    /usr/local/bin/idevicenotificationproxy
    /usr/local/bin/ideviceenterrecovery
    /usr/local/bin/idevicescreenshot
    /usr/local/bin/idevicediagnostics
    /usr/local/bin/idevicedebug
    /usr/local/bin/idevicebackup
    /usr/local/bin/idevicedebugserverproxy
    /usr/local/bin/idevicesyslog
    /usr/local/bin/idevicedate
    /usr/local/lib
    /usr/local/lib/libimobiledevice.la
    /usr/local/lib/pkgconfig
    /usr/local/lib/pkgconfig/libimobiledevice-1.0.pc
    /usr/local/lib/libimobiledevice.so.6.0.0
    /usr/local/lib/libimobiledevice.a
    /usr/local/share
    /usr/local/share/man
    /usr/local/share/man/man1
    /usr/local/share/man/man1/idevicebackup2.1.gz
    /usr/local/share/man/man1/ideviceprovision.1.gz
    /usr/local/share/man/man1/idevicebackup.1.gz
    /usr/local/share/man/man1/idevicecrashreport.1.gz
    /usr/local/share/man/man1/idevice_id.1.gz
    /usr/local/share/man/man1/ideviceenterrecovery.1.gz
    /usr/local/share/man/man1/ideviceimagemounter.1.gz
    /usr/local/share/man/man1/idevicename.1.gz
    /usr/local/share/man/man1/idevicescreenshot.1.gz
    /usr/local/share/man/man1/idevicedebug.1.gz
    /usr/local/share/man/man1/idevicenotificationproxy.1.gz
    /usr/local/share/man/man1/idevicedebugserverproxy.1.gz
    /usr/local/share/man/man1/idevicedate.1.gz
    /usr/local/share/man/man1/ideviceinfo.1.gz
    /usr/local/share/man/man1/idevicesyslog.1.gz
    /usr/local/share/man/man1/idevicediagnostics.1.gz
    /usr/local/share/man/man1/idevicepair.1.gz
    /usr/local/include
    /usr/local/include/libimobiledevice
    /usr/local/include/libimobiledevice/syslog_relay.h
    /usr/local/include/libimobiledevice/lockdown.h
    /usr/local/include/libimobiledevice/diagnostics_relay.h
    /usr/local/include/libimobiledevice/screenshotr.h
    /usr/local/include/libimobiledevice/property_list_service.h
    /usr/local/include/libimobiledevice/installation_proxy.h
    /usr/local/include/libimobiledevice/restore.h
    /usr/local/include/libimobiledevice/file_relay.h
    /usr/local/include/libimobiledevice/mobile_image_mounter.h
    /usr/local/include/libimobiledevice/mobilebackup2.h
    /usr/local/include/libimobiledevice/afc.h
    /usr/local/include/libimobiledevice/service.h
    /usr/local/include/libimobiledevice/webinspector.h
    /usr/local/include/libimobiledevice/heartbeat.h
    /usr/local/include/libimobiledevice/libimobiledevice.h
    /usr/local/include/libimobiledevice/mobilesync.h
    /usr/local/include/libimobiledevice/misagent.h
    /usr/local/include/libimobiledevice/debugserver.h
    /usr/local/include/libimobiledevice/mobilebackup.h
    /usr/local/include/libimobiledevice/house_arrest.h
    /usr/local/include/libimobiledevice/sbservices.h
    /usr/local/include/libimobiledevice/notification_proxy.h
    /usr/local/lib/libimobiledevice.so
    /usr/local/lib/libimobiledevice.so.6
    
respondido por el A.B. 09.09.2015 - 08:30
8

Esto es lo que hice para construir libimobiledevice-1.2.0:

  1. Instalar herramientas y dependencias de compilación

    sudo apt-get install build-essential fakeroot devscripts pbuilder
    sudo apt-get build-dep libimobiledevice
    
  2. Descargue los scripts de compilación fuente y Debian de la versión actualmente empaquetada (1.1.5 en Ubuntu 14.04):

    apt-get source libimobiledevice
    cd libimobiledevice-1.1.5
    
  3. Buscar y descargar nueva versión de subida:

    uscan --verbose
    
  4. Descomprimirlo, colocar los scripts de compilación de Debian en su lugar y actualizar el registro de cambios:

    uupdate ../libimobiledevice_1.2.0.orig.tar.bz2
    cd ../libimobiledevice-1.2.0
    
  5. Cree el paquete binario (en paralelo con tantos trabajadores como núcleos de CPU disponibles):

    debuild -b -j$(getconf _NPROCESSORS_ONLN)
    

    ( -j instruye al sistema de compilación para que ejecute tareas de compilación individuales en paralelo, si es posible. Como esto a veces genera problemas, puede valer la pena tratar de volver a ejecutar la compilación sin esa bandera o dejarla caer en el primer lugar).

  6. Instalar el paquete integrado:

    sudo dpkg -i ../libimobiledevice_1.2.0*.deb
    

En realidad, hice trampa un poco. No pude satisfacer las dependencias de compilación, porque una biblioteca no está disponible en versiones suficientemente recientes en Ubuntu 14.04: libimobiledevice-1.2.0 requiere libusbmuxd-dev (>= 1.0.9) , por lo que tendrá que compilarlo desde el origen con la misma receta.

    
respondido por el David Foerster 04.04.2015 - 10:55
8

De acuerdo, esto es lo que funcionó para mí.

El orden es:

libplist -> libusbmuxd -> libimobiledevice -> usbmuxd, ifuse, ideviceinstaller, ...

Fuente: enlace

mkdir -p ~/src
cd ~/src

sudo apt-get -y install libusbmuxd-dev libplist-dev libplist++-dev libgnutls-dev libssl-dev usbmuxd make automake autoconf libtool pkg-config gcc cython doxygen checkinstall libusb-1.0-0-dev libssl-dev

git clone https://github.com/libimobiledevice/libplist.git
cd libplist/
./autogen.sh 
make
sudo make install

cd ..
git clone https://github.com/libimobiledevice/libusbmuxd.git
cd libusbmuxd/
./autogen.sh 
make
sudo make install

cd ..
git clone https://github.com/libimobiledevice/libimobiledevice.git
cd libimobiledevice/
./autogen.sh 
make
sudo checkinstall 

En el indicador checkinstall :

> y[ENTER]
> [ENTER]
> 3[ENTER]
> 1.2.1[ENTER]
> [ENTER]
    
respondido por el ATOzTOA 21.12.2015 - 22:41
3

Utilizo este PPA, tiene el último dispositivo libimobile, pero no todos los componentes están representados allí: enlace

    
respondido por el yanpas 13.10.2015 - 13:58
1

16.04 tendrá 1.2. Pude descargar los debs del launchpad ( enlace ) e instalarlos en 15.10. Necesitaba libusbmuxd4 , libimobiledevice6 y libimobiledevice-dev . Luego instalé ifuse 1.1.3 siguiendo estas instrucciones: enlace

    
respondido por el Aleksandr Dubinsky 13.02.2016 - 23:25

Lea otras preguntas en las etiquetas