¿Cómo hago que Sublime Text 2/3 no abra las pestañas anteriores cuando lo ejecuto?

19

Cada vez que abro Sublime, estas pestañas se abren automáticamente. Cómo puedo solucionar esto. No puedo encontrar ningún ajuste para esto.

    
pregunta BigSack 25.08.2012 - 02:37

3 respuestas

16

Sublime Text 2

Verifique el contenido del directorio ~/.config/sublime-text-2/Settings para un archivo llamado Session.sublime_session

Si esos archivos están incluidos allí, elimínelos

Sublime Text 3

ST3 almacena los archivos de sesión en:

~/.config/sublime-text-3/Local/Session.sublime_session
    
respondido por el Adonis K. Kakoulidis 25.08.2012 - 03:00
42

En realidad, hay una mejor solución implementada en Sublime Text. Seleccione Preferences-> Settings - User y establezca remember_open_files y hot_exit en falso. El archivo resultante debería verse así:

{
    "remember_open_files": false,
    "hot_exit": false
}

(Todas las configuraciones posibles se pueden ver en Settings - Default .)

Simplemente reinicie Sublime Text después (puede ser necesario reiniciar el programa dos veces, una vez para aplicar la configuración) y se debe iniciar sin ningún archivo abierto.

Nota: Solo pude probar esto con Sublime Text 3, pero estoy bastante seguro de que esta configuración también existe en la versión 2.

    
respondido por el Adam S 15.03.2013 - 17:48
1

En Texto sublime 3 , a continuación funcionó para mí.

  

$ rm ~ / .config / sublime-text-3 / Local / Auto \ Guardar \   Session.sublime_session

    
respondido por el BTR Naidu 15.11.2017 - 08:15

Lea otras preguntas en las etiquetas