¿Cómo arreglar redes inalámbricas lentas en máquinas con tarjetas inalámbricas Intel?

21

He revisado todas las preguntas anteriores, pero la desactivación de la administración de energía para la tarjeta Wi-Fi no funcionó. Este problema parece ser con los Lenovo Thinkpads. Cambié a Ubuntu 11.10 de Windows 7 hace 3 días, así que soy nuevo en el sistema operativo.

    
pregunta Kaine McAliece 07.04.2012 - 00:18

8 respuestas

20

OP publicado:

  • Nota 1: la conexión lenta puede ser debida a su proveedor de servicios o por cualquier otro motivo, para comprobarlo, pruebe la misma red en cualquier otra computadora con sistema operativo diferente o conectándose a la red mediante un cable. Si es rápido, esta solución puede ayudarte. Si no, ¡puede ser una pérdida de tiempo! *

  • Nota 2: en el primer enlace de las referencias que publico, hay más métodos para resolver la conexión inalámbrica lenta. Cada método resuelve diferentes motivos posibles de la conexión lenta. Recomiendo probar la solución que puse aquí antes de buscar diferentes métodos porque es muy probable que sea efectiva. *

Si está utilizando Ubuntu 11.10, haga lo siguiente:

terminal abierto. Escriba las dos líneas siguientes:

sudo rmmod -f iwlagn
sudo modprobe iwlagn 11n_disable=1

Ahora, verifique su velocidad de Internet inalámbrica. Si todavía es lento, esta solución probablemente no sea una solución para su caso. En este caso, simplemente reinicie la computadora para revertir el cambio que hizo. Si se vuelve normal y rápido, hágalo permanentemente escribiendo la siguiente línea en la terminal:

gksudo gedit /etc/modprobe.d/iwlagn-disable11n.conf

Se abrirá un archivo. Al final del archivo, pega la siguiente línea y luego guárdalo:

options iwlagn 11n_disable=1

Después de guardar, ¡simplemente salga y DISFRÚTELA!

Solución para Ubuntu 12.04:

terminal abierto. Escriba las dos líneas siguientes:

sudo rmmod iwlwifi
sudo modprobe iwlwifi 11n_disable=1

Ahora, verifique su velocidad de Internet inalámbrica. Si todavía es lento, esta solución probablemente no sea una solución para su caso. En este caso, simplemente reinicie la computadora para revertir el cambio que hizo. Si se vuelve normal y rápido, hágalo permanentemente escribiendo la siguiente línea en la terminal:

gksudo gedit /etc/modprobe.d/iwlwifi-disable11n.conf

Se abrirá un archivo. Al final del archivo, pega la siguiente línea y luego guárdalo:

options iwlwifi 11n_disable=1

Después de guardar, ¡simplemente salga y DISFRÚTELA!

Referencias:

* Intenté ambas soluciones y funcionan.

    
respondido por el Jorge Castro 04.05.2012 - 23:03
10

Resolví esto por mí mismo usando las instrucciones aquí .

en una terminal, escribe:

echo "options iwlagn 11n_disable=1" | sudo tee /etc/modprobe.d/iwlagn.conf
sudo modprobe -rfv iwlagn
sudo modprobe iwlagn

Para 12.04 y más reciente: cambie options iwlagn 11n_disable=1 a options iwlwifi 11n_disable=1

    
respondido por el eskararriba 11.04.2012 - 01:14
4

Para 12.04, cambie:

options iwlagn 11n_disable=1

Para:

options iwlwifi 11n_disable=1
    
respondido por el eskararriba 30.04.2012 - 18:52
3

Este error afecta a mi computadora portátil con Centrino Ultimate-N 6300 también. Lo único que ayudó fue encender el parámetro swcrypto. Mi /etc/modprobe.d/iwlwifi.conf ahora se ve así:

options iwlwifi 11n_disable=1 led_mode=1 swcrypto=1

Y puedo usar wifi sin problemas. Sin embargo, el hecho de que n-networks no se pueda usar sigue siendo molesto.

    
respondido por el Karl Frisk 01.08.2012 - 22:07
2

Estos comandos me ayudaron y funcionaron, Kubuntu 15.10 (wily), mi Intel Wifi Adapter (Intel Corporation Centrino Wireless-N 1000) pasó a la velocidad máxima de rastreo (velocidad de caracol):

echo options iwlwifi 11n_disable=1 | sudo tee /etc/modprobe.d/iwlagn.conf
echo options iwlwifi 11n_disable=1 | sudo tee /etc/modprobe.d/iwlwifi.conf
sudo modprobe -rfv iwlwifi
sudo modprobe iwlwifi
apt-get update

Al principio tuve tantas dificultades para encontrar esto, espero que ayude a alguien, fue tan lento al principio, cuando instalé Linux (Kubuntu), me estaba volviendo loco:)

    
respondido por el David V. 04.11.2015 - 02:48
1

ACTUALIZACIÓN: De alguna manera terminó sin conectarse de nuevo, así que hice más investigación aquí es lo que encontré:

Restaurar los comandos iwlwifi originales en el archivo iwlwif.conf (puede no ser necesario restaurar los comandos originales en el archivo iwlwifi.conf ) en /etc/modprobe.d/iwlwifi.conf y pegar esta línea al final:

options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1

Para restaurar el archivo, puede crear un nuevo archivo de texto en sus documentos denominado iwlwifi.conf y agregar las líneas de comando:

# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1

Luego guarde el documento y ejecute konsole e ingrese los comandos

sudo cp /home/[replaceyourusernamehere]/Documents/iwlwifi.conf /etc/modprobe.d/iwlwifi.conf

Después de eso, mi wifi comenzó a funcionar más rápido que antes cuando ingresé:

options iwlwifi 11n_disable=1

Nota: lo anterior funcionó para mí donde copié el archivo usando superusuario. No hice esta parte a continuación, pero puede que funcione o no.

Es posible que aún deba ejecutar los comandos como:

echo options options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1 | sudo tee /etc/modprobe.d/iwlwifi.conf
sudo modprobe -rfv iwlwifi
sudo modprobe iwlwifi
apt-get update

Todavía estaba recibiendo el módulo de error iwlwifi estaba en uso cuando corrí anteriormente:

sudo modprobe -rfv iwlwifi.

Avíseme si esto funciona para usted o no en los comentarios.

    
respondido por el David V. 07.11.2015 - 06:02
1

Abra una terminal ( Alt + Ctrl + T ) y escriba:

sudo modprobe -r iwlwifi
sudo modprobe iwlwifi 11n_disable=1

Ahora verifica si las velocidades han mejorado. Si es así, hagámoslo permanente.

  1. Abrir /etc/modprobe.d/iwlwifi_disable11n.conf como superusuario, e. g.:

    gksudo gedit /etc/modprobe.d/iwlwifi_disable11n.conf
    
  2. Agregue la siguiente línea al final del archivo:

    options iwlwifi 11n_disable=1
    
  3. ¡Después de eso, guárdalo y sal de ahí!

En caso de que obtenga un error como

ERROR: Removing 'iwlwifi': No such file or directory

reemplace iwlwifi con iwlagn en los comandos anteriores e inténtelo de nuevo.

    
respondido por el Mukund 20.12.2012 - 16:47
0

Después de varios años de no poder utilizar 801.11n en mi computadora portátil. ¡Encontré una solución que realmente soluciona este problema! Esta parece ser la mejor solución posible porque todavía puedes usar bluetooth, y también acceder a redes a través de 801.11n sin ningún problema (obtengo ~ 70Mbps).

Ingrese los siguientes comandos en una terminal:

echo options iwlwifi bt_coex_active=0 swcrypto=1 11n_disable=8 | sudo tee /etc/modprobe.d/iwlwifi-disable11n.conf

sudo modprobe -r iwlwifi

sudo modprobe iwlwifi

Aquí hay una explicación de lo que estamos haciendo:

  • swcrypto=1 cambia el cifrado de hardware para el cifrado del software.
  • bt_coex_active=0 desactiva la función de autointerferencia entre Bluetooth y wifi desactivado; esta es probablemente la verdadera causa de los problemas.
  • 11n_disable=8 habilita la agregación TX AMPDU.

Lo que bt_coex_active realmente hace cuando está habilitado es esencialmente "silenciar" el wifi cada vez que el sistema piensa que se está utilizando la frecuencia bluetooth, pero en implementaciones defectuosas, supone que el bluetooth siempre está transmitiendo, lo que limita el wifi permanentemente.

La mayoría de las personas opta por cambiar el archivo predeterminado /etc/modprobe.d/iwlwifi.conf , pero personalmente prefiero ponerlo en un archivo separado para que se pueda deshacer si es necesario. Si probó ajustes previos, verifique que su archivo se revierte a la configuración predeterminada. Para la mina de referencia es (en Ubuntu 16.04):

# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

Si esto no funciona para ti, ejecuta:

sudo rm /etc/modprobe.d/iwlwifi-disable11n.conf

Fuentes:

  • enlace
  • centrino-6235-congelación lenta

enlace

Mi uso (su kilometraje puede variar):

  • OS: Ubuntu 16.04 (también funcionará en versiones más nuevas y más antiguas)
  • Hardware: Intel Corporation Centrino Wireless-N 1000 [Condor Peak] (pero funcionará en modelos similares, por ejemplo, Intel Centrino 6235)
respondido por el hazrpg 23.05.2017 - 01:15

Lea otras preguntas en las etiquetas