Quiero instalar libssl.0.9.8

20

Estoy intentando instalar el programa utorrent, y cuando ejecuto el programa obtengo

./utserver: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory

Estoy navegando por los diferentes foros desde ayer y no encontré nada útil hasta ahora, así que por favor dime ¿cuál es el problema?

    
pregunta Muhammad Jawabreh 08.11.2011 - 20:05

4 respuestas

16

En general, debe buscar software a través del centro de software o si le gusta la línea de comando, puede usar apt-cache search . En este caso, apareció el siguiente paquete (en 11.10): libssl0.9.8

Puede intentar instalarlo ( sudo apt-get install libssl0.9.8 ). Si esto no ayuda, puede decirnos qué versión de Ubuntu está utilizando.

    
respondido por el xubuntix 08.11.2011 - 20:32
7

Si usa 11.10 (dado que no lo mencionó), tiene libssl1.0.0 que es mayor que 0.9.8. Cualquier programa que necesite 0.9.8 también podrá manejar versiones anteriores a esa.

Si NO tienes 11.10, entonces tienes varias formas:

  1. Vaya al sitio de OpenSSL: enlace y siga las instalaciones allí.

  2. Vaya a los paquetes de Ubuntu y descargue .DEB desde allí: enlace

  3. Vaya a Paquetes de Debian y descargue .DEB desde allí: enlace

  4. Instálelo a través de apt-get o aptitude :

    • sudo apt-get install libssl0.9.8 - Para la versión 0.9.8
    • sudo aptitude install libssl0.9.8 - Para la versión 0.9.8
    • sudo apt-get install libssl1.0.0 - Para la versión 1.0.0
    • sudo aptitude install libssl1.0.0 - Para la versión 1.0.0
respondido por el Luis Alvarado 08.11.2011 - 20:35
7

En Ubuntu 12.04 versión de 64 bits, funcionó para instalar la versión de 32 bits:

sudo apt-get install libssl0.9.8:i386

Pero, por supuesto, cuando usas Ubuntu de 32 bits, esto debería funcionar (sin el :i386 ):

sudo apt-get install libssl0.9.8
    
respondido por el ayke 10.02.2013 - 23:44
0

Solo prueba estos pasos cuando lo necesites para CAV para Linux.

Si ya intentó instalar cav pero hay un error con Libssl0.9.8:

  1. sudo apt-get --purge remove cav-linux
  2. Desinstale todos los libssl0.9.8 de / con Synaptic
  3. sudo apt-get clean
  4. sudo apt-get autoremove
  5. sudo aptitude install libssl0.9.8

y luego instálalo de la manera normal.

  1. Crear un directorio /opt/COMODO

    Copie el archivo cav allí:

    cd /opt/COMODO
    sudo dpkg -i cav-linux_1.1.268025-1_amd64.deb
    
  2. Descargar el controlador y reconstruir el controlador

    cópialos a /opt/COMODO

    ejecutar configuración de publicación:

    sudo /opt/COMODO/post_setup.sh
    
  3. Ejecuta esto solo si obtienes un error de que los módulos de RedirFS no están instalados

    sudo bash /opt/COMODO/fix_rebuild_driver.sh
    sudo /opt/COMODO/post_setup.sh
    
  4. Reiniciar

respondido por el JDoerr 28.08.2016 - 08:10

Lea otras preguntas en las etiquetas