Las teclas de volumen funcionan en unidad, pero no en xfce4

20

Mis teclas de volumen no funcionan en xfce. Cuando los usé, muestra una indicación en la pantalla de que se está cambiando el volumen, pero el volumen no está cambiando (lo mismo con la tecla de silencio).

Lo extraño es que cuando paso de xfce a ubuntu, las claves funcionan bien ahora.

No sé si esto importa, pero tengo una tarjeta de sonido en mi computadora.

¿Cómo puedo hacer que las teclas de volumen funcionen en xfce?

    
pregunta skeept 15.05.2012 - 16:26

8 respuestas

14

Esto todavía está roto en 12.10. Puede solucionarlo instalando xfce4-mixer y luego seleccionando manualmente los mezcladores para controlarlo, y luego accediendo al editor de configuraciones xfce4 y escribiendo el nombre de la "tarjeta activa". El botón de silencio aún no funciona correctamente, puede silenciar pero no activar el sonido con él. Sin embargo, todo lo demás funciona, incluso en las notificaciones en pantalla. Es realmente complicado hacer que todo funcione, así que abrí un error: enlace

En detalle, en xfce4-mixer quieres que luzca algo como esto:

Esto debería mostrar solo el control de volumen principal de su tarjeta de sonido. Debe elegir una tarjeta de sonido en la parte superior y luego hacer clic en "Seleccionar controles ..." para agregar controles. Luego, en el editor de configuraciones xfce4, debe configurar la "tarjeta activa" de esta manera:

En "tarjetas de sonido", verá una lista de todas las tarjetas de sonido para las que agregó mezcladoras. Es probable que tenga varias tarjetas, por lo que puede llevar algo de prueba y error para encontrar la correcta. Debe copiar el nombre de la tarjeta correcta de "tarjetas de sonido" a "tarjeta activa"; este será el mezclador controlado por los botones de volumen.

    
respondido por el Alistair Buxton 03.12.2012 - 00:20
5

xfce4-volumed solo funciona para mí cuando no se ejecuta en modo daemon. Las claves de volumen me funcionan cuando ejecuto este comando para eliminar cualquier proceso volum existente y comenzar uno nuevo que no se ejecuta en modo daemon:

kill 'pidof xfce4-volumed' ; mkdir -p /tmp/volumed && cd /tmp/volumed && nohup xfce4-volumed --no-daemon &

Esto ejecuta el proceso usando nohup, por lo que el terminal en el que ejecuta este comando se puede cerrar sin matar el proceso.

    
respondido por el Stephen Ostermiller 20.02.2014 - 21:52
4

Esas teclas de volumen están basadas en gnome ... o basadas en la unidad o lo que sea ... Tienes que crear un atajo de teclado personalizado en la configuración del teclado para reducir, aumentar y silenciar el volumen ... Para aumentar el volumen, el comando es "amixer set master 5% +" para la disminución de volumen "amixer set master 5% -" para silenciar "amixer set master toggle"

    
respondido por el Arpit Roopchandani 19.05.2012 - 07:05
1

Tuve el mismo problema en Xubuntu 12.04, aunque no sé si hubiera funcionado en Unity, ya que solo tengo Xfce4. En terminal, escriba:

$ xfconf-query -c xfce4-mixer -p /active-card -s xfconf-query -c xfce4-mixer -p /sound-card

Fuente: enlace

    
respondido por el MrPink 06.06.2012 - 23:44
1

Si se trata de un problema temporal, como en mi caso, simplemente hazlo en línea de comandos:

killall xfce4-volumed && xfce4-volumed

    
respondido por el Felipe 17.12.2015 - 16:56
0

Solucioné el problema cambiando el parámetro "Tarjeta activa" en el editor de configuración xfce4

Tengo dos tarjetas de sonido (una HDMI y la otra normal) y la tarjeta seleccionada era diferente de la tarjeta normal que estaba usando.

    
respondido por el Damiano 30.12.2012 - 16:19
0

También tenía este problema muy extraño, podía ajustar el deslizador de volumen en el menú y no haría nada. Además, si intentaba ajustarlo con mi teclado, el control deslizante se movería, pero nada cambiaría con el volumen real.

Lo arreglé yendo a PulseAudio Volumne Control . En el panel Output Devices , puede ver todas las opciones de su tarjeta de sonido. A partir de ahí, me aseguré de que el puerto estuviera configurado en Salida analógica. En su caso, podría ser HDMI o auriculares dependiendo de dónde quiera que vaya su sonido. Luego seleccione la opción 'establecer como alternativa'. Parece una marca de verificación verde.

no tuve que instalar xfce4-mixer para que esto funcione.

    
respondido por el John 27.12.2014 - 20:27
0

En Settings > Settings Manager > Keyboard > Applications Shortcut :

  • agregue amixer set Master 3+ para aumentar el volumen
  • agregue amixer set Master 3- para disminuir el volumen
  • agregue amixer -D pulse set Master Playback Switch toggle para silenciar / activar el sonido
respondido por el dr0i 09.03.2017 - 07:53

Lea otras preguntas en las etiquetas