No se puede instalar Skype 4.3 en Ubuntu 14.04 64 bit

19

En primer lugar, creo que esta pregunta no está duplicada, porque he intentado todas las demás soluciones que encontré aquí, pero nada resolvió mi problema.

Uso Ubuntu 14.04 de 64 bits.

Lo he intentado hasta ahora: sudo apt-get install skype - & gt; No funcionó. El error fue:

The following packages have unmet dependencies:
skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.

Probé sudo dpkg add-architecture & amp; & amp; sudo dpkg -i skype-ubuntu-precise_4.3.0.37-1_i386.deb pero tampoco funcionó. El error fue:

dpkg: dependency problems prevent configuration of skype:
skype depends on libqt4-dbus (>= 4:4.5.3); however:
Package libqt4-dbus is not installed.
skype depends on libqt4-network (>= 4:4.8.0); however:
Package libqt4-network:i386 is not installed.
skype depends on libqt4-xml (>= 4:4.5.3); however:
Package libqt4-xml:i386 is not installed.
skype depends on libqtcore4 (>= 4:4.7.0~beta1); however:
Package libqtcore4:i386 is not installed.
skype depends on libqtgui4 (>= 4:4.8.0); however:
Package libqtgui4:i386 is not installed.
skype depends on libqtwebkit4 (>= 2.2~2011week36); however:
skype depends on libstdc++6 (>= 4.2.1); however:
Package libstdc++6:i386 is not installed.
skype depends on libx11-6; however:
Package libx11-6:i386 is not installed.
skype depends on libxext6; however:
Package libxext6:i386 is not installed.
skype depends on libxss1; however:
Package libxss1:i386 is not installed.
skype depends on libxv1; however:
Package libxv1:i386 is not installed.
skype depends on
dpkg: error processing package skype (--install):
dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1) ...
Errors were encountered while processing:
skype

Intenté usar después de sudo apt-get -f install pero no resolvió.

Intenté instalar usando Gdebi . El error fue:

Cannot install 'libqtwebkit4:i386'

Intenté instalar usando Ubuntu Software Center . El error fue:

Cannot install 'libqtwebkit4:i386'

He intentado cambiar el servidor en "Softwares y actualizaciones". He intentado usar "Servidor principal" y "Servidores para Estados Unidos". Pero no pudo resolver mi problema.

¿Alguien tiene alguna idea de cómo resolver eso?

SOLUCIONADO

Bueno, formateé mi PC y primero instalé Skype. Probablemente otra instalación que había hecho antes de la instalación de Skype era el problema, supongo.

¡Gracias a todos!

    
pregunta z_inx 30.07.2014 - 18:29

9 respuestas

32

Estoy ejecutando 14.04 64 bits, así es como lo instalé.

Skype 4.3 descargado de aquí y yo usó Gdebi, para instalarlo, y lo instaló bien. si no tiene instalado Gdebi, simplemente presione Ctrl + Alt + T en su teclado para abrir Terminal. Cuando se abra, ejecute los comandos a continuación:

sudo apt-get install gdebi

Como dije, no he tenido ningún problema con el método indicado anteriormente. Otra cosa que puede hacer para arreglar paquetes rotos, puede hacer

sudo apt-get clean && sudo apt-get update
sudo apt-get upgrade

O

Vaya al administrador de paquetes sináptico si lo tiene instalado, vaya a Editar - & gt; Reparar paquetes rotos.

Una forma alternativa de instalarlo es

sudo dpkg --add-architecture i386
sudo apt-get update
wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb

Después de esto, si obtiene algún error como que no puede instalar 'libqtwebkit4: i386' o algún otro paquete, intente con este comando.

     sudo apt-get upgrade --fix-missing

Te sugerirá que pruebes el siguiente comando.

    sudo apt-get -f install

Después de ejecutar el comando anterior, intente con el siguiente una vez más.

sudo dpkg -i skype-install.deb

Para obtener más información, consulte el foro oficial de Skype aquí .

Espero que esto te ayude :)

    
respondido por el Mitch 30.07.2014 - 18:44
4

Primera ejecución:

sudo apt-get install -f

para instalar las tareas relacionadas con el sistema operativo 14.04LST de 64 bits y luego probar debajo de los comandos ... skype 4.3 se instala perfectamente

sudo dpkg --add-architecture i386
sudo apt-get update
wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb

Me funcionó ... ;;;; :)

    
respondido por el suri 05.08.2014 - 14:13
2

Ejecución de los siguientes comandos:

sudo apt-get clean && sudo apt-get update
sudo apt-get upgrade

Resolvió el problema para mí.

    
respondido por el nick 05.08.2014 - 12:26
2

Pasos:

sudo sh -c "echo 'deb http://archive.canonical.com/ubuntu/ trusty partner' >> /etc/apt/sources.list.d/canonical_partner.list"
sudo apt-get update
sudo apt-get install skype
    
respondido por el John Foley 21.10.2014 - 20:54
1

Me encontré con el mismo problema al incluir Skype 4.3 en Ubuntu 13.10. Sin embargo, al seguir las instrucciones anteriores, Skype 4.2 siempre se muestra, incluso al eliminar Skype antes de descargar la versión más nueva. Para que funcione, tuve que eliminar el archivo de configuración .Skype en mi directorio personal:

rm -r ~/.Skype

No se preocupe, no perderá sus contactos o cualquier otra cosa. La única molestia es que puedo ver que al principio algunos de tus contactos aparecerán con su nombre de skype y no con el nombre completo familiar.

    
respondido por el Marc Corluy 25.08.2014 - 10:59
1

En mi caso, tengo el mismo problema al no seguir el principio RTFM :) Instalé algunos paquetes de xorg-edgers y luego no los eliminé correctamente como se dice en el comentario de la instalación (es decir, simplemente eliminé el repositorio pero no los paquetes instalados). Esto causó un efecto dominó que llevó a que no se puedan instalar los paquetes dependientes de la biblioteca i386 ...

Lo he encontrado al intentar instalar paquetes con aptitude que detallan directamente los problemas (diferentes versiones de paquetes de 64 bits). Luego, agregué el repositorio de xorg-bordeadores y lo eliminé correctamente con:

sudo apt-get install ppa-purge
sudo ppa-purge xorg-edgers

Espero que ayude a alguien ...

    
respondido por el Karel Lenc 25.08.2014 - 17:42
1

Solucioné este mismo problema al habilitar "Actualizaciones recomendadas (actualizaciones de confianza)" en el panel de control "Actualizaciones de software" y en la pestaña "Actualizaciones".

    
respondido por el Douglas Held 24.11.2014 - 18:04
0

Actualicé a la versión 4.3.0.37 porque la versión 4.2.0.13 no me permitía volver a iniciar sesión con el error "No se puede conectar" .

Desafortunadamente para mí después de horas de intentarlo no pude hacer que pulseaudio funcionara en mi sistema, solo ALSA está funcionando, así que volví a bajar a 4.2.0.13

Para resolver el error de inicio de sesión, falsifiqué el número de versión 4.2.0.13 con la última versión 4.3.0.37 y el inicio de sesión volvió a funcionar, problema resuelto.

Para resolver su problema simplemente vuelva a bajar de categoría a 4.2.0.13 y suplante a la versión 4.3.0.37 , salga de Skype y ejecute este comando:

sudo sed -i "s/\x34\x2E\x32\x2E\x30\x2E\x31\x33/\x34\x2E\x33\x2E\x30\x2E\x33\x37/g" /usr/bin/skype

Después de que deberías poder iniciar sesión como siempre.

    
respondido por el mikelinux 12.08.2014 - 07:03
0

Para aquellos que probaron todo lo anterior pero aún luchan (como yo):

El problema podría ser solo el servidor que usa para su actualización de Ubuntu (fue en mi caso). El servidor que estaba usando no tenía la definición correcta de libqtwebkit4:i386 .

Para resolver eso:

  • Abrir configuración del sistema
  • Software y amp; Actualizaciones
  • pestaña de Software de Ubuntu
  • Descargar desde (Otro ... y seleccionar el mejor servidor)

Actualiza tu sistema con sudo apt-get update y luego:

wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb

Funcionó para mí.

    
respondido por el Raphael_b 15.05.2015 - 16:17

Lea otras preguntas en las etiquetas