Molesto parpadeo en 16.04 LTS - Chrome

196

Me actualicé de 4.4.0 a 4.4.8 y luego a 4.5.2 en Ubuntu 16.04 LTS de 64 bits, y todavía está sucediendo.

En 4.5.2 es aún más frecuente, y principalmente en Chrome (aún no he probado Firefox u Opera). Cada vez que abro una nueva página web. ¿Alguna forma de solucionar eso o es un error?

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
04:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Venus XTX [Radeon HD 8890M / R9 M275X/M375X] (rev 81)

Saludos.

    
pregunta Mookey 03.05.2016 - 08:31

11 respuestas

186

Después de algunas investigaciones, encontré una solución a este problema. Me funciona ahora.

Inhabilité la aceleración de hardware para mi navegador desde

Settings > Advance Settings > System > uncheck the hardware acceleration

Espero que esto funcione en tu máquina.

Estoy usando google-chrome-stable Version 50.0.2661.94 (64-bit) en Ubuntu 16.04

----- EDITAR ----

Si te encuentras con un desfase de desplazamiento y una rotura de pantalla. Haga lo que sugiere Amos Folarin en el comentario a continuación:

Vaya a: chrome://flags/#smooth-scrolling y habilítelo.

    
respondido por el sgiri 05.05.2016 - 19:54
158

Tuve el mismo problema, la configuración de rasterización de GPU en "Force-enabled for all layers" parece estar funcionando:

    
respondido por el Gondy 08.08.2016 - 09:52
38

Abre una terminal e ingresa este comando:

sudo nano /usr/share/applications/chromium-browser.desktop

y desplácese hacia abajo hasta llegar a esta línea:

Exec= chromium-browser

A continuación, agregue estos dos parámetros

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

Presione Ctrl + O para guardar y Ctrl + X para salir.

Luego ingrese este comando:

sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf

y agregue estas líneas

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

Presione Ctrl + O y luego Ctrl + X.

Abre Chromium y escribe en la barra de direcciones: chrome://flags/ e intro.

  • Habilitar-copia cero
  • Habilitar la anulación de la lista de reproducción de software
  • Habilitar visualización del lienzo de la lista 2D

Finalmente, abra la configuración de Chrome y haga clic en:

  • Utilice la aceleración de hardware cuando esté disponible
respondido por el zafer 27.07.2016 - 10:10
37

Lo arreglé de la siguiente manera:

sudo apt-get purge xserver-xorg-video-intel

luego reinicie. Esto se debe a que los controladores de Intel se movieron a la configuración del modo. Para obtener más información, consulte este comentario en el hilo de error de Chromium .

    
respondido por el ComBin 19.08.2016 - 16:25
24

Ninguna de estas respuestas pareció ayudarme. Lo que terminé haciendo que parece que lo ha arreglado (Mi referencia era este sitio enlace que parpadeaba como CRAZY y ahora funciona sin problemas) es este:

1.- Navegado a chrome://gpu/ . Esto es lo que mostró:

2.- Intenté solucionar los problemas uno por uno. En mi caso, al habilitar estos indicadores se corrigieron algunos de ellos: GPU rasterization , Override software rendering list . Entonces se mostró así:

3.- Edité el iniciador de escritorio y agregué los parámetros --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers .

4.- Después de eso, no se detectaron más problemas, todo se muestra como "hardware acelerado" y, lo que es más importante, no parpadea más:

Si agrega primero los parámetros al iniciador, la lista de problemas debería ser más corta y probablemente sea más fácil determinar qué indicadores le ayudarán con los problemas que le quedan.

    
respondido por el Nahuel 14.09.2016 - 14:29
7

Con la versión de Chrome 51.0.2704.103 (64 bits), los indicadores

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

ya no funciona.

La mejor forma en que podemos hacer es retroceder a Chrome 50 (Versión 50.0.2661.86 (64-bit)), aquí hay una instrucción de cómo puede retroceder: ¿cómo puedo degradar google chrome?

Importante es que presionamos a Google para que solucione este problema, votemos por el error en Chromium y en la página del producto de google:

enlace

enlace

    
respondido por el user157697 19.06.2016 - 10:02
5
chrome://flags/ > GPU rasterization > Enable,

¡Esto finalmente funcionó para mí! ¡Lo encontré en la parte inferior de este formulario de Google! enlace

    
respondido por el Chris Lane Jones 16.10.2016 - 22:44
4

Creo que encontré la solución:

flags --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers y también enable-zero-copy ENABLE

    sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf
    Section "Device"
       Identifier  "Intel Graphics"
       Driver      "intel"
       Option      "AccelMethod"  "sna"
       Option      "TearFree"    "true"
       Option      "DRI"    "3"
    EndSection
    
respondido por el Hector 07.07.2016 - 17:14
2

Intente cargar con algunas opciones de GPU deshabilitadas:

- disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

Después de probar eso, también puedes jugar con algunas de las configuraciones de renderizado en about: // flags y ver si hay algo que ayude, pero la mayor parte de mis parpadeos de renderizado fueron resueltos por los dos indicadores de línea de comando. Si tiene un archivo launcher .desktop, agregue esos indicadores a la entrada superior de Exec antes del '% U'. También puede agregarlos a las otras entradas de Exec para que los indicadores se apliquen a todos los modos de inicio.

    
respondido por el MattCole3 04.05.2016 - 17:44
2

Descubrí que las correcciones actuales no funcionan para la versión actual de Chrome, es necesario cambiar otras cosas (al menos para mi configuración).

Puedo confirmar que esto funciona (elimina el parpadeo y el desgarro), gracias a enlace

Computadora: XPS13 9343 Gráficos: 00: 02.0 Controlador compatible con VGA: Intel Corporation Broadwell-U Integrated Graphics (rev 09) Versión de Chrome: versión 54.0.2840.100 (64 bits)

Configuración

1) Verifique los mensajes de error antes y después de los ajustes de configuración a continuación

  • chrome: // gpu
  • toma una captura de pantalla para que puedas comparar después.

2) Editar (para Chrome): /usr/share/applications/google-chrome.desktop o para (cromo): /usr/share/applications/chromium-browser.desktop

  • Agregue las banderas --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers
  • línea debería verse así: Exec=/usr/bin/google-chrome-stable --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers %U

3) sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf agregue esto (puede que necesite crear el archivo):

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

4) Configuración de los indicadores de Chrome: chrome: // flags:

  • Activar ("rasterizador de copia cero"): chrome: // flags / # enable-zero-copy
  • Habilitar (habilitar el lienzo 2d de la lista de visualización): chrome: // flags / # enable-display-list-2d-canvas
  • Activar ("Anular lista de reproducción de software"): chrome: // flags / # ignore-gpu-blacklist
  • Activar "Lienzo 2D de la lista de visualización"): chrome: // flags / # enable-display-list-2d-canvas
  • Activar (indicador de cromo para un desplazamiento suave en Linux): chrome: // flags / # desplazamiento suave

5) Mantuve la configuración de Chrome & gt; Avanzado & gt; Use Hardware Acceleration cuando esté disponible [ keep checked ]. Si desactivas este realmente rendimiento de éxitos (aunque reduce el parpadeo pero no el desgarro), las opciones anteriores funcionaron mucho mejor para mí.

6) Reinicia la computadora.

7) Comparar configuraciones. chrome: // gpu

Esto eliminó totalmente el parpadeo y el desgarro para mí.

    
respondido por el Amos Folarin 15.02.2017 - 15:27
1

La desactivación de la aceleración del hardware degradará el rendimiento de su navegador para las páginas que tengan animaciones y otras tareas intensivas del procesador.

Sin embargo, si no tiene ninguna GPU instalada en su sistema, entonces el enfoque de deshabilitar la aceleración de hardware sugerido por sgiri es mejor para ti.

Pero tengo una GPU NVidia instalada en mi computadora portátil y estoy usando el sistema operativo de escritorio Ubuntu. Entonces instalé el controlador binario patentado (versión 352.63). Me funcionó, la esperanza también funcionará en tu sistema Ubuntu.

    
respondido por el user4128091 23.08.2016 - 08:50

Lea otras preguntas en las etiquetas