¿Dónde puedo encontrar un binario de Subversion 1.7?

84

¿Alguien sabe de una fuente de ppa o puedo obtener una subverison 1.7 deb?

Acaba de salir ayer, así que estoy seguro de que algo aparecerá eventualmente. Sin embargo, creo que este será un buen lugar para publicar cuando se publique algo.

    
pregunta Ryu 12.10.2011 - 16:37

6 respuestas

62

A partir de Ubuntu 12.10, subversión 1.7 está disponible como parte de la distribución. Subversion se puede instalar usando apt-get.

sudo apt-get install subversion

Para versiones anteriores de Ubuntu, hay un ppa disponible en subversion-1.7 . El repositorio se puede agregar de la siguiente manera:

sudo apt-add-repository ppa:dominik-stadler/subversion-1.7

Para obtener la última versión de la actualización de subversión y actualizar el repositorio.

sudo apt-get update
sudo apt-get upgrade

También necesitaba hacer una actualización de dist.

sudo apt-get dist-upgrade

Supongo que ya tiene subversión instalada, de lo contrario:

sudo apt-get install subversion
    
respondido por el Richard Povinelli 17.11.2011 - 02:24
44

También hay un ppa admitido directamente por el equipo de subversión: Equipo de "Subversion" .

Debería poder agregar el ppa con el siguiente comando:

sudo apt-add-repository ppa:svn/ppa

El comando apt-add-repository lo proporciona el paquete python-software-properties, así que asegúrese de instalarlo primero.

Nota: RabbitVCS parece tener un problema con Subversion 1.7: Rabbitvcs no marca como subfodlers versionados / archivos en svn 1.7 . Esto se soluciona en el tronco, pero aún no se ha insertado en una compilación.

    
respondido por el Waylon Flinn 30.07.2012 - 21:17
14

El script de Wandisco realmente instala un nuevo repositorio que contiene el archivo .deb para instalar SVN 1.7.

Casi lo mismo se puede lograr ejecutando los siguientes comandos:

sudo add-apt-repository 'deb http://opensource.wandisco.com/ubuntu lucid svn17'
sudo wget -q http://opensource.wandisco.com/wandisco-debian.gpg -O- | sudo apt-key add -    
sudo apt-get update    
sudo apt-get install subversion
    
respondido por el Fernando 23.10.2011 - 19:16
1

Cuando usa Trac, puede notar un problema después de actualizar su Subversion usando el repositorio de WANdisco. Su síntoma es un mensaje en el sitio de Trac:

  

Advertencia: no se puede sincronizar con el repositorio "(predeterminado)" (No compatible)   sistema de control de versiones "svn": ningún módulo llamado svn). Mire en el Trac   regístrese para obtener más información.

Este paquete enlaza svn a python2.6 y Ubuntu 12.04 tiene python2.7. Aquí hay un script que resolvió el problema de mi lado:

mkdir /usr/lib/python2.7/dist-packages/libsvn
for f in /usr/lib/pyshared/python2.6/libsvn/*; do ln -s $f /usr/lib/python2.7/dist-packages/libsvn/; done
for f in /usr/share/pyshared/libsvn/*; do ln -s $f /usr/lib/python2.7/dist-packages/libsvn/; done

mkdir /usr/lib/python2.7/dist-packages/svn
for f in /usr/share/pyshared/svn/*; do ln -s $f /usr/lib/python2.7/dist-packages/svn/; done

mkdir /usr/lib/pyshared/python2.7/libsvn
for f in /usr/lib/pyshared/python2.6/libsvn/*; do ln -s $f /usr/lib/pyshared/python2.7/libsvn/; done
    
respondido por el Wojciech Dec 19.06.2012 - 13:59
1

Utilicé los binarios de Wandisco con fuentes de apt como Fernando describió, pero ahora que la próxima versión de Ubuntu tiene binarios oficiales actualizados a 1.7, quería usarlos mientras sigo con 12.04 LTS.

Agregó las siguientes fuentes a un nuevo archivo /etc/apt/sources.list.d/svn17.list:

deb http://archive.ubuntu.com/ubuntu/ quantal main universe
deb-src http://archive.ubuntu.com/ubuntu/ quantal main universe

Y de acuerdo con los consejos sobre enlace y /etc/apt/apt.conf.d/90svn17:

APT::Default-Release "precise";

Luego se instaló usando

sudo apt-get install -V subversion -t quantal

No estoy seguro de si estos nuevos nombres de archivo siguen las convenciones adecuadas, pero funciona. Intenté fijar la configuración primero pero sin suerte. Con "-t quantal" no era necesario realizar un pinning.

    
respondido por el solsson 22.09.2012 - 12:29
0

No crea que todavía hay disponible .deb público. Puede probar este script para instalar 1.7 desde WANdisco

svn1.7_ubuntu_wandisco.sh

#!/bin/bash +x
# WANdisco Subversion Installer V0.1
# opensource@wandisco.com

echo WANdisco Subversion Installer v0.1 for Ubuntu 9.10, 10.04, 10.10
echo Please report problems and bugs to opensource@wandisco.com
echo 
echo Gathering some information about your system...

MINVERSION='1'
SVNVER='1.7.0'
ARCH='uname -m'
SVNSTATUS='dpkg -l|grep " libsvn1 " | awk '{print }''

#functions
check_is_root ()
{
    if [[ $EUID -ne 0 ]]; then
        echo "This script must be run as root" 1>&2
        exit 1
    fi  
}
svn_remove_old ()
{
    echo Removing old packages...
    apt-get -y remove libsvn1 subversion libapache2-svn libsvn-dev libsvn-doc libsvn-perl subversion-tools 
}
add_repo_config ()
{
        echo Adding repository configuration to /etc/apt/sources.list.d/
    if [ -f /etc/apt/sources.list.d/WANdisco.list ]; then
        rm /etc/apt/sources.list.d/WANdisco.list
    fi
    echo "Installing Apt repo...."
    echo "# WANdisco Open Source Repo" > /etc/apt/sources.list.d/WANdisco.list
    echo "deb http://opensource.wandisco.com/ubuntu lucid svn17" >> /etc/apt/sources.list.d/WANdisco.list
        echo "Importing GPG key"
        wget http://opensource.wandisco.com/wandisco-debian.gpg -O /tmp/wandisco-debian.gpg &>/dev/null
        apt-key add /tmp/wandisco-debian.gpg
        rm -rf /tmp/wandisco-debian.gpg
        apt-get update
}
install_svn ()
{
        echo Checking to see if you already have Subversion installed via dpkg...
        if [ "$SVNSTATUS" == "ii" ]; then
        echo
            echo Subversion is already installed on the system.
            echo Do you wish to replace the version of subversion currently installed with the WANdisco version? 
        echo This action will remove the previous version from your system.
        echo -n "[y/N]: "
        read svn_install_confirm
        if [ "$svn_install_confirm" == "y" -o "$svn_install_confirm" == "Y" ]; then
            svn_remove_old
            add_repo_config
            echo        
            echo Installing Subversion $SVNVER-$MINVERSION
            echo
            apt-get -y --force-yes install subversion libsvn-perl subversion-tools
            echo -n "Would you like to install apache and the apache SVN modules? [y/N] "
            read dav_svn_confirm
            if [ "$dav_svn_confirm" == "y" -o "$dav_svn_confirm" == "Y" ]; then
                echo Installing apache and subversion modules
                apt-get -y --force-yes install apache2 libapache2-svn
                echo -n "Installation complete. Restart apache? [y/N] "
                read apache_restart_confirm
                if [ $apache_restart_confirm == "y" -o $apache_restart_confirm == "Y" ]; then
                    /etc/init.d/apache2 restart 
                fi
            fi

            else
            echo "Install Cancelled"
            exit 1
            fi

    else
        # Install SVN
        echo "Subversion is not currently installed"
        echo -n "Starting installation, are you sure you wish to continue? [y/N] "
        read svn_install_confirm
                if [ "$svn_install_confirm" == "y" -o "$svn_install_confirm" == "Y" ]; then
            add_repo_config
                        echo
                        echo Installing Subversion $SVNVER-$MINVERSION
                        echo
                        apt-get -y --force-yes install subversion libsvn-perl subversion-tools
                        echo -n "Would you like to install apache and the apache SVN modules? [y/N] "
                        read dav_svn_confirm
                        if [ "$dav_svn_confirm" == "y" -o "$dav_svn_confirm" == "Y" ]; then
                                echo Installing apache and subversion modules
                                apt-get -y --force-yes install apache2 libapache2-svn libsvn-dev
                                echo -n "Installation complete. Restart apache? [y/N] "
                                read apache_restart_confirm
                                if [ $apache_restart_confirm == "y" -o $apache_restart_confirm == "Y" ]; then
                                        /etc/init.d/apache2 restart
                                fi
                        fi

                else
                        echo "Install Cancelled"
                        exit 1
                fi

        fi

}

install_32 ()
{
        echo Installing for $ARCH
    install_svn
}
install_64 ()
{
        echo Installing for $ARCH
    install_svn
}

#Main
check_is_root

echo Checking your system architecture.
if [ "$ARCH" == "i686" -o "$ARCH" == "i386" ]; then
    install_32
elif [ "$ARCH" == "x86_64" ];
then
    install_64
else 
    echo Unsupported platform: $ARCH
    exit 1
fi
    
respondido por el Thermionix 20.10.2011 - 06:32

Lea otras preguntas en las etiquetas