Conectar / desconectarse de VPN desde la línea de comando

114

Tengo dos configuraciones de VPN en mi máquina Ubuntu, una usando vpnc y una usando PPTP. Estos se configuraron utilizando la interfaz del administrador de red de GNOME y funcionaron muy bien. Sin embargo, en ocasiones, necesito acceder a esta máquina de forma remota. ¿Existe alguna forma de conectar o desconectar estas VPN desde la línea de comandos?

    
pregunta Tim Fountain 16.08.2011 - 17:15

2 respuestas

165

Si desea interactuar con NetworkManager desde la línea de comandos, puede usar el comando "nmcli".

listar todas las conexiones NM: nmcli con

iniciar conexión (wifi, vpn, etc.): nmcli con up id ConnectionName

conexión descendente: nmcli con down id ConnectionName

(más comandos de nmcli en página de manual de nmcli ).

También tenga en cuenta que los usuarios normales generalmente no tienen permiso para controlar la red. El uso de los comandos anteriores con sudo debería funcionar para la mayoría de las conexiones, pero VPN específicamente puede fallar con "Error: la activación de la conexión falló: no hay secretos VPN válidos".

Si eso le sucede a usted, es probable que la contraseña de VPN se almacene en el gnome-keyring de su usuario, lo que hace que sea inaccesible para el usuario root. Este comentario explica por qué.

Para solucionar esto, edite / etc / NetworkManager / system-connections / ConnectionName y debajo de [vpn] , cambie marcas de contraseña línea a:

password-flags=0

Si hay una línea que comienza con Xauth password-flags , cámbiela en su lugar.

Luego agregue lo siguiente debajo del bloque [vpn] :

[vpn-secrets]
password=YourPassword

(Si en el paso anterior cambió la línea Xauth password-flags , agregue Xauth password=... en su lugar)

Ahora reinicie el administrador de red mediante:

sudo service network-manager restart

Luego, comenzar la conexión VPN con sudo nmcli con up id ConnectionName debería funcionar sin problemas.

    
respondido por el ihashacks 17.08.2011 - 05:44
4

La respuesta de ihashacks con los comentarios de Matt funcionó para mí ... casi. Tenía que ajustar una línea.

la línea de mi marca de contraseña realmente se lee: "Xauth contraseña-bandera". La respuesta aceptada no funcionaría para mí hasta que cambié a la siguiente

[vpn]
...
Xauth password-flag=0
IPSec secret-flags=0

[vpn-secrets]
Xauth password=<my pw> ## This is the one I changed.
IPSec secret=<group pw>

No estoy seguro de por qué mis conexiones vpn tienen "Xauth" antes de cada mención de contraseña.

(Lo siento, esta es una nueva respuesta, aún no puedo hacer comentarios).

    
respondido por el John 23.03.2015 - 06:03

Lea otras preguntas en las etiquetas